Support multi-seat

Bug #593493 reported by Robert Ancell on 2010-06-14
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Low
Unassigned
Baltix
Undecided
Unassigned

Bug Description

Support multi-seat setup. This is (I think) when you run two sessions on a single X server (with two displays/keyboards/mice).

Changed in lightdm:
status: New → Triaged
importance: Undecided → Wishlist
Changed in lightdm:
importance: Wishlist → Low
summary: - Support multi-head setup
+ Support multi-seat
Robert Ancell (robert-ancell) wrote :

You can now specify multiple displays in the lightdm config (0.0.4)

Changed in lightdm:
status: Triaged → Fix Released

syntax example?

Robert Ancell (robert-ancell) wrote :

[LightDM]
displays=display0 display1

[display0]
...

[display1]
...

Only static configurations are supported at this time. Please open new bugs for new features that are required (e.g. per display configuration).

Tom De Caluwé (tom-de-caluwe) wrote :

This does not quite work on my system. LightDM uses the same screen for both "displays". Note that I'm using two different GPUs with each one connected monitor.

One way to solve this is to provde a way to pass extra options to X in the separate display sections in lightdm.conf. Like that I could pass different xorg.conf ServerLayouts by adding "-layout seat1" and -layout seat2.

Tom

Robert Ancell (robert-ancell) wrote :

Hi Tom,

Would -layout be the main flag required for the xserver? I'd like to make the config as simple as possible, e.g:

[display1]
xserver-layout=Layout1

[display2]
xserver-layout=Layout2

(I will also add xserver-additional-args and xserver-config for people needing more complicated configuration).

Changed in lightdm:
status: Fix Released → Triaged
Robert Ancell (robert-ancell) wrote :

OK, the version in master now has configuration like this:

[LightDM]
displays=display0 display1

[display0]
xserver=xserver0

[display1]
xserver=xserver1

[xserver0]
layout=layout0

[xserver1]
layout=layout1

Changed in lightdm:
status: Triaged → Fix Committed
Robert Ancell (robert-ancell) wrote :

You can also specify the default xserver in the LightDM section and more arguments if required, e.g.:

[LightDM]
xserver=default-xserver

[default-xserver]
command=/usr/bin/X -foo
config-file=/etc/X-foo.conf
layout=layout0

Tom De Caluwé (tom-de-caluwe) wrote :

This looks pretty good. Can't wait for the release!

Oli (oli) wrote :

Just a language clarification on the initial description: multi-seat and multi-head are not the same thing.

Multi seat:
 - Many users
 - One (or multiple) monitors per user, one keyboard, one mouse.
 - Each user laid out as a distinct server layout in xorg.conf
 - Each X "screen" should present a login screen

Multi head:
 - One user
 - Multiple hardware monitors
 - One server layout.
 - One X "screen" and one X "display" that spans these two monitors (though Xinerama might actually use two "displays").

It should be possible to have multi-head within multi-seat (eg two people on one system with two video cards, 4 monitors, two "screens", two "displays", two keyboards, two mice, etc)

Robert Ancell (robert-ancell) wrote :

Desciption updated, thanks Oli

description: updated
Tom De Caluwé (tom-de-caluwe) wrote :

Multi-seat now basically works in the new lightdm 0.4.0, however there is a very annoying glitch. Whenever I log out of my gnome session on one of the seats the X server crashes. Logging out on seat :0 even causes both servers (on a dual-seat setup) to crash.

I confirmed this behavior with two different hardware setups:
1) Dual-seat running on an onboard intel chip and an ATI Radeon 5450 card (X command: "/usr/bin/X -novtswitch -sharevts")
2) Dual-seat on the same screen in different VTs (like in the old lightdm, switching with ctrl-alt-F[1-9])

Since it shows similar behavior on both setups it is probably hardware-independent. Additionally, the second setup did not crash in the previous lightdm version (0.3.7). I'll include the log files for both seats on the first setup. The actual crash output starts at line 20 (in both files).

Tom De Caluwé (tom-de-caluwe) wrote :
Tom De Caluwé (tom-de-caluwe) wrote :

The first log file is of course /var/log/lightdm/:0.log

Robert Ancell (robert-ancell) wrote :

Hi Tom, could you please open new bugs for these problems? Thanks.

Changed in lightdm:
status: Fix Committed → Fix Released
jap1968 (jap1968) wrote :

Hello everybody,

I have another question related to multiseat. I do not know if I should open a new bug report, but since it is also related to multiseat options, I report here the problem:

I am trying to setup a multiseat computer following this tutorial (http://netpatia.blogspot.com/2009/06/multiseat-in-ubuntu-904.html). The idea here is to have a base X and several Xephyr sessions running on the main X session. The main X session does not have to initiate a greeter, but just hold the Xephyr sessions. This is the way of having multiseat on computers with just a graphics card and several outputs.

The question is how to avoid launching the lightdm greeter on the main X session. Previously (with gdm) that was achieved with the parameter "handled" of every session. ¿Is this parameter still active? ¿Can I obtain a base session with just X running and two additional sessions with the LightDM greeter running over two Xephyr sessions?

Thanks a lot for your help,

 José Antonio

Robert Ancell (robert-ancell) wrote :

Hi José,

What is the reason to run no greeter? Please open a new bug if this is required.

Thanks,
--Robert

duportail (guy-linux-service) wrote :

It is the only way to configure multiseat on the two outputs of a videocard.(nvidia driver does not support multiseat)
The main xserver is started but with no greeter, after that you can start a xephir or xnest session (with greeter)on each display.So the mainserver is started on :0 but with no greeter.Then each xephir or xnest session get's :0.1 , :0.2 and so on.

jap1968 (jap1968) wrote :

duportail described perfectly the problem. In fact I opened a bug related to that:
https://bugs.launchpad.net/lightdm/+bug/812170

Another question: You can have multiseat with nvidia cards. Hope this link can help you:
http://netpatia.blogspot.com/2009/07/multiseat-with-nvidia-card.html

Is it possible to specify autologin accounts for the various seats? Example: I have a PC with 3 displays attached. I want one of the displays to run Home Theatre software on (http://www.xbmc.org) where a user can watch movies and such. The two other displays should be available for a different user for normal desktop use. I would like the home theatre display's session to autologin to a specific user, so that it automatically launches the home theatre software upon startup. The other session should show a standard login screen for any user to login to.

Would that be possible?

Leon (leonbo) wrote :

@Wilco:
Have a look at the following configuration lines of lightdm:

# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)

Leon (leonbo) wrote :

I copied the configuration of Tom but I can't get the -sharevts working.

root@basil:/etc# ps aux | grep X
root 10609 0.0 0.4 101016 17952 tty7 Ss+ 21:11 0:00 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
root 10612 0.2 0.7 125936 29764 tty8 Ss+ 21:11 0:00 /usr/bin/X :1 -auth /var/run/lightdm/root/:1 -nolisten tcp vt8 -novtswitch

Can anyone lend me a hand with this?

Michael Franzl (michaelfranzl) wrote :

Could someone provide or point me towards a working configuration for a multi-seat setup in Ubuntu 11.10? I have a USB touchscreen from Mimo with a displaylink chip. It already works as the primary display, even the touch events are supported. But after two days of combing through the internet and trying various multi-seat configurations, it still does not work. Everything seems to be supported by now (November 2011), but just a working configuration would be needed to tie the pieces together. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions