freeze on login with prime-select intel

Bug #1637733 reported by ubuntubughelp on 2016-10-29
124
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
Linux Mint
Confirmed
Undecided
Unassigned
Nvidia
Undecided
Unassigned
Ubuntu Drivers Common
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

3 laptops I have with both Nvidia and Intel graphics completely free on login after selecting the intel chip. Sometimes after a reboot I cannot even get the lightdm and the screen is black, requiring me to enter the ubuntu recovery mode and run 'prime-select nvidia'. With either situation I cannot enter a TTY.

This problem does not happen with Xubuntu.

I have tried Nvidia-367 361 and 370 from the graphics-drivers ppa. The machines have 950M 960M 970M chips.

This bug cannot be reproduced in 16.04, only 16.10

description: updated
description: updated
description: updated
description: updated
ubuntubughelp (ubuntubughelp) wrote :
jonnylithui (jonnylithui) wrote :

i have been waiting to see if anyone else was having this issue; my lap have the same problem but with a 980M and an Skylake processor; I tried mate flavour but the problem is still here;

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Carlinuxxx (foro.carlos) wrote :

Same problema with Skylake + gtx 1060

ronaldorjr (ronaldo-rjr) wrote :

same problem on my laptop:
nvidia gtx 960M
skylake i7 6700 HQ
SSD

Miguel (miguel-magalhaes) wrote :

same problem here
nvidia gtx 970M
cpu i7 6700 HQ
SSD

Miguel (miguel-magalhaes) wrote :

still appens with drivers 375.26 and 378.09

Muzafar Umarov (umarov) wrote :

I have this problem on MSI GS63VR
NVidia Gtx 1060
i7 6700 HQ
Samsung EVO SSD
16GB RAM

I switched to Intel in Nvidia Settings. After reboot, I login then everything freezes. I can't access TTY. I have to force shutdown with the power button. It's really annoying.

Happens on 375 and 378 :(

Blake Tregre (btregre) wrote :

I have the same problem with Gigabyte Aero 14.
NVidia gtx 1060
Kabylake i7 7700HQ
16GB RAM

Richard Paul (two00lbwaster) wrote :

I'm also trying to run 16.10 desktop Ubuntu on a P651rp6-g laptop and I'm experiencing the same issue. I have MSHYBRID option selected in the UEFI, I'm using the UEFI rather than legacy Bios.

I'm currently using two ppas, the https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa with nvidia 378 drivers and the latest mesa from https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/poppa.

Just to note that this problem still exists with our without these ppas and with our without the proposed updates. I've also had to add GRUB_GFXPAYLOAD_LINUX=text to grub as otherwise I can't even complete the boot under UEFI as the screen just turns on and off.

It definitely seems to be related to lightdm somehow as issuing service commands against lightdm from the console, especially after changing the GPU with prime select results in the same symptoms

This bug report seems to highlight some very similar issues and behaviours:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1569383

Karthik Karanth (medakk) wrote :

I encountered the same problem on my brand new Asus FX553-VD, with a Kabylake 7700HQ i7 and GTX 1050. I'm running Ubuntu GNOME 16.10, 4.10 kernel and have installed the Intel i915 drivers.
I found a workaround for it.

1) Install and enable acpi-call-dkms
sudo apt install acpi-call-dkms
sudo modprobe acpi_call

2) Whenever you want to switch to Intel, run `sudo prime-select intel`, and reboot.

3) At the login screen, press Ctrl+Alt+F2, login, and run:
sudo /usr/share/doc/acpi-call-dkms/examples/turn_off_gpu.sh

4) Press Ctrl+Alt+F1 and login. It should be using the Intel graphic card now. You could check with `glxinfo | grep -i opengl`

You'll have to do this whenever you're using the Intel GPU unfortunately.

I found this method of turning the GPU off on the Arch wiki(https://wiki.archlinux.org/index.php/hybrid_graphics#Fully_Power_Down_Discrete_GPU). I don't know if it will work for others, but I hope it helps diagnose the issue.

To switch back to NVIDIA, run `sudo prime-select nvidia` and reboot.

Karthik Karanth (medakk) wrote :

I forgot to mention, the above workaround doesn't seem to work when the laptop is charging. Plug in the charger after you have logged in.

I am also affected.

Specifications:

vendor: MSI
SKU: MSI GS43VR 6RE Phantom Pro
GPUs: Nvidia GeForce GTX 1060 6 GB + Intel Skylake HD 530 GT2
Processor: Intel Core i7 6700HQ.

Please fix :-)

5th (fifth-8) wrote :

it happens not only after reboot, but also when restarting lightdm.
When frozen even REISUB magic commands have no effect (so i suggest this bug is of great importance).
The only trace of crash in logs is few lines of NUL (written as ^@ )

spec:
Clevo N850 HK1
Kubuntu 17.04 with 4.10.0-21-generic kernel
GTX 1050 Ti with nvidia-381.22
intel i7-7700HQ

5th (fifth-8) on 2017-05-18
Changed in lightdm:
status: New → Confirmed
5th (fifth-8) wrote :

WORKAROUND:

Commenting line:
gfxmode $linux_gfx_mode
in GRUB2 menu entry solved the problem

jlaustill (jlaustill) wrote :

I'm having this same issue with Ubuntu Gnome 17.04 on a Sager NP-8174. I didn't have this issue with Linux Mint 18.1.

Kyle25 (wkwong00) wrote :

Affecting me as well. Running i5 6300hq with GTX 960m on Dell 7559
Having this issue on all the Ubuntu flavors that I have tried

affects me also, BUT:

fresh install of Ubuntu 17.04 + Cinnamon on Dell XPS 15 9560 with Nvidia GTX1050. Switching worked fine until i installed virtualbox-5.1 with all dependencies and Steam + Portal 2.

I can`t say, what started the issue, but now, i`m only able to use the nvidia card.

Have to investigate further.

Workaround #15 does not work for me.

According to https://gist.github.com/whizzzkid/37c0d365f1c7aa555885d102ec61c048 i added 'acpi_osi=! acpi_osi="Windows 2009"' to grub and now i am back again on intel :-). The nvidia-gpu is switched off:
root@Anor:~# cat /proc/acpi/bbswitch
0000:01:00.0 OFF

Michael Knyazev (mkn1980) wrote :

I have the same problem with Asus X580VD running Ubuntu 16.04
- Intel Core i7-7700HQ
- Intel HD 630 (Intel Corporation Device 591b)
- GeForce GTX 1050

dratc (dratc) wrote :

This also affects me on a Clevo P950HP with:
- Kaby Lake i7-7700HQ
- NVIDIA GTX 1060 w/ 384.69 driver (binary installed via 'Additional Drivers' in Software & Updates menu)
- Intel HD Graphics 630, i915 driver w/ latest KBL firmware (via https://01.org/linuxgraphics/downloads/firmware)
- Xubuntu 17.04
- Kernel 4.12.14-041214-generic (via http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.12.14/)

The NVIDIA driver + card works fine, but selecting intel in the NVIDIA X-server or running prime-select intel causes the system to hang on shutdown, or at login after forced power-off, at the point when LightDM is loading.

Yu Lou (louyu1999) wrote :

I experienced a similar situation with a fresh installation of Ubuntu Gnome on Dell XPS 15. I didn't install virtual box.

Details about my computer:

Processor: Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Graphics: GeForce GTX 1050/PCIe/SSE2
Driver: Nvidia binary driver version 384.90; Processor microcode from intel-microcode(proprietary)

After running "prime-select intel" and log out, I couldn't log in again. When I tried to log in, the screen just blanked out and got back to log in screen after a few seconds. After I run "prime-select nvidia" in tty to restore settings, I can log in.

The solution on #11 didn't work for me. It successfully shut down the graphics, but I couldn't open GUI anymore and had to reboot to power up the graphics.

However, I did find some workaround if you just want to reduce the power consumption. Instead of shutting down the graphics, you may constrain the clock rate by using this method:

https://devtalk.nvidia.com/default/topic/572053/linux/-solved-forcing-maximum-power-saving-on-the-desktop-quot-minimum-power-quot-mode-for-powermizer-/

It worked on my computer and helped me to get rid of the annoying sound from GPU fan.

Yu Lou (louyu1999) wrote :

I forgot to mention my system version. It's Ubuntu Gnome 17.04 64-bit.

Yu Lou (louyu1999) wrote :

Update:

I just found that the workaround I posted won't work after suspend. It will work again after restart.

R.Erol (leopard1907) wrote :

I'm also affected by that.

ASUS FX553VD-DM160

Core i7 7700 HQ
Gtx 1050
Mint 18.2

My solution is that ; don't install Nvidia prop drivers immediately.

First ; start using MDM instead of Lightdm. Because workaround above is not working with it and you cannot even enter TTY screen.

Then install Nvidia drivers.

Change your gpu by using terminal with these commands:

sudo prime-select intel

or

sudo prime-select nvidia

and then

sudo reboot

Lightdm maintainers are not seemed interested so use MDM instead.

DD (orlangur) wrote :

Same here.

Clevo N870HK1
Core i7 7700 HQ
Gtx 1050Ti
Kubuntu 17.10

As of now only prime-select nvidia allows me to normally boot. But in my case it's not lightdm, but sddm. Also worth noting is on the previous version of Kubuntu (17.04) I was using kernel 4.10.0-21 and I was able to normally boot and work on intel graphics. For some reason it's not the case anymore - booting with that kernel results in the same freeze.

R.Erol (leopard1907) on 2017-11-18
Changed in linuxmint:
status: New → Confirmed
crroush (crroush) wrote :

I experienced the same issue on my XPS 9560 running a fresh install of Ubuntu 16.04
If I used either prime-select intel or switching it in nvidia-settings, I would end up unable to get a display. I am using 384.9 NVIDIA driver.
I have not found a viable work around

Yu Lou (louyu1999) wrote :

This problem was solved after updating to Ubuntu 17.10, but I don't know why(maybe the bug was fixed in a new release in some packages).

Richard (f-richaad-h) wrote :

Also affects gdm3 (as well as lightdm) on Ubuntu 17.10. Removing Virtualbox 5.2 doesn't help at all from my testing. I know that this worked after an upgrade from 17.04 to 17.10, but something broke it after the upgrade, and it probably worked okay on a fresh install.

I'm waiting for 18.04 to be released so that I can confirm that after upgrading this works and then I'll keep testing after updating each of my frequently used/updated/installed packages to find out which one causes the kernel to die.

I'd like to get this working because the Nvidia GPU means that I get about 50mins of battery life which is no good for meetings, where I have to grab my comedy PSU (massive 200W brick) to keep my laptop working.

Sum Sim (draugr200) wrote :

Xubuntu 18.04
Nvidia GTX 1050
driver: Nvidia-390

I can't log in! Everytime I enter password, screen becomes blue and freezes, there is only a mouse pointer and blank screen. Then I press Ctrl-Alt-Del, go to enter screen, type passwrd again and voila, everything works! Very annoying bug.

I believe there was a similar problem in gdm and they fixed it, pls fix this bug too!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments