lightdm-gtk-greeter in Xubuntu, has one untranslated item

Reported by Pjotr12345 on 2011-11-28
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Low
Gunnar Hjalmarsson
lightdm (Ubuntu)
Low
Unassigned
Oneiric
Low
Gunnar Hjalmarsson
Precise
Low
Unassigned

Bug Description

[Impact]
<fill me in with explanation of severity and frequency of bug on users and justification for backporting the fix to the stable release>

[Development Fix]
lightdm-gtk-greeter has been broken out from the lightdm package into a separate branch. A fix, identical with the fix in the lightdm MP for Oneiric that this bug report links to, has been committed upstream into the lightdm-gtk-greeter branch. However, the new branch has not yet been packaged for Precise; please see bug #918604. Consequently the fix will make it into Precise once lightdm-gtk-greeter has been packaged.

[Stable Fix]
<fill me in by pointing out a minimal patch applicable to the stable version of the package.>

[Text Case]
<fill me in with detailed *instructions* on how to reproduce the bug. This will be used by people later on to verify the updated package fixes the problem.>
1.
2.
3.
Broken Behavior:
Fixed Behavior:

[Regression Potential]
<fill me in with a discussion of likelihood and potential severity of regressions and how users could get inadvertently affected.

[Original Report]
The greeter of LightDM in Xubuntu Oneiric, is almost completely translated. When you install the packages that are currently still in Proposed, anyway. But not the item "Password:".

This happens even in languages for which LightDM has been fully translated (100 %). In my case: Dutch. So the item "Password:" is somehow untranslatable now.

At the request of Sebastien Bacher, I've forked this bug from this previous bug report: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/868613

I should add that I'm using the LightDM packages from Proposed, which fix most of the translation issues, but not this final one.

According to Robert Ancell in the previous bug report, lightdm-gtk-greeter should pull it's translation of the item "Password:" from PAM: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/868613/comments/12

But it doesn't do so: PAM has been fully translated into Dutch as well, but still no translation for the item "Password:" in lightdm-gtk-greeter.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Pjotr12345 (computertip) wrote :

Deafening silence.... I'd really appreciate some feedback from a developer. Keep your intrepid bug reporters happy and motivated, people....

Dmitry Shachnev (mitya57) wrote :

@Robert: Can you look at it?
BTW, here is Dutch translation for "Password: ": https://translations.launchpad.net/ubuntu/oneiric/+source/pam/+pots/linux-pam/nl/4/+translate

Sebastien Bacher (seb128) wrote :

Sorry Pjotr12345 but nobody is actively working on the gtk greeter (which has been made as an example greeter, the default greeter in Ubuntu is the unity one) and december is usually a low activity month dues to holidays

If somebody wants to look at doing a patch or a merge request that could increase the chances to have the issue reviewed, it will be looked at during this cycle otherwise but not sure when

Changed in lightdm (Ubuntu Precise):
importance: Undecided → Low
Changed in lightdm-gtk-greeter:
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

I have proposed a fix of the upstream trunk.

An Oneiric build with the fix is available in my PPA at
https://launchpad.net/~gunnarhj/+archive/misc
Please feel to install it to confirm that it fixes the issue.

Sebastien: I guess the bug isn't important enough for an SRU. Or is it, considering that lightdm-gtk-greeter is the default greeter in Xubuntu? After all the bug is highly visible.

Pjotr12345 (computertip) wrote :

I've tested it, and it works! Thank you, Gunnar Hjalmarsson! :-)

I sincerely hope that this very visible bug, will be fixed in an SRU.

Changed in lightdm-gtk-greeter:
status: In Progress → Fix Committed
Pjotr12345 (computertip) wrote :

I've changed the bug status to "Fix committed", but I'm not sure whether this was right... Please correct it when not.

Other people who may want to test the fix, can do it as follows:

- start the application Software Sources, and add the following source:
ppa:gunnarhj/misc

- start a terminal and add the key:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B99AF5C2

- install the updates that you're being offered, for several lightdm packages;

- reboot your computer

Again, I'm very happy with this fix.... this particular bug has annoyed me for a long time.

Dmitry Shachnev (mitya57) wrote :

The branch has not been merged yet.

Changed in lightdm-gtk-greeter:
status: Fix Committed → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks, Pjotr, for confirming that the proposed fix works as intended.

On 2012-01-07 11:31, Pjotr12345 wrote:
> I've changed the bug status to "Fix committed", but I'm not sure whether
> this was right...

As Dmitry said, it wasn't. So far it's just my proposal for a fix.

We'll probably get to know on Monday if it can be 'SRUed'.

Robert Ancell (robert-ancell) wrote :

This seems appropriate for a SRU (and should be reasonably easy). Any volunteers? (not me).

Gunnar Hjalmarsson (gunnarhj) wrote :

Robert,
I already had the branch on my disk, so I just made an MP. Can you please add the Oneiric task to this bug (I don't have access to do it).

Changed in lightdm (Ubuntu Precise):
status: Confirmed → Triaged
Changed in lightdm (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Low
Changed in lightdm-gtk-greeter:
importance: Undecided → Low
Changed in lightdm-gtk-greeter:
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

As regards verification:
The lightdm branch in my PPA (https://launchpad.net/~gunnarhj/+archive/misc), which is identical with the branch in the oneiric-proposed MP except for the first line in debian/changelog, has been installed and run successfully, and it has been confirmed (see above) that it actually fixes the issue in this bug report.

Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Pjotr12345 (computertip) wrote :

I have a clean 64-bit Xubuntu 11.10 system available for testing this fix again, this time with a package from Proposed, but there is no lightdm package in Proposed yet....

Marc Deslauriers (mdeslaur) wrote :

I've taken a look at the merge request. For an Oneiric SRU, could you please change it to use the package's patch system, instead of inline patching the file, please?

Changed in lightdm (Ubuntu Oneiric):
status: In Progress → Incomplete
Gunnar Hjalmarsson (gunnarhj) wrote :

Changed the MP to using the patch system as requested. The new branch tested successfully.

Changed in lightdm (Ubuntu Oneiric):
status: Incomplete → In Progress
Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact: The lightdm-gtk-greeter's password string isn't translated. This has been fixed in the lightdm-gtk-greeter upstream source tree. lightdm-gtk-greeter has been removed from Precise, so the issue doesn't apply to Precise.

Fix: A minimal patch was applied to use the pam stack's password string. See merge request.

Regression potential: minimal, worst case the password string won't display properly.

Changed in lightdm (Ubuntu Precise):
status: Triaged → Invalid
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2012-01-18 17:45, Marc Deslauriers wrote:
> ... lightdm-gtk-greeter has been removed from Precise, so the issue
> doesn't apply to Precise.
> ...
> ** Changed in: lightdm (Ubuntu Precise)
> Status: Triaged => Invalid

Marc,
Robert has a more robust solution in mind, which would involve both the lightdm and lightdm-gtk-greeter package. I think that's why he triaged this bug for lightdm in Precise.

Changed in lightdm (Ubuntu Precise):
status: Invalid → Triaged
Bryce Harrington (bryce) on 2012-01-27
description: updated
description: updated

Hello Pjotr12345, or anyone else affected,

Accepted lightdm into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lightdm (Ubuntu Oneiric):
status: In Progress → Fix Committed
Pjotr12345 (computertip) wrote :

I've installed three Lightdm packages from Proposed in Xubuntu 11.10 (64 bit). Result: success! "Password" has neatly been replaced by it's Dutch translation.

Thanks for this SRU!

Martin Pitt (pitti) on 2012-01-30
tags: added: verification-done
removed: verification-needed
Sebastien Bacher (seb128) wrote :

removing the sponsors, the sru got uploaded and precise will need a newer version which is not covered by this bug

Martin Pitt (pitti) wrote :

Precise recently got a new version, assuming it's fixed there now.

Changed in lightdm (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu1.3

---------------
lightdm (1.0.6-0ubuntu1.3) oneiric-proposed; urgency=low

  * debian/patches/06_translate_prompt_label.patch:
    Enable translation of prompt_label (LP: #897166).
 -- Gunnar Hjalmarsson <email address hidden> Wed, 18 Jan 2012 16:48:00 +0100

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

This should be now fixed in lightdm-gtk-greeter 1.1.4.

Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers