lightdm-gtk-greeter in Xubuntu, has three untranslatable items

Bug #868613 reported by Pjotr12345 on 2011-10-05
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Medium
Dmitry Shachnev
Oneiric
Medium
Unassigned
Precise
Medium
Dmitry Shachnev

Bug Description

The greeter of LightDM in Xubuntu Oneiric, is largely translated. But not the following items:
- "Password:"
- "Guest Account"
- "Other..."

This happens even in languages for which LightDM has been fully translated (100 %). So these items are somehow untranslatable now.

Related branches

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Please note the "Password:" string in the gtkbuilder .ui is not marked as translatable which should probably be fixed as well. Perhaps the other two strings are also marked wrong?

Changed in lightdm (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
milestone: none → later
milestone: later → none
Sebastien Bacher (seb128) wrote :

let's get it fixed in an oneiric sru, there is no real point to try to push it in Oneiric now since the langpacks have been exported so we will not get translations for Oneiric now

Dmitry Shachnev (mitya57) wrote :

Oh, sorry, didn't notice that there's already a branch here (but mine is earlier) :)

Pjotr12345 (computertip) wrote :

Thankfully a fix has been committed (twice, in fact, by two different people). Can anybody tell me when the fix will be released?

Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Fix Committed
Changed in lightdm (Ubuntu):
status: Triaged → Fix Committed
Dmitry Shachnev (mitya57) wrote :

It's not committed yet, it's just my own branch.

Changed in lightdm (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
status: Fix Committed → Confirmed
Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Fix Committed
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in lightdm (Ubuntu Oneiric):
status: In Progress → Fix Committed

Hello Pjotr12345, or anyone else affected,

Accepted lightdm into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Pjotr12345 (computertip) wrote :

I installed and tested the proposed lightdm: it seems to works fine on my HP Mini netbook!

Did a couple of reboots, logging in and logging out as normal user and logging in and out with the Guest account: all works well.

Martin Pitt (pitti) on 2011-10-27
tags: added: verification-done
removed: verification-needed
Pjotr12345 (computertip) wrote :

Thanks for the commit, but the problem is not entirely solved, it appears.... I'm a member of the Dutch Translation Team of Ubuntu, and so I wanted to do the translation right away.

When I checked, I saw that only two new items had become translatable. Whereas it should be three.

I could translate the following two items:
- "Guest Account"
- "Other..."

But I could *not* translate:
- "Password:"

So that conspicuous word is probably still untranslatable.

Dmitry Shachnev (mitya57) wrote :

Pjotr: I don't think the problem is in code here. Probably that translation was not extracted/uploaded to Launchpad.

Robert, can you do what's needed?

Pjotr12345 (computertip) wrote :

Reverted the status back to "confirmed", because there is still one untranslatable string left (namely "Password:").

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Changed in lightdm (Ubuntu Precise):
status: Fix Committed → Confirmed
Sebastien Bacher (seb128) wrote :

How is it not translatable? see the first chunk in https://code.launchpad.net/~timovwb/lightdm/fix-for-868613/+merge/78705

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in lightdm (Ubuntu Precise):
status: Confirmed → Fix Committed
Robert Ancell (robert-ancell) wrote :

These messages come from PAM, and use the system language currently.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu2

---------------
lightdm (1.0.6-0ubuntu2) precise; urgency=low

  * Upload to precise.

lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Martin Pitt <email address hidden> Thu, 10 Nov 2011 07:19:12 +0100

Changed in lightdm (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu1

---------------
lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Robert Ancell <email address hidden> Wed, 02 Nov 2011 11:37:43 -0400

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Pjotr12345 (computertip) wrote :

I have a Dutch localized Xubuntu. I installed the new LightDM packages from proposed. The strings "Guest account" and "Other..." are now translated into Dutch. :-)

But "Password: " is still untranslated... Apparently lightdm-gtk-greeter does not succeed in importing the translation from PAM. In spite of the fact that PAM itself, has been fully translated into Dutch.

Can somebody look into this? I'm willing to help with testing fixes.

Pjotr12345 (computertip) wrote :

Changed the status back to "Confirmed", because the fix from Proposed was only partially succesful ("Password: " is still untranslated, see comment #15).

Changed in lightdm (Ubuntu Oneiric):
status: Fix Released → Confirmed
Changed in lightdm (Ubuntu Precise):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks but that issue seems a different one, better to open a new bug

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in lightdm (Ubuntu Precise):
status: Confirmed → Fix Released
Pjotr12345 (computertip) wrote :

@Sebastien Bacher: OK. I've filed this new bug report:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/897166

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers