lightdm-gtk-greeter flickers once little after lightdm starts

Bug #1531224 reported by Serede on 2016-01-05
172
This bug affects 35 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Bug context:
 · Arch Linux x86_64 4.3.3-2-ARCH
 · systemd 228-3 (using lightdm-plymouth.service)
 · plymouth 0.9.2-8 (compiled from AUR)
 · lightdm 1:1.16.6-2
 · lightdm-gtk-greeter 1:2.0.1-2

At the end of boot process, right after plymouth splash, lightdm starts normally and the GTK+ greeter login screen is shown for about 1 second, but then the screen instantly flickers (goes black) and the greeter is redrawn. From here on, everything works flawlessly, but the brief flickering is certainly annoying.
This happens every time and no other greeter I have tried presents this issue, so I can confirm it is lightdm-gtk-greeter-related.

Serede (serede) wrote :

The issue is noticeable at the end of the attached video. Quality is not too high but enough to see the flickering.

Hanno Meyer-Thurow (h.mth) wrote :

Same here on Gentoo Linux.

Linux amari 4.3.4-gentoo #1 SMP PREEMPT Sun Jan 24 14:21:25 CET 2016 x86_64 Intel(R) Core(TM) i5-2537M CPU @ 1.40GHz GenuineIntel GNU/Linux

sys-apps/openrc-0.17
x11-misc/lightdm-1.16.6
x11-misc/lightdm-gtk-greeter-2.0.1-r1

Yes, definitely, I can confirm this. I'm using the latest ubuntu 15.10. It happens only with my notebook which has an Intel Haswell integrated graphics and not on my AMD R9 380 + fglrx.
In addition to the flicker, when I'm using the user wallpaper (lightdm+cinnamon, when I choose the background with cinnamon the user has a personal wallpaper in /var/lib/AccountsService/user/*myuser*, the wallpaper just shows for seconds and after the "flicker" it resets to the original one. I will make a video about this.

Here is the video

I have the same problem. I noticed thought that the flicker seems to coincide with the appearance of the "Enter Password" text. It's already focused when the screen first arrives, then the screen flickers and focus is lost. Could be a coincidence, but thought it might be helpful. Can anyone else confirm that?

Running Arch Linux: tried both the lightdm-gtk-greeter (Arch repo) and lightdm-gtk-greeter-devel (AUR) packages.

Also, I don't have plymouth (or lightdm-plymouth). Don't think it's related to the bug.

Monty (spoothie) wrote :

I am affected by this as well on both Arch and Xubuntu 15.10. I am also using Intel integrated graphics in both cases. I want to add that this issue is especially annoying for me because of the password prompt. When the greeter is redrawn, the password prompt is reset as well. If I start typing my password normally when the login screen comes up, it oftentimes redraws the screen while I am in the middle of typing my password, therefore removing what I have put in so far and forcing me to type it again.

Why this isn't confirmed yet? This affects a lot of people

Sb (sb56637) wrote :

The workaround is to use Intel UXA acceleration instead of SNA:

--------------------------------------
/etc/X11/xorg.conf.d/20-intel.conf
--------------------------------------

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "AccelMethod" "uxa"
EndSection

--------------------------------------

Of course this is only a workaround, and only LightDM is affected by Intel SNA acceleration, so I agree that this bug should be confirmed and handled.

kaefert (kaefert) wrote :

I can confirm that the workaround works for me.

BenTLor (social-d) wrote :

The workaround works for me as well, although the file in my case was /usr/share/X11/xorg.conf.d/20-intel.conf

Sven Jakob (sven-jakob-s) wrote :

Same issue here on a Dell Latitude E6429 with Ubuntu Mate 16.04
Workaround does not work because I don't have the conf file.

sunox (ejspero) wrote :

Same issue. Lenovo Thinkpad T430 running Xubuntu 16.04.

The workaround works, but of course this means I lose TearFree.

Sebastian (sn-ubuntu) wrote :

Can confirm same issue: Xubuntu 15.10. Integrated intel graphics.

Hanno Meyer-Thurow (h.mth) wrote :

JFYI, after upgrading kernel from 4.5.1 to 4.6.3, I have not seen the flicker anymore.

Monty (spoothie) wrote :

I haven't seen this problem for a couple of weeks either, and I am on 4.6.4 as of this moment. I guess this was fixed with some kernel update, as Hanno also mentioned.

I also encounter the issue on a Thinkpad L440 with Core i3-4000M and Xubuntu 16.04.1.

James (jamesbysea) wrote :

I've seen this bug since first installing Ubuntu 16.04 (xenial) and it persists after all the regular updates I've run.

Perhaps like the following bug this only affects Intel graphics + lightdm?
https://bugs.launchpad.net/ubuntu/xenial/+source/xserver-xorg-video-intel/+bug/1568604

I'm running Xubuntu 16.04, details:

Ubuntu 16.04.1 LTS (xenial)
Hardware: NUC5i5RYK with Intel HD Graphics 6000
lightdm 1.18.2-0ubuntu2
Kernel: 4.4.0-34-generic

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2016-08-15
affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
no longer affects: lightdm

Recently, xserver-xorg-video-intel has been updated to xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.1 to fix https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1568604. However, this update doesn't fix the bug discussed here for me.

Ubuntu 16.04.1 LTS (xenial)
Hardware: Dell OptiPlex 3020 with Core i5-4690 and Intel HD Graphics 4600

James (jamesbysea) wrote :

I'm experiencing the same as Johannes. I applied that xserver-xorg-video-intel update, which fixed the mouse cursor bug, but it does not fix this lightdm flicker - the bug remains for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
RonaldvZ (ronaldvanzuijlen) wrote :

I believe I'm experiencing this issue as well. If lightdm loads up, I enter half my password and the flickering happens, I type the rest of my password and am not able to login. I believe the flickering interrupts my typing somehow. When I retype my password entirely after the flickering, it works fine.

Ubuntu MATE 16.04
Ubuntu MATE desktop 1.12.1
CPU: Intel Core i7-6500U CPU @ 3.1GHz
GPU: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)

nimnull (macachuto) wrote :

That tread was very helpful.
But you mixed things up.
I also experience the same problem with flickering background in greeter.

But, my story starts differently.
When I first time installed Xubuntu 16.04 and set up desktop background, greeter was showing it without any problem.

Then, I created xorg.conf.d, and specify "Monitor" "Device" "Screen", and after this my greeter background starts to blink.
But it is not just blink.
SNA somehow remembers desktop background and draws it again, but LightDM greeter redraws it and this process looks like flicker.
If you specify in greeter: user-background=false, with SNA you will see background and then greeter will clear it.

So the solution is to add option: user-background="do nothing"

Also I found out that with SNA I can't wakeup my monitor, because xrandr loses "current" mode
To wake it up I need to connect via ssh and manually set monitor mode:
xrandr -d :0 --output HDMI2 --mode 0x47

After this mouse movements wake up my monitor.

SNA is crappy.

Anurag (anurag-misra26) wrote :

Can confirm this bug persisted on my Thinkpad L430 with Xenial 16.04.1 with kernel 4.4.0.81. However, it was fixed by manually updating the kernel to the latest version (4.8.0.58) by running

sudo apt-get install --install-recommends xserver-xorg-hwe-16.04

Now, I don't see the flicker anymore. This thread was quite useful for the suggestions regarding updating the kernel.

Kristan Kenney (kmxkenn) wrote :

On an HP ProBook 6470b with Intel HD 4000 graphics, adding the following line to /usr/share/X11/xorg.conf.d/20-intel.conf resolved this issue in addition to fixing the resolution of my external monitor at the login screen:

Option "ReprobeOutputs" "true"

nimnull (macachuto) wrote :

It is now 05/2018.
I got my new T480 with i7 8th generation

And guess what, right, I see the same one flick in login prompt.

But now, I can't change acceleration module to UXA, because performance is very very slow, although it solves this issue.

It really needs to be fixed.
It is really annoying to see this flick and it drops login details also.

Please, fix it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers