Dash: very high latency responding to input

Bug #828582 reported by Paul Sladen on 2011-08-18
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
libunity
Fix Released
High
Michal Hruby
libunity (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Michal Hruby

Bug Description

After an upgrade to Ubuntu 11.10 the Dash now has very high latency (500+ milliseconds) responding to user input, such as typing characters in the Dash search and seeing those letters displayed.

The GNOME HIG requires an input/feedback latency of below 100 milliseconds.

If the update is waiting on results/matches to appear it should be possible to focus on displaying the user input initially, and then waiting for further results to come in.

(In order to always meet the 100 millisecond target, it may be necessary to find ways to transparently degrade the visual quality).

Related branches

Right now Unity itself has a pretty high timeout before sending queries to the lenses. Michal is working on improving the lens side query handling in various ways by tweaking libunity. This should make it possible to do the timeouts inside libunity, that is on the lens-side of things, allowing the lenses themselves to tweak the timeout to their needs.

Concretely, I propose:

 * Lower the timeout in Unity to something very low
 * Implement another timeout for dispatching LensSearch instances in libunity
 * Make that timeout in libunity a writable property for Scopes to override to suit their needs

Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
milestone: none → 5.0.0
status: New → Triaged
Changed in libunity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
milestone: none → 5.0.0
status: New → Triaged
Michal Hruby (mhr3) wrote :

@Paul: What graphics drivers do you use? Are you using any special input methods? I don't think what you see is normal, FWIW typing something in the Dash's search box displays the letters immediately here.

Omer Akram (om26er) on 2011-12-05
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Michal Hruby (mhr3)
Gord Allott (gordallott) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Changed in libunity:
milestone: 5.0.0 → 5.0.2
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Michal Hruby (mhr3) wrote :

I believe what Paul is seeing is that some of the icons in his theme are only available as huge svgs and the icon loading is what's causing the delay.

Omer Akram (om26er) on 2012-01-19
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in libunity:
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2012-01-27
Changed in libunity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in libunity (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in libunity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 5.2.0-0ubuntu1

---------------
libunity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash: very high latency responding to input (LP: #828582)
    - Adding an option to the Sources filter from a remote Python scope
      doesn't work (LP: #916758)
    - Dash - Genre filter category in the Music Lens should use a 3 column
      layout (LP: #841902)
  * debian/control:
    - build with vala 0.14 and on python
  * debian/libunity9.symbols:
    - updated symbols
  * -
 -- Didier Roche <email address hidden> Fri, 03 Feb 2012 11:38:26 +0100

Changed in libunity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

Appears to be fixed; tested with the following method:

  1. Press <Logo> to open Dash
  2. Hold down 'w'

an infinite number of Ws matches against a 'wwwwwwwwwwwwwwwwwwwwwwwwwwww' URL link. However, the input correctly continues to update with the icon appear 1-2 seconds later in the background.

Paul Sladen (sladen) wrote :

Above was validated with Unity 2D. Have validated Unity 3D aswell, which is fixed too.

(Although the overall latency/jerkiness is below that of Unity 2D using the same two steps for confirmed).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu Quantal):
status: New → Confirmed
Chad Cloman (waoi-public) wrote :

This bug is marked as fixed, but I still experience significant delays before my first keystroke appears as well as while the keystrokes appear. Basically, I bring up the dash, type my search string, then sit back and wait for the characters to appear on screen. Even though I've typed the entire string, the auto search is occuring before the first keystroke and between some (or sometimes all) keystrokes. The delays tend to be on the order of seconds.

Admittedly, I have old hardware, but this is annoying.

I'd like some way to either (1) disable the auto search completely until I press the enter key, or (2) have the ability to set a user-defined delay parameter that holds off on the auto search until after that much time has passed with no keyboard input in the search field.

Running Ubuntu 12.10 with the latest updates.

Daniel van Vugt (vanvugt) wrote :

Chad,

As this bug is marked Fix Released, you should log a new one to ensure the problem gets re-examined. Please do so by running this command on the affected machine:
    ubuntu-bug unity

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: libunity (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers