Hud not really functional with webapps

Bug #1081305 reported by Alexandre Abreu on 2012-11-20
84
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity HUD
Fix Released
Medium
Unassigned
WebApps: libunity-webapps
High
Unassigned

Bug Description

When trying to use the HUD from any integrated webapp (that uses it off course), one cannot seem to be able to access actions registered for the current url.

I tried using hud-gtk to see what's happening and indeed the webapp associated actions are not being considered.

Changed in unity-chromium-extension:
importance: Undecided → High
chad (crossroads1112) wrote :

I am having the same problem with both chromium and firefox

Will Cooke (willcooke) on 2012-11-26
tags: added: kanban

I am also getting this issue with Firefox. The bug title is really misleading in this regard.

summary: - Hud not really functional with chromium
+ Hud not really functional with webapps
Omer Akram (om26er) on 2012-12-10
Changed in unity-chromium-extension:
status: New → Confirmed
Will Chester (william-chester) wrote :

I am also seeing this issue after a clean install of 12.10 with my Google Online Account added. I can't get HUD integration on Google Docs with either Chromium or Firefox. I have also installed the unity-webapps-gmail and unity-webapps-googledocs packages.

Changed in libunity-webapps:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
status: New → In Progress
Changed in unity-chromium-extension:
status: Confirmed → In Progress
David King (amigadave) on 2013-01-11
Changed in libunity-webapps:
importance: Undecided → High
Alex Launi (alexlauni) wrote :

This is due to a bug in bamf/HUD. A merge has been proposed.

Changed in unity-chromium-extension:
assignee: Alexandre Abreu (abreu-alexandre) → Alex Launi (alexlauni)
Changed in libunity-webapps:
assignee: Alexandre Abreu (abreu-alexandre) → Alex Launi (alexlauni)
Changed in hud:
assignee: nobody → Alex Launi (alexlauni)
Changed in libunity-webapps:
status: In Progress → Invalid
Changed in unity-chromium-extension:
status: In Progress → Invalid
Changed in hud:
importance: Undecided → High
status: New → In Progress
Thomas Kluyver (takluyver) wrote :

Any progress on this? I can't find the merge proposal mentioned - was it already accepted?

Ted Gould (ted) on 2013-05-28
Changed in hud:
importance: High → Medium
status: In Progress → Triaged
assignee: Alex Launi (alexlauni) → nobody

I've tested HUD on a number of webapps and many of them don't seem to expose any actions for HUD to display. I may be wrong but it seems this is more an issue with the app implementations rather than an issue with HUD. I say this because some webapps do work really well. E.g. unity-webapps-linkedin, and unity-webapps-reddit.

David Barth (dbarth) wrote :

Correct. The framework support has been here for a while, and is working great with some webapps which expose things nicely. The effort is more on enabling more apps to surface their commands.

no longer affects: unity-chromium-extension
Changed in libunity-webapps:
assignee: Alex Launi (alexlauni) → nobody
status: Invalid → Fix Released

Great, marking the HUD bug status as "Fix Released" too as clearly this issue has since been resolved.

Changed in hud:
status: Triaged → Fix Released
Mateo Salta (mateo-salta) wrote :

Seems like this worked at one time, but I'm not seing this function on any browser, chromium with the unity-chromium-extention, firefox, the unity browser.

This shows google docs integration: http://www.omgubuntu.co.uk/2012/07/list-of-that-websites-support-unitys-new-web-apps-feature but currently in 14.04 I'm not seeing any.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers