Music store widget should not navigate to external sites

Bug #544490 reported by Ævar Arnfjörð Bjarmason on 2010-03-22
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libubuntuone
High
Stuart Langridge

Bug Description

When I'm at the "We’ve just emailed <email address hidden> (from <email address hidden>) with instructions on resetting your password." screen there's no UI feature that i can see to get back to the main store. I have to restart rhythmbox to get back.

Related branches

tags: added: 7digital
Changed in rhythmbox-ubuntuone-music-store:
assignee: nobody → Stuart Langridge (sil)
Matt Griffin (mattgriffin) wrote :

This sounds like your desktop has not been added to Ubuntu One and you were taken to the Ubuntu SSO page to sign-in from within Rhythmbox. Can you confirm?

tags: removed: 7digital
Changed in rhythmbox-ubuntuone-music-store:
status: New → Incomplete

If you're asking if I was signed into Ubuntu One via the Desktop at the time then no. Rhythmbox spotted this and offered me to log in, I then encountered the issue described in the report.

Brendan Martens (shrift) wrote :

I was going to add another bug, but I'll ad it here as it is essentially the same problem. Within a *lot* of places of the store, there is no way to get back to the ubuntu one home page; especially if you follow a link that goes to the 7digital main page. In addition to not being able to get back to Ubuntu One Store without quitting rhythmbox, this has the added confusion that you start browsing music and adding it to the 7digital cart, not the ubuntu one cart.

Brendan Martens (shrift) wrote :

Oh, also before I logged in with the me menu I found the exact same problem with the ubuntu one sign in page.

Changed in rhythmbox-ubuntuone-music-store:
status: Incomplete → Confirmed
Brendan Martens (shrift) wrote :

Sorry for the spam here... Can we change the name of this bug to something more like "throughout ubuntu one store there is lacking the navigation/method to get back to the main store page".

I changed it to something more general.

Someone also pointed out that the root of my particular problem was that I should sign into Ubuntu One via the system-wide login menu instead of in the Ubuntu One store.

If that's the case then the store shouldn't duplicate the system login facilities.

summary: - No way to get back from "we just mailed you a reset password token"
- screen
+ There's no navigation feature to get back to the main store page
+ throughout the Ubuntu One store, forcing a restart of Rhythmbox

I agree, that was the same confusion I had, then I got a 500 oops which asked me to open a bug, so I did then they told me I should use the me menu.

Stuart Langridge (sil) on 2010-03-24
Changed in rhythmbox-ubuntuone-music-store:
importance: Undecided → High
Dylan McCall (dylanmccall) wrote :

Good idea on the more general title. I encountered a server error while browsing the music store. Not sure what triggered it, but the important part is that this error used 7 Digital's usual page template instead of the Ubuntu One Music Store template. The result is that I can't go back or refresh the page since the controls are expected to be built in to the web page and the context menu is disabled.

Stuart Langridge (sil) on 2010-03-25
Changed in rhythmbox-ubuntuone-music-store:
status: Confirmed → Fix Committed
dobey (dobey) on 2011-02-22
affects: rhythmbox-ubuntuone-music-store → libubuntuone
Changed in libubuntuone:
status: Fix Committed → Fix Released
summary: - There's no navigation feature to get back to the main store page
- throughout the Ubuntu One store, forcing a restart of Rhythmbox
+ Music store widget should not navigate to external sites
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers