Container apps should use same keyboard layout as Unity 8

Bug #1566487 reported by Christopher Townsend on 2016-04-05
72
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Stephen M. Webb
Libertine
High
Christopher Townsend
xorg-server (Ubuntu)
High
Christopher Townsend
Xenial
Medium
Unassigned

Bug Description

[Impact]
XMir clients do not get keyboard layout set in Unity 8.

[Test Case]
1. Set keyboard layout to non-english
2. Start X application

Expected result:
Application uses selected layout

Observed result:
Application uses default layout

[Regression Potential]
Low. The change just connects the keyboard layout signal from Mir to Xkb.

Changed in libertine (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

On all applications, when I do use the physical keyboard I'm missing a several characters (like accents), and on all Xmir apps the keyboard layout configuration has no effect.

I don't want to be annoying or negative, but I want to make things very clear:

This renders the tablet useless to do any serious work by people who aren't native english speakers, and aren't geek enough to know the english keyboard layout even if they've never owned or seen one (at least a physical one).

lith (minilith) wrote :

With respect to "medium" importance: It doesn't make the recently released BQ M10 that is supposed to show off Ubuntu Touch too good, when the most prestigious apps ignore the keyboard layout. It makes the whole convergence thing pointless. Want to use LibreOffice with an external bluetooth keyboard as it was advertised? Doesn't work. Try again sometime later.

Changed in libertine (Ubuntu):
importance: Medium → High
peter waldman (waldman) wrote :

Affects me too and, according to my search result for a way to rectify the keyboard layout, annoys quite a number of other users too.
So I couldn't agree more with importance -> high.

Maartje Eyskens (maartjee) wrote :

In meantime, is there any way to manually set it (via the cli)? Being an azerty user this limits my M10 to only using the touch apps.

Detlef Passberger (j-2nfo-w) wrote :

Affects me too. Want to use LibreOffice, Gimp and gedit with an external bluetooth keyboard as it was advertised? Doesn't work.

Christopher Townsend (townsend) wrote :

After doing some more investigation, there is a new Mir input event called mir_event_type_keymap which is sent every time a Mir surface is focused. This event should be caught by Xmir and handled by applying the sent keymap to the current Xmir/Mir surface.

tags: added: xmir
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

See also: bug 1565236

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed

Hey Daniel,

I'm not I understand the correlation between this bug and bug #1565236. The referenced bug seems something specific to Unity 8 & Mir whereas this bug is about getting the keymap correct for the apps in the Xmir surface.

Changed in xorg-server (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)

I have a fix ready in the attached patch. The fix is in Xmir and the patch is just a refreshed xmir.patch with the added code. Let's try to get this in for OTA11.

This is a diff of the actual changes made.

no longer affects: libertine (Ubuntu)
no longer affects: libertine/trunk
no longer affects: libertine/devel
Changed in libertine:
status: Triaged → Invalid

The attachment "xmir.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Daniel van Vugt (vanvugt) wrote :

Thanks Chris. Fix committed:
https://git.launchpad.net/~xmir-team/xorg-server/+git/xmir/commit/?id=37929cdd62330eee3d3fd22273d7f5eeef06f220

You already seem to have permissions, so you are free to commit to Xmir git directly in future.

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed

A few more details:

Also affects login screen (I think it's also an Xmir app). and even on non Xmir apps, not all keys seem to work (like the @ and accents).
I haven't tried any fix.

Hope this helps, and thank you!

@ diogoconstantino,

You are hitting a different issue than what this bug is describing. The login screen is not an Xmir app. I believe the bug you are hitting is bug #1565236.

Changed in canonical-devices-system-image:
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High
milestone: none → 11
status: New → In Progress
Changed in xorg-server (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
description: updated

Hello Christopher, or anyone else affected,

Accepted xorg-server into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.18.3-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.3-1ubuntu3

---------------
xorg-server (2:1.18.3-1ubuntu3) yakkety; urgency=medium

  * debian/patches/xmir.patch:
    - Pass keymap from Mir to Xkb (LP: #1566487)
  * debian/patches/xmir-fixes.diff:
    - Merged into xmir.patch

 -- Robert Ancell <email address hidden> Fri, 29 Apr 2016 14:36:49 +0200

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
kevin gunn (kgunn72) on 2016-05-05
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Please test the -proposed package, it blocks the next SRU that is waiting in the queue. Thanks!

@pitti,

There is bug in the Xkb patch in Xmir that has been fixed and is in the Vivid overlay. I think Robert will need to respin the Xmir patch to fix the bug.

That said, I'll mark this verification-failed.

tags: added: verification-failed
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Christopher, or anyone else affected,

Accepted xorg-server into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.18.3-1ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Not wild about #if 0 debugging code making it into the SRU, but it *is* small and dead.

Daniel van Vugt (vanvugt) wrote :

Technically we're free to omit that from distro. Although it's imperfect it's also harmless. I expected to have that issue fixed before anyone rolled another Xmir update...

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.3-1ubuntu2.2

---------------
xorg-server (2:1.18.3-1ubuntu2.2) xenial; urgency=medium

  * debian/patches/xmir.patch:
    - Fix recently added keymap code
  * debian/patches/xmir-fixes.diff:
    - Merged into xmir.patch

xorg-server (2:1.18.3-1ubuntu2.1) xenial; urgency=medium

  * debian/patches/xmir.patch:
    - Pass keymap from Mir to Xkb (LP: #1566487)

 -- Robert Ancell <email address hidden> Wed, 04 May 2016 12:19:14 +1200

Changed in xorg-server (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xorg-server has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers