Lernid "Event Connection Interrupted" message due to nick/password issue

Bug #850419 reported by John S. Gruber
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lernid
Medium
John S. Gruber
telepathy-idle
New
Undecided
Unassigned
lernid (Ubuntu)
Undecided
John S. Gruber
telepathy-idle (Ubuntu)
Undecided
Unassigned

Bug Description

Lernid suggests that the Internet connection be reestablished, but that's no help.

The problem is that a registered nick can be locked at the server for a while after an attempt is made to use it without either using a password, or when supplying an incorrect one. Telepathy does not recognize this freenode nickserv behaviour and Lernid cannot distinguish between this situation and a network connection problem.

The message from the server that telepathy-idle lacks from its parsing table is:
:niven.freenode.net 437 * userid :Nick/channel is temporarily unavailable

After no attempt is to react to this for a while, this message is issued and the connection is closed by the server end:
ERROR :Closing Link: adsl-sb-067-061.wcnet.org (Connection timed out)

If this 437 error were reported as a nick error to the application program, Lernid (or other application program) could try logging on with a different nick.

The nick is again usable after the server finishes the unavailability time and the student can then again logon using the nick as long as the correct password is issued.

The problem only happens if the nick has "enforce" set on with nickserv, but this is common. Unfortunately only one faulty attempt to use a protected nick is enough to trigger this problem.

Lernid may be able to circumvent this problem, at some cost, by always signing on to nick with a random component, and then trying to switch to the correct nick after the connection has been completed.

Changed in telepathy-idle (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Changed in lernid (Ubuntu):
status: New → Confirmed
Changed in lernid:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telepathy-idle (Ubuntu):
status: New → Confirmed
Changed in lernid:
milestone: none → 0.8.5
Changed in lernid:
status: Confirmed → Fix Released
Changed in lernid (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.4 KiB)

This bug was fixed in the package lernid - 0.8.5

---------------
lernid (0.8.5) quantal; urgency=low

  * Release 0.8.5. (LP: #1039839)

lernid (0.8.4.11) precise; urgency=low

  * Merge lernid-proposed

lernid (0.8.4.10) precise; urgency=low

  * Merge translations

lernid (0.8.4.9) precise; urgency=low

  * Disable all plugins through webkit settings so they won't crash
    lernid. Future webkit releases may run plugins in a separate
    process allowing us to reconsider this eventually.
    lernid/widgets/Browser.py . Closes LP: #995695.

lernid (0.8.4.8) precise; urgency=low

  * Don't add irc logs for future events in lernid/widgets/Schedule.py

lernid (0.8.4.7) precise; urgency=low

  * Change version number and create new version of .pot files

  * Fix scrolling case when there are no sessions in the schedule timeframe.

  * Underline Irclog entries to make it apparent that they are clickable.

lernid (0.8.4.6) precise; urgency=low

  * Change version number and create new version of .pot files

  * Get rid of slide error message more quickly, and when a new attempt
    is made to download slides.

lernid (0.8.4.5) precise; urgency=low

  * Don't release the nick--it causes the server to change previous
    signons elsewhere to Guestn.

  * Add calendar override option for use in testing.

  * Create irclog lines for current and future sessions, too.

  * If there are no future sessions, scroll to the bottom of the calendar.

  * Add the --no-update command line option to supress lernid's
    scheduled schedule updates.

  * Scramble the calendar domain name before every calendar download

  * At disconnect time, be sure schedule _update handle is removed. Don't
    let an initial calendar load ending after an event is disconnected
    produce schedule the update chain.

  * Ignore callbacks from cancelled messages

  * Select time to trigger calendar updates from a list. At :06 after
    the hour and half hour. Other times are :01, :11, :21, :31, :41, :51

  * Add remarks about the schedule buttons in the lernid man page.

  * Clean up some corner cases when events are terminated. Schedule._event
    is now None when there is no event active. Rename irclog click callback.

  * Remove event interrupted message when the next connection is made.

  * When a new slide load attempt is made, stop outstanding I/O and retries.

  * Add a schedule refresh button

  * Clean up and simplify calendar reload scheduling. Only load it every
    ten minutes and once a night to produce a new irclog entry in the
    schedule.

  * Be sure we don't pre-announce the same session twice in a row.

  * Make server disconnections more robust

lernid (0.8.4.4) precise; urgency=low

  * New version number; new .pot file. Clear lintian errors

lernid (0.8.4.3) precise; urgency=low

  * Depend on python version 2.6 as lernid uses the io module

  * Don't reparse calendar unless it has changed. Simplify
    _calendar_refresh parameters.

  * Don't scroll schedule unless we have just connected to an event.`

lernid (0.8.4.2) precise; urgency=low

  * Increment release version by .1. Adjust version number in package.
    Make python-support a straight build depend...

Read more...

Changed in lernid (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers