lernid fails to launch 11.10 desktopcouch--('unauthorized', 'Authentication required.')

Bug #795138 reported by IdleOne
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Lernid
High
Unassigned
desktopcouch (Ubuntu)
Undecided
Unassigned
lernid (Ubuntu)
Undecided
Unassigned

Bug Description

lsb_release -a:
Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric

Traceback (most recent call last):
  File "/usr/bin/lernid", line 455, in <module>
    window = NewLernidWindow()
  File "/usr/bin/lernid", line 434, in NewLernidWindow
    window.finish_initializing(builder)
  File "/usr/bin/lernid", line 90, in finish_initializing
    if HAVE_APPINDICATOR and Preferences.get('show_appindicator'):
  File "/usr/lib/python2.7/dist-packages/lernid/CouchDBPreferences.py", line 75, in get
    klass = cls.get_instance()
  File "/usr/lib/python2.7/dist-packages/lernid/CouchDBPreferences.py", line 66, in get_instance
    cls._instance = cls()
  File "/usr/lib/python2.7/dist-packages/lernid/CouchDBPreferences.py", line 31, in __init__
    self._database = CouchDatabase(self._db_name, create=True)
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/server.py", line 101, in __init__
    oauth_tokens=oauth_tokens, ctx=ctx)
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/server.py", line 75, in __init__
    oauth_tokens=oauth_tokens, ctx=ctx, views_factory=views_factory)
  File "/usr/lib/pymodules/python2.7/desktopcouch/records/database.py", line 123, in __init__
    self._reconnect()
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/server.py", line 85, in _reconnect
    super(DesktopDatabase, self)._reconnect(uri=uri)
  File "/usr/lib/pymodules/python2.7/desktopcouch/records/database.py", line 139, in _reconnect
    self._server.create(self._database_name)
  File "/usr/lib/pymodules/python2.7/couchdb/client.py", line 193, in create
    self.resource.put_json(validate_dbname(name))
  File "/usr/lib/pymodules/python2.7/couchdb/http.py", line 405, in put_json
    status, headers, data = self.put(*a, **k)
  File "/usr/lib/pymodules/python2.7/couchdb/http.py", line 384, in put
    return self._request('PUT', path, body=body, headers=headers, **params)
  File "/usr/lib/pymodules/python2.7/couchdb/http.py", line 419, in _request
    credentials=self.credentials)
  File "/usr/lib/pymodules/python2.7/desktopcouch/records/http.py", line 251, in request
    raise Unauthorized(error)
couchdb.http.Unauthorized: ('unauthorized', 'Authentication required.')

Related branches

Revision history for this message
John S. Gruber (jsjgruber) wrote :
Changed in lernid (Ubuntu):
status: New → Confirmed
Revision history for this message
3vi1 (launchpad-net-eternaldusk) wrote :

Looks like this is still an issue with all the current updates as of 7/23.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Thanks for the bug report, IdleOne, and for the update, 3vi1. Thanks also to those who marked this bug as affecting them.

IdleOne, are you still experiencing this problem?

I'm able to run either the Ubuntu Lernid, or the one from the Lernid PPA just fine today after installing Oneiric from the 7/21 daily cd (written to usb stick) with the 7/23 updates installed. It seems appropriate to ask the question how are the failing systems different from the working ones?

Therefore, for all still experiencing this problem:

1. What version of the following packages are installed (since the development process can leave some things behind):
python-desktopcouch-records, desktopcouch, python-desktopcouch-application, couchdb-bin, python-couchdb?

Mine are:
python-desktopcouch-records 1.0.7-0ubuntu2
desktopcouch (same)
python-desktopcouch-application (same)
couchdb-bin 1.0.1-0ubuntu16
python-couchdb 0.8-0ubuntu1

2. Can you read your preferences using your browser?
e.g.
firefox ~/.local/share/desktop-couch/couchdb.html

After a pause and an automatic redirect you should be able to choose "lernid", and then pick the item with the random looking name and see your lernid preferences.

3. Is yours a fresh install or an upgrade from natty or before?

Thanks for your help in tracking this down.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

A couple of additional questions:

What version of Lernid are you running?

Have you done anything with Ubuntu 1 on your system.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Same as lp: #780972 ?

Revision history for this message
IdleOne (idleone) wrote :

python-desktopcouch-records 1.0.7-0ubuntu2
desktopcouch 1.0.7-0ubuntu2
python-desktopcouch-application 1.0.7-0ubuntu2
couchdb-bin 1.0.1-0ubuntu16
python-couchdb 0.8-0ubuntu1

 - Yes, I am able to see my preferences by doing: firefox ~/.local/share/desktop-couch/couchdb.html

 - This is a upgrade from ubuntu server 11.04 with kubuntu-desktop and all updates up to 7/23 installed: 3.0.0-6-server #7-Ubuntu SMP Wed Jul 20 15:18:56 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Changed in lernid:
importance: Undecided → High
status: New → Confirmed
Revision history for this message
3vi1 (launchpad-net-eternaldusk) wrote :

>> Same as lp: #780972 ?

Yes, I think it could be.

My versions of the packages are the same as IdleOne's, I can also bring up the prefereces, and my install was a clean Ubuntu 11.04 desktop install that was updated to the latest oneiric packages.

Linux saturn 3.0.0-6-generic #7-Ubuntu SMP Wed Jul 20 13:53:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Thanks for posting your versions.

What version of Lernid are you running?

Have you done anything with Ubuntu One?

Is gnome-keyring-daemon running for your sessions?

Revision history for this message
3vi1 (launchpad-net-eternaldusk) wrote :

Lernid version = 0.8.0.2

Yes - I have Ubuntu One configured and use it to synchronize a few directories/config files.

Yes - gnome-keyring-daemon seems to be running.

Revision history for this message
IdleOne (idleone) wrote :

lernid: Installed: 0.8.0.2

I am not using Ubuntu one but it is installed.
As for the keyring I suppose I have whatever Kubuntu uses.

Changed in desktopcouch (Ubuntu):
status: New → Confirmed
Revision history for this message
John S. Gruber (jsjgruber) wrote :

3vi1,

I see you reported a similar symptom when starting Firefox. How similar is its traceback to the one attached to this bug by IdleOne? Would you mind attaching it to this bug so we can have a look?

For all,

Can you circumvent this problem by creating and using a new user on your system?

Thanks.

Changed in lernid:
status: Confirmed → Incomplete
Changed in lernid (Ubuntu):
status: Confirmed → Incomplete
summary: - lernid fails to launch 11.10
+ lernid fails to launch 11.10 ('unauthorized', 'Authentication
+ required.')
summary: - lernid fails to launch 11.10 ('unauthorized', 'Authentication
- required.')
+ lernid fails to launch 11.10 desktopcouch--('unauthorized',
+ 'Authentication required.')
Changed in lernid:
status: Incomplete → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (8.2 KiB)

This bug was fixed in the package lernid - 0.8.2.2~lr2

---------------
lernid (0.8.2.2~lr2) oneiric; urgency=low

  * Oneiric release. (LP: #844923)
  * Merge changes to convert from python-central to dh_python2

lernid (0.8.2.2) natty; urgency=low

  * Ready for release

lernid (0.8.2.1) natty; urgency=low

  * Make schedule a bit easier to read by making font used for instructors one size smaller

lernid (0.8.2) natty; urgency=low

  * Add 'avoid-desktopcouch' debugging option.

  * Remove #ubuntu-classroom-es. Assign correct calendar to #ubuntu-charlas

  * Document the following merges in debian/changelog:

  * Add instructor names to schedule.

  * Add option -d (--debug) for message received and members changed events as
      well as for all other verbose messages. Makes --verbose less verbose.
      Fixes LP: #816080.

  * Couch desktopcouch in try: clause; ignore desktopcouch database if
      unavailable. Fixes LP: #795138 and LP: #516619 by this circumvention.

  * Use a config file as backup for desktopcouch. Window sizes and pane settings
      will not be restored. The config file is recreated each time lernid
      is run, whether or not desktopcouch is available.

  * Get the events from /etc/lernid-classrooms.d/* rather than from the
      Internet. Remove all but the last weeks events and scroll down
      to the current time. LP: #528870.

  * Add /etc/lernid-classrooms.d/ubuntu-classroom and
      /etc/lernid-classrooms.d/ubuntu-classroom-es

  * Add ubuntu-charlas chatroom choice. These implement the
      lernid-config-file-improvements blueprint
      basic requirements. Also fix LP: #533279 and LP: #793033.

  * Add button to open the slide file in the user's (external) browser.
      Add tooltip text to slide window giving the slide url.
      Resolves LP: #830856 and LP: #530817.

  * Add new [slidefile url] and [slidefile url 3] instructor commands to
      load a slide file during a session, and to load the slide file and then
      switch to the page.

  * Load slide file asynchronously using gio (rather than using threads).
      Again fixes LP: #530119. Fixes LP: #795347. Report downloading progress.
      Restablishes these two functions originally created by Peeyoosh
      Sangolekar.

  * Remove bold effect from the room names in the classroom and chatroom label.
      Include the '#' in the name, if someone had abbreviated it.
      Fixes LP: #806797.

  * Add a ZERO WIDTH SPACE and SIX-PER-EM SPACE following "QUESTION: " to help
      classbot pick out questions without regard to the word "QUESTION" as its
      language might not match the one lernid is using. Addresses LP: 808570.

  * Look for classbot messages in a case-insensitive manner. Mark its messages
      by making them italic. Fixes LP: #794126

  * Retrieve the value of "QUESTION:" from the session or the event. Look first
      for a question_token value in the session, then for a locale for the
      session, then for a question_token value for the event, then for a locale
      value for the event.

  * If locale is used and begins with es, translate QUESTION to spanish, otherwise
      leave as english.

  * Added a server variable to e...

Read more...

Changed in lernid (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers