change icon

Bug #500503 reported by Ddorda on 2009-12-26
This bug affects 5 people
Affects Status Importance Assigned to Milestone

Bug Description

The icon that Lernid uses ATM is an little Ubuntu symbol, which can't get to bigger sizes (for example when using AWN, or just a big panel) and is too much uses either.

i believe this icon should be changed. I thought of a graduation cap or a notebook, both with a little Ubuntu icon in involved in it (after all, it's about Ubuntu).

Jono Bacon (jonobacon) on 2009-12-26
Changed in lernid:
importance: Undecided → Low
milestone: none → 0.5
status: New → Confirmed
Shahar Or (mightyiam) wrote :

Several people looking at a bigger person, which has his mouth open or holds a teacher stick.

grofaty (grofaty) wrote :

Ddorda: ...both with a little Ubuntu icon...
Ubuntu icon should be avoided in the first place. I hope Lernid will become cross-distro program for learning. So other teams will most probably want to change the icon. I see this as a waste of time. Just make an icon that really reflects what program is about and that is learning.

Jono Bacon (jonobacon) wrote :

I am happy for it to not be an Ubuntu logo if needed.

Lasse Havelund (lhavelund) wrote :

grofaty: +1

I like the idea of a student cap, though. Perhaps there's already a Tango icon available that suits the purpose?

Ddorda (ddorda) wrote :

I've edited an image i found:
out of this one i made the attached SVG.
it would be nice if someone will make it better, since i made it with a program, and can't find out how to make it "cleaner".

Michael Budde (mbudde) wrote :

Here is my attempt. A pretty good one if you ask me. What do you think?

Vish (vish) wrote :

Wasnt sure if the team was interested in any other metaphors , but I tried a different version for the icon. [just a rough draft] :)

Emilien Klein (emilien-klein) wrote :

Isn't this a nice bikeshed!
Anyway, +1 for changing the logo, preferably not Ubuntu-related... I like Michael's student cap.

grofaty (grofaty) wrote :

The idea of student cap is interesting starting point. The same for board picture. My homble opinion is to use some kind of icon that is a symbol of learning and that is owl with the book.

I have searched around Google Images and found the following pictures.

Owl with reading book (not the best picture, but just like an idea):

Owl sitting on a book (owl is not best pictured it looks like a chicken, but just to illustrate an idea):

Owl with the light and standing on the book (I like this idea, but owl on the picture is not best art):

Owl with the book opened and having student cap (Owl is not looking the best, it should be no doubt that owl is on the picture):

If you like an idea someone could polish some of the picture and create icon.

Despite this "bug" looks like it is not important one, but I think it is. To make logo make it possible that other Linux-distro are not wasting the time creating something different.

I think this bug should be handled by design people and not programmers.

Michael Budde (mbudde) on 2010-01-28
Changed in lernid:
milestone: 0.5 → none
Emilien Klein (emilien-klein) wrote :

I like the idea of the owl for the logo, but it just wouldn't fit in an icon. Keeping just the student cap as the icon would work pretty well, IMHO.

Emilien Klein (emilien-klein) wrote :

Oh and yeah, raise the priority of this issue...

Michael Budde (mbudde) on 2010-01-29
Changed in lernid:
importance: Low → High
status: Confirmed → In Progress
Jack Leigh (leighman) wrote :

I like the idea of some kind of blackboard, personally, since that most resembles what's going on.

Michael Budde (mbudde) wrote :

I'm a fan of the blackboard too actually. It is not so dark, so I think it would scale better and it's also simple. Vish, do you have a SVG version?

Ddorda (ddorda) wrote :

IMHO the idea of a blackboard is nice, but must say this specific blackboard doesn't seem to look like an icon.
try to think how it will look as an 16X16 image...

and now when i think of it, wouldn't it be too much similar to the gnome-terminal and system monitor icons?

Elizabeth K. Joseph (lyz) wrote :

I quite like the blackboard (well, it's green) that we used as part of the actual Classroom logo.

Ddorda (ddorda) wrote :

Elizabeth: must say it is nice :D

Vish (vish) wrote :

Michael Budde , Attaching the source svg. [cleaned it up a bit]
I had earlier done only the 48p icon.
I havent yet done the smaller sizes yet , [will complete them and attach them within this week].

We would atleast need a 24px, 16px icon , any other sizes you require?

Emilien Klein (emilien-klein) wrote :

I will stick with my liking of the graduation cap, because IMHO the board will look like a green rectangle, once put as a small icon. You won't be able to see the E=mc2 white letters.
Don't get me wrong, I like the black board image, but I just think that it would not render well as a tiny icon. The graduation cap, with it's more particular form, is IMHO a better candidate for an icon.

Michael Budde (mbudde) wrote :

Vish: I think the logo would work better with something more simple than E = mc². I've attached a modified version that uses 'a b c' instead. What do you think? I think that the Purisa font fits quite nicely (available in the ttf-thai-tlwg).

Vish (vish) wrote :

Michael Budde , ah , I was thinking the same.

Comments on this report are fast ;)
I thought i'd test Emilien Klein's comment that it wont be visible on small sizes , and just gave it a shot , attaching the quick draft of icon in 24px , 16px.

But anyways, we can change it to ABC too , it's much easier to do in small sizes , the E = mc² was just an idea ;) I dont mind.

Vish (vish) wrote :

Michael Budde , Do you want the smaller icons[with abc] as well or is the 48px sufficient?

grofaty (grofaty) wrote :

Nobody likes the idea of owl. :?( OK, just kidding.

The board is good idea too. But I like original learning logo. Original learning board has board legs included. It also has beautiful shadow. I also more like a,b,c title then E=mc2, because E=mc2 would look like some kind of physic program.

I have little bit changed the board legs (see attached picture), I have removed "cross" from board legs. One friend of mine has said board legs looks like come kind of "Christian table". I don't want to get into religious conflict of any kind so it is safer to remove such a suggestions in the first place. I have also added extra shading where "cross" was drawn before.

Ddorda (ddorda) wrote :

In my opinion there's a problem with the board idea, since it doesn't look well when it's small, and it's with too many details.

n3storm (n3storm) wrote :

I mixed two icons a couple of days ago to represent "education", as this is the same concept a show you my hybrid in case you like it. Aknowledgements to Tango and Gnome-colors authors.


Jono Bacon (jonobacon) wrote :

n3storm - that looks great.

Can I recommend that we just pick something and move on. This bug has the opportunity to outlive us all. :-)

I am going to recommend we go with n3storm's icon. What do you think, folks?

I will look to Michael to pick the final one as he is now leading the project.

Ddorda (ddorda) wrote :

evenn I prefer the cap i must say n3storm's icon is nice! +1

Emilien Klein (emilien-klein) wrote :

You're right Jono, it's a nice bikeshed...
I indeed prefer n3storm's icon, because it will not look like a green rectangle, it has more colors. And the semi-circle reminds me of Ubuntu...


n3storm (n3storm) wrote :

Good point Emilien, I didn't realise the similarity. Attached you can find a more "brandy" version.

Emilien Klein (emilien-klein) wrote :

Well, this one is nice indeed, but I think that it would be best to distance Lernid from Ubuntu (see first comment by grofaty). I like your first version better because to me it's a slight reference, the reference in the newer version is too explicit...

I largely prefer the first, so that the program can have a wider use (other distros might not like to include such a direct reference to Ubuntu, and that would just hurt Lernid...)

Vish (vish) wrote :

n3storm's icon does look good. [It's a good mix of the gnome icons terminal and the user icon]

But you need to remember that the icon is a _128px_ icon. we cant get all those details when the icon zooms out to a 24px or 16px icon. which will be most commonly used in the system.

So , I'v added a teacher to the earlier icon in front of the board. [user icon from gnome]

n3storm (n3storm) wrote :

Emilien: I agree :) not branded icons for general purpose

Vish: The blackboard comes from Desktop icon from Gnome-colors, just for the reference.
Your icon looks nice :)

I have to disagree with you on one thing. Your icon has the very same problems as mine. for 24px and 16px Freedesktop guidelines (and Tango too) recommend a handmade low resolution version of the icon. Make a good looking icon for >128px and 16px is almosty impossible, except if you go for primitive forms, circles, squares, and so.

Vish (vish) wrote :

I'm aware of the guidelines ;) , [I'm part of the humanity icon team , breathe icon team and do icons for Upstream gnome icon theme as well]
Hence I'v already earlier suggested we also need icons in 24 and 16px atleast.

I think it should be a picture of Jono wearing the cap! :-)

Vish (vish) wrote :

Argh! lp ate half my comment earlier :/

Since the icon is 128px it will be scaled down 3times more and loose more details.

Irrespective of which icon is used :) , a few things you need to watch out for are:
- Lighting [the lower glow inside suits a monitor , but not for a blackboard]
- Shine [blackboards usually dont shine glossy like that] ,
- since the frame is white , when it scales down dark grey border will become small and almost invisible. the white would merge with the surrounding , and display only the green square.

Michael Budde (mbudde) wrote :

I have decided to go with Vish's logo. I'm going to push the change later tonight.

Thanks for the input everyone!

grofaty (grofaty) wrote :

Vish, n3storm and others, I suggest to create few sample of pictures (student cap, board with teacher etc) in ALL SIZES REQUIRED and attached pictures to this bug report. When we will see picture in sizes required I think we will decide very quickly. Like some simple voting (+1 for first suggestion).

I think this bug is very important and critical. That means it has to be solved quickly, so we can forget about this bug and go doing something more productive.

Michael Budde (mbudde) on 2010-01-31
Changed in lernid:
status: In Progress → Fix Committed
Michael Budde (mbudde) on 2010-02-24
Changed in lernid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers