Better reporting of codeshosting permission errors

Bug #93606 reported by Jonathan Lange on 2007-03-19
2
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Michael Hudson-Doyle

Bug Description

Many users have difficulties using the bzr branch hosting service on Lanuchpad. One of the most common problems is not being a member of the team owning the branch.

The permission error for branch access should be improved (as previously mentioned on bug 33223 and 85392).
 * "You cannot write to branch ~foo/bar/baz because you are not foo: https://launchpad.net/~foo"
 * "You cannot write to branch ~foo/bar/baz because you are not a member of foo: https://launchpad.net/~foo"

It would be good if the sftp server could give useful error messages to let user diagnose and correct this common problem themselves.

This bug was split from bug #85392.

Jonathan Lange (jml) wrote :

Setting to high priority, because bug #85392 is high.

Changed in launchpad-bazaar:
assignee: nobody → jml
importance: Undecided → High
status: Unconfirmed → Confirmed
Michael Hudson-Doyle (mwhudson) wrote :

Grabbing this.

Changed in launchpad-bazaar:
assignee: jml → mwhudson
Michael Hudson-Doyle (mwhudson) wrote :

Getting somewhere with this now.

Changed in launchpad-bazaar:
milestone: none → 1.1.11
status: Confirmed → In Progress
Michael Hudson-Doyle (mwhudson) wrote :

RF launchpad/devel 5165

Changed in launchpad-bazaar:
status: In Progress → Fix Committed
Michael Hudson-Doyle (mwhudson) wrote :

Rolled out with 1.1.11.

Changed in launchpad-bazaar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers