Comment 31 for bug 907675

Colin Watson (cjwatson) wrote :

The current blocker is https://github.com/twisted/twisted/pull/1202, which has had one review but isn't yet landed. Once that happens I'll push my branch for the actual Ed25519 key type, which is otherwise ready to go.

That still leaves the deployment issues I mentioned. IIRC from the last time I asked distro folks about this, upgrading Ubuntu 18.04 to OpenSSL 1.1.1b wasn't likely to be viable, as the changes were rather more invasive than the version difference suggests; so we probably are going to need some form of PyNaCl-based fallback code regardless. I haven't started on this yet.