Show string origin at string level

Reported by Claude Paroz on 2007-01-26
26
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Данило Шеган

Bug Description

This bug is the first step to resolve #60029. Rosetta should show whether a currently translated string is from upstream or if it has been superseded in Rosetta. I see three possible cases. They are detailed with an image in the following comments.

Claude Paroz (paroz) wrote :

Case 1: the translated string is the upstream one. The string icon has green color.

Claude Paroz (paroz) wrote :

Case 2: there is an upstream string, but the current translated string has been typed in Rosetta (or through non-upstream import). The current string has a blue icon, while the latest upstream "suggestion" is identified by his green icon.

Claude Paroz (paroz) wrote :

Case 3: there is no upstream string available. The currently translated string has a purple icon.

Carlos Perelló Marín (carlos) wrote :

I think something should be done, but I don't think the proposal is the right way to do it...

I would like some input from our UI guru, Matthew, about the best way to implement this.

The main problem with your suggestion is that the UI for reviewers that we implemented doesn't have such icons so it will not work at all.

If you want to see what I'm talking about, go to: https://edge.launchpad.net and try to translate something that you have rights to, you will get the new review UI.

Cheers.

Changed in rosetta:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Carlos Perelló Marín (carlos) wrote :

Matthew, could you give us some input here?

Thank you.

Changed in rosetta:
status: Confirmed → Needs Info
Claude Paroz (paroz) wrote :

I checked edge.launchpad.net. Interesting, indeed.
I don't care about colors being applied to icons. Maybe it could apply to another widget, or as background to some items. I let this to UI experts.

Matthew Paul Thomas (mpt) wrote :

Excellent idea, Claude! I think it would be worth trying a background color around the current translation. The color would be a pastel version of the equivalent color used on the translation status bar charts. That would not only help show where each translation had come from, it would also make the charts feel more trustworthy.

(If even pastel background colors turned out to be too distracting, we could try a colored dot next to the translation instead.)

Changed in rosetta:
status: Needs Info → Confirmed
Claude Paroz (paroz) wrote :

I'm afraid that a background for entire strings would be a bit disturbing, transforming the page in a "Christmas tree" :-) Anyway needs testing.
I suggest the implementation use CSS classes, (maybe at the <td> level) so as we can experiment different effects with different CSS.

Claude Paroz (paroz) wrote :

Sister Ann, Sister Ann, do you see anyone coming?
:-)

Séverin Lemaignan (skadge) wrote :

No news on that front ? It's a real problem for the translation team... a lot of upstream strings are overriden, and to keep synchro with upstream teams is hard...

Changed in rosetta:
assignee: nobody → danilo

After discussion with mpt, this is what we think would work best.

Instead of the current layout, use the following:

  English:
      Original string
  Current Serbian:
      So-so translation
  Upstream:
      Good translation
  Suggestions:
    - Blah-blah
      Coming from: <Somebody New>
    - Foo
      Coming from: used in Ubuntu Hoary package "evolution" by <Somebody Old>
    - Bar
      Coming from: suggested in Ubuntu Hoary package "evolution" by <Somebody Fresh>

Basically, the changes would be:
 1. separate out 'upstream' suggestion (if there is one) into another section called 'Upstream'
 2. Merge all other suggestions into one section and add some text to indicate whether they are used somewhere or just suggestions elsewhere
 3. Remove template name from the description in 'Coming from', but keep the link pointing directly to that template

David Planella (dpm) wrote :

Once this is implemented, it would also be very useful to display all strings from a module for which there is an upstream translation and it differs from the Ubuntu one.

I'm simply thinking of a new "Show" filter added to the existing ones ('all', 'untranslated', 'need review', 'translated'). Something along the lines of 'differs from upstream', which when selected would display only the strings different from upstream.

Claude Paroz (paroz) wrote :

What's important for me is to be able to quickly see when a string diverges from upstream, either with some color scheme or symbol. I don't know if you meant to print the upstream suggestion only when it is different from current one.

David, that's actually coming first (I've already implemented it as fix for bug #32471, it's in our code review process already), and it should be in Launchpad 1.1.6 which is what we call 'June' edition: https://launchpad.net/rosetta/+milestone/1.1.6

Claude, I know why you guys want this, and we are working on providing it for you. 'Upstream' section will be there only if the string coming from upstream is not being used (so, it's different from the current translation), and in combination with #32471, it should be simple to revert to upstream translations where needed.

Then, the only remaining bit to complete this would be to add an overview of modules with translations changed in Launchpad (basically, making the 'blue bars' in https://translations.launchpad.net/ubuntu/feisty/+lang/sr more accessible, since they are barely visible if a small percentage of strings has changed), so you know what templates might need reverting.

Changed in rosetta:
status: Confirmed → In Progress

Fixed in RF 4456.

Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers