launchpad lets me make bug metadata changes I can't undo, with no warning

Bug #717483 reported by Peter Maydell on 2011-02-11
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Unassigned

Bug Description

I just accidentally changed the status of a bug (#604872, as it happens) to "Fix Released". I then realised my error and tried to undo my change, and Launchpad didn't let me: the drop down box for status didn't have any other options.

Apparently status changes back out of 'fix released' need you to be in ubuntu-bugcontrol, so for a normal user this is a one-way non-undoable change.

I think Launchpad:
 * should provide a way of undoing this kind of error without needing to find somebody privileged (ie permit the state change if it is the reverse of the last one and done by the same person)
 * alternatively if that's not possible, should warn somehow about state changes which are not undoable by you

Changed in launchpad:
status: New → Triaged
importance: Undecided → High
Dylan McCall (dylanmccall) wrote :

I'm not sure I understand how this bug report is a duplicate of bug #520413. That one deals with someone (presumably with the appropriate privilege) being able to say "this user is spamming: revert all his spam!"

This bug report, on the other hand, involves users who _don't_ have the appropriate privileges who accidentally make a change and want to revert it themselves instead of creating work for said privileged users :)

Robert Collins (lifeless) wrote :

You are righ t- I have been doing a lot of triage recently. Sorry. I am however sure that there *is* a dupe for this, its just not that one.

Martin Pool (mbp) wrote :

I think this is bug 655385, and see also bug 659947.

There is a gross workaround, btw: change the task to be inside a project you own, change the status, then change it back in to the original project.

Peter Maydell (pmaydell) wrote :

I disagree -- 655385 seems to be more or less entirely about the Triaged state, people finding it confusing, suggestions to replace Triaged with something else, etc, and actually started out as an attempt to *restrict* the set of transitions people could make, not extend it as this bug suggests. I don't think it's particularly related to this bug and this bug shouldn't be marked a dup of it.

659947 doesn't seem to be related even tangentially, and is also about Triaged states specifically.

Robert Collins (lifeless) wrote :

It is certainly not bug 659947, but bug 655385 is on the surface fairly close. However 655385 is indeed about the narrower circumstances driven by confusion around triaged/confirmed; this bug is broader and encompasses the principle of undoing mistakes - particularly undoing mistakes where the 'undo' would look like an action the user cannot perform.

This comment in that bug - https://bugs.launchpad.net/launchpad/+bug/655385/comments/14 - is one I wrote trying to get to a clearer UI (but again, does not speak towards mistaken clicks etc at all).

I'll unduplicate this I think; that other bug can remain; it would be mitigated by this bug being fixed, but still be a UI issue.

Robert Collins (lifeless) wrote :

@poolie btw the workaround you suggest won't work for milestones, and won't work if/when more bug task transition cleanups are done. There is a bug somewhere saying that retargeting shouldn't permit injecting a state the user doing the retargeting could not make on a new task in the target context.

summary: - launchpad lets me make bug status changes I can't undo, with no warning
+ launchpad lets me make bug metadata changes I can't undo, with no
+ warning
Matthew Paul Thomas (mpt) wrote :

I get e-mail: “I am a new user and while checking the status of the Bug […], I accidentally changed it from Triaged to Opinion and I cant undo it. I am extremely sorry for my mistake, please change it back to Triaged.”

Johann Felix Soden (johfel) wrote :

Same mistake here: https://bugs.launchpad.net/ubuntu/+source/pdftk/+bug/779908/comments/19

Can someone undo this change and also fix this bug, please?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers