Use UbuntuBeta as font if it's available

Bug #620537 reported by Jonathan Lange on 2010-08-19
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical SSO provider
High
Łukasz Czyżykowski
Launchpad Blog WordPress Theme
High
Andrea Corbellini
Launchpad Development Wiki Moin theme
High
Andrea Corbellini
Launchpad Help Wiki Moin theme
High
Andrea Corbellini
Launchpad itself
High
Andrea Corbellini
Payment service
Undecided
Ricardo Kirkner
Ubuntu One Servers
High
Joshua Blount
Web themes
High
Matthew Nuzum
libubuntuone
Undecided
Unassigned

Bug Description

<sabdfl> hi folks, could you amend the LP CSS to use UbuntuBeta as a preferred font, if it's available, please?
 and let me know when that's on edge?

Only for things that currently use variable-width fonts, since monospace Ubuntu font is not available yet.

http://design.canonical.com/the-toolkit/guides-for-websites/ recommends: font-family: ‘Ubuntubeta’, 'Ubuntu', ‘Bitstream Vera Sans’, ‘DejaVu Sans’, Tahoma, sans-serif;

Related branches

Curtis Hovey (sinzui) wrote :

The ones we absolutely must fix is
    lib/canonical/launchpad/icing/style-3-0.css.in
    lib/canonical/launchpad/icing/print.css

/me thinks print looks odd and wonders if it actually works

Shipit is not ours, but it is cheap to fix
    lib/canonical/launchpad/icing/shipit.css

Our wikis are probably easy fixes to the theme's stylesheet.

Changed in launchpad-web:
assignee: nobody → Matthew Revell (matthew.revell)
Curtis Hovey (sinzui) wrote :

The ubuntubetafont project just renamed itself to ubuntu-font-family. We may want to ask someone in UX what the final name will be so that we can include it in the font string now.

Changed in launchpad-web:
assignee: Matthew Revell (matthew.revell) → nobody
Matthew Revell (matthew.revell) wrote :

Changing the font may require some tweaks to the CSS. On the front page, for example, the list of possible actions in the "Getting started" section is bunched up with the different font (see screenshot).

Curtis Hovey (sinzui) wrote :

I do not see that. I hacked my local CSS rules to always use the font for Launchpad when the font was released. This issue may relate to browser zooming.

The issue in the picture looks like a line-height problem and sprite do set that, but that picture shows them offset from their text just like they are now. The root-index has some line-height exceptions, but none are at play on that portlet. The markup in the template is somewhat dubious (inline elements with block element siblings). We could wrap the sentence in a <p> so that the browser does not need to guess at how to interpret the text next to the <ul>

The font names are likely to be:

 Ubuntu
 Ubuntu Mono

During the beta, they will be:

 UbuntuBeta
 UbuntuBeta Mono

So, if we could use those four names in the CSS, we should be just fine.
Leave UbuntuBeta over Ubuntu as we will continue development even after
the first release, so those with the latest Beta will always see that,
it would be great.

Mark

Changed in launchpad-web:
assignee: nobody → Andrea Corbellini (andrea.corbellini)
status: Triaged → In Progress
Changed in launchpad-news-wordpress-theme:
assignee: nobody → Andrea Corbellini (andrea.corbellini)
status: New → In Progress

I've written the necessary code for all the projects. The code branches are:

  lp:~andrea.corbellini/launchpad/ubuntu-font-620537
  lp:~andrea.corbellini/launchpad-news-wordpress-theme/ubuntu-font
  lp:~andrea.corbellini/launchpad-help-moin-theme/ubuntu-font
  lp:~andrea.corbellini/+junk/lp-dev-wiki-theme-ubuntu-font

I've replaced all the sans-serif fonts with:

  UbuntuBeta, Ubuntu, 'Bitstream Vera Sans', 'DejaVu Sans', Tahoma, sans-serif

and all monospace fonts with:

  'UbuntuBeta Mono', 'Ubuntu Mono', monospace

I've left "Trebuchet Ms, sans-serif" just to the "launchpad" text near the logo in the headings of {blog,dev,help}.launchpad.net, to respect the brandmark.

Mark Shuttleworth (sabdfl) wrote :

 On 21/08/10 17:21, Andrea Corbellini wrote:
> I've written the necessary code for all the projects. The code branches
> are:
>
> lp:~andrea.corbellini/launchpad/ubuntu-font-620537
> lp:~andrea.corbellini/launchpad-news-wordpress-theme/ubuntu-font
> lp:~andrea.corbellini/launchpad-help-moin-theme/ubuntu-font
> lp:~andrea.corbellini/+junk/lp-dev-wiki-theme-ubuntu-font

That's wonderful, thanks Andrea! This bug is linked to each of the
relevant projects, so everyone who needs to be in the loop should be.

I'm cc'ing Stuart Metcalf to ask him to make analogous changes to
projects overseen by his team.

Any other places we should apply this?

Mark

Changed in launchpad-news-wordpress-theme:
importance: Undecided → High
Changed in launchpad-help-moin-theme:
importance: Undecided → High
Changed in launchpad-dev-moin-theme:
importance: Undecided → High
Changed in launchpad-help-moin-theme:
assignee: nobody → Andrea Corbellini (andrea.corbellini)
status: New → In Progress
Changed in launchpad-dev-moin-theme:
assignee: nobody → Andrea Corbellini (andrea.corbellini)
status: New → In Progress

On Sun, 2010-08-22 at 12:19 +0100, Mark Shuttleworth wrote:
> Any other places we should apply this?

I think that the following websites should absolutely use the Ubuntu
Font: www.ubuntu.com, wiki.ubuntu.com, help.ubuntu.com, *qa.ubuntu.com,
www.canonical.com and one.ubuntu.com.

Mark Shuttleworth (sabdfl) wrote :

 On 22/08/10 12:57, Andrea Corbellini wrote:
> On Sun, 2010-08-22 at 12:19 +0100, Mark Shuttleworth wrote:
>> Any other places we should apply this?
> I think that the following websites should absolutely use the Ubuntu
> Font: www.ubuntu.com, wiki.ubuntu.com, help.ubuntu.com, *qa.ubuntu.com,
> www.canonical.com and one.ubuntu.com.

Agreed. B, Ale, Richard, can you influence the CSS on all of those
sites? Details at bugs.launchpad.net/bugs/620537

Mark

Curtis Hovey (sinzui) wrote :

Hi andrea.

I took a quick look at your changes. I expected to see Ubuntu /before/ UbuntuBeta so that Ubuntu is the preferred font for the site. Placing the beta font first means that some users may need to uninstall a font to see the official font. Do we intend to keep the beta font forever, if so then the order is probably right.

On Sun, 2010-08-22 at 17:12 +0000, Curtis Hovey wrote:
> I took a quick look at your changes. I expected to see Ubuntu /before/
> UbuntuBeta so that Ubuntu is the preferred font for the site. Placing
> the beta font first means that some users may need to uninstall a font
> to see the official font. Do we intend to keep the beta font forever, if
> so then the order is probably right.

Hi and thanks for your feedback. Mark said in comment #5:

> Leave UbuntuBeta over Ubuntu as we will continue development even
> after the first release, so those with the latest Beta will always see
> that, it would be great.

So I think that what I've done is right, or did I misunderstood
something?

Curtis Hovey (sinzui) wrote :

Sorry for introducing confusion Andrea.

You are correct. I should have finished drinking my morning coffee and read all the discussion before looking at the changes.

Mark Shuttleworth (sabdfl) wrote :

There will likely be a beta forever, with ever newer glyphs and updates,
so yes, beta should be preferred.

If people installed via a package from a repo, the package will be
updated as needed. If they installed manually then they will be forever
out of date, but that's understood, it's why we've run the beta as we
have :-)

Mark

FYI - for canonical.com and ubuntu.com this is already with Matt Nuzum -
to be implemented this week

(Dom had logged the bug
https://bugs.launchpad.net/ubuntu-website-content/+bug/615801)

Kind regards
B

On 22/08/10 13:03, Mark Shuttleworth wrote:
> On 22/08/10 12:57, Andrea Corbellini wrote:
>
>> On Sun, 2010-08-22 at 12:19 +0100, Mark Shuttleworth wrote:
>>
>>> Any other places we should apply this?
>>>
>> I think that the following websites should absolutely use the Ubuntu
>> Font: www.ubuntu.com, wiki.ubuntu.com, help.ubuntu.com, *qa.ubuntu.com,
>> www.canonical.com and one.ubuntu.com.
>>
> Agreed. B, Ale, Richard, can you influence the CSS on all of those
> sites? Details at bugs.launchpad.net/bugs/620537
>
> Mark
>
>

--
Birgit Oberlerchner
Canonical www.canonical.com | Ubuntu www.ubuntu.com
27th Floor, 21-24 Millbank Tower, London, SW1P 4QP
Direct: +44 (0)20 7630 2440

Mark Shuttleworth (sabdfl) wrote :

 On 23/08/10 09:18, Birgit Oberlerchner wrote:
> FYI - for canonical.com and ubuntu.com this is already with Matt Nuzum
> - to be implemented this week
>
> (Dom had logged the bug
> https://bugs.launchpad.net/ubuntu-website-content/+bug/615801)
>

Brilliant - thanks B - can't wait to see it in action! :-)

Richard Henry Lee (rhlee) wrote :

It has already been changed in design.canonical.com .

Changed in canonical-identity-provider:
milestone: none → 2.8.0
Changed in canonical-payment-service:
milestone: none → beta2.1

For ISD projects, we're already using UbuntuBeta but need to add the regular (ie: non-beta) version. Thanks for the heads-up.

Changed in canonical-identity-provider:
importance: Undecided → Medium
Changed in canonical-identity-provider:
assignee: nobody → Łukasz Czyżykowski (lukasz-czyzykowski)
status: New → In Progress
importance: Medium → High
Changed in canonical-identity-provider:
status: In Progress → Fix Committed
Changed in canonical-payment-service:
assignee: nobody → Ricardo Kirkner (ricardokirkner)
status: New → In Progress
Changed in canonical-payment-service:
status: In Progress → Fix Committed
Danny Tamez (zematynnad) on 2010-08-23
Changed in web-themes:
assignee: nobody → Danny Tamez (zematynnad)
Curtis Hovey (sinzui) on 2010-08-23
Changed in launchpad-web:
status: In Progress → Fix Committed
tags: added: qa-needstesting
Changed in launchpad-dev-moin-theme:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2010-08-29
tags: added: qa-ok
removed: qa-needstesting
Julien Funk (jaboing) on 2010-08-31
Changed in canonical-isd-qa:
importance: Undecided → High
milestone: none → canonical-identity-provider+2.8.0
Julien Funk (jaboing) on 2010-09-01
Changed in canonical-isd-qa:
importance: High → Undecided
milestone: canonical-identity-provider+2.8.0 → canonical-payment-service+beta2.1
Julien Funk (jaboing) on 2010-09-02
Changed in canonical-payment-service:
status: Fix Committed → Confirmed
Julien Funk (jaboing) on 2010-09-02
Changed in canonical-identity-provider:
status: Fix Committed → Confirmed
Changed in canonical-isd-qa:
status: New → Incomplete
tags: added: bug-1 bug-2

Change back to Fix Commited, as we don't need to add support for Ubuntu Mono because we are not using monospace fonts anywhere.

Changed in canonical-payment-service:
status: Confirmed → Fix Committed
Julien Funk (jaboing) on 2010-09-03
Changed in canonical-isd-qa:
status: Incomplete → Opinion
status: Opinion → Fix Committed
Changed in canonical-identity-provider:
status: Confirmed → Fix Committed
Julien Funk (jaboing) on 2010-09-03
Changed in canonical-isd-qa:
importance: Undecided → High
milestone: canonical-payment-service+beta2.1 → canonical-identity-provider+2.8.0
importance: High → Undecided
milestone: canonical-identity-provider+2.8.0 → canonical-payment-service+beta2.1
Julien Funk (jaboing) on 2010-09-03
Changed in canonical-isd-qa:
importance: Undecided → High
milestone: canonical-payment-service+beta2.1 → canonical-identity-provider+2.8.0
importance: High → Undecided
milestone: canonical-identity-provider+2.8.0 → canonical-payment-service+beta2.1
Julien Funk (jaboing) on 2010-09-07
Changed in canonical-isd-qa:
importance: Undecided → High
milestone: canonical-payment-service+beta2.1 → canonical-identity-provider+2.8.0
importance: High → Undecided
milestone: canonical-identity-provider+2.8.0 → canonical-payment-service+beta2.1
David Owen (dsowen) on 2010-09-07
Changed in canonical-identity-provider:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2010-09-09
Changed in launchpad-web:
status: Fix Committed → Fix Released
Changed in web-themes:
importance: Undecided → High
assignee: Danny Tamez (zematynnad) → nobody
Mat Tomaszewski (mat.t.) on 2010-09-09
description: updated

Ah, there's a bug in that guideline! It should be:

  font-family: UbuntuBeta, Ubuntu, 'Bitstream Vera Sans’, ‘DejaVu
Sans’, Tahoma, sans-serif;

Anybody know where I file a bug on the web guidelines?

Mark

Mat Tomaszewski (mat.t.) wrote :

  On 09/09/2010 14:30, Mark Shuttleworth wrote:
> Ah, there's a bug in that guideline! It should be:
>
> font-family: UbuntuBeta, Ubuntu, 'Bitstream Vera Sans’, ‘DejaVu
> Sans’, Tahoma, sans-serif;
>
> Anybody know where I file a bug on the web guidelines?
>
> Mark
>

Hi Mark,

This has already been updated couple of weeks ago and the currently
available document is correct:
http://design.canonical.com/the-toolkit/guides-for-websites/

Cheers,
mt

Matthew Nuzum (newz) on 2010-09-09
Changed in web-themes:
assignee: nobody → Matthew Nuzum (newz)
status: New → In Progress
Mark Shuttleworth (sabdfl) wrote :

No, the current document at that address fails to use BOTH UbuntuBeta
and Ubuntu. It uses only UbuntuBeta, which is not the font most people
will have on their systems. We don't want to go fixing all the sites
again in 2 weeks when the font is available to the world as Ubuntu, do we?

Mat Tomaszewski (mat.t.) wrote :

  On 09/09/2010 15:41, Mark Shuttleworth wrote:
> No, the current document at that address fails to use BOTH UbuntuBeta
> and Ubuntu. It uses only UbuntuBeta, which is not the font most people
> will have on their systems. We don't want to go fixing all the sites
> again in 2 weeks when the font is available to the world as Ubuntu, do we?
>

Indeed! As it turns out, I was referring to an earlier bug, which was
already addressed. I'm updating the document now. Apologies for the mix-up.

Mat Tomaszewski (mat.t.) on 2010-09-09
description: updated
Mark Shuttleworth (sabdfl) wrote :

OK, could all the folks that fixed this in their various sites check that they are using UbuntuBeta, Ubuntu, 'Bitstream Vera Sans’, ‘DejaVu Sans’, Tahoma, sans-serif;

That way, we won't have to fiddle this again.

In future, we'll have a nice single canonical.css somewhere so we don't have to hack around in a zillion different places ;-)

Martin Albisetti (beuno) on 2010-09-09
Changed in ubuntuone-servers:
assignee: nobody → Joshua Blount (jblount)
importance: Undecided → High
status: New → Triaged
Curtis Hovey (sinzui) on 2010-09-09
Changed in launchpad-help-moin-theme:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2010-09-09
Changed in launchpad-news-wordpress-theme:
status: In Progress → Fix Committed
Matthew Nuzum (newz) on 2010-09-09
Changed in web-themes:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2010-09-10
Changed in launchpad-news-wordpress-theme:
status: Fix Committed → Fix Released
Dave Morley (davmor2) on 2010-09-14
Changed in canonical-isd-qa:
status: Fix Committed → Fix Released
Changed in canonical-payment-service:
status: Fix Committed → Fix Released
Martin Albisetti (beuno) on 2010-10-05
Changed in ubuntuone-servers:
status: Triaged → Fix Committed
Curtis Hovey (sinzui) on 2010-10-07
Changed in launchpad-help-moin-theme:
status: Fix Committed → Fix Released
Changed in launchpad-dev-moin-theme:
status: Fix Committed → Fix Released
Martin Albisetti (beuno) on 2010-10-07
Changed in ubuntuone-servers:
status: Fix Committed → Fix Released
dobey (dobey) on 2011-02-23
affects: rhythmbox-ubuntuone-music-store → libubuntuone
Matthew Nuzum (newz) on 2011-06-08
Changed in web-themes:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers