hot_bugs view property inefficient, causes timeouts for Ubuntu's bugs homepage

Bug #512749 reported by Eleanor Berger on 2010-01-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Eleanor Berger

Bug Description

bugs.staging.launchpad.net/ubuntu times out trying to read the hot_bugs property. The time is spent in SQL, and we believe it is especially slow because we're lacking an index on bug.heat.

Related branches

The cause for this is that we forgot to update the index when renaming the column from hotness to heat.

Scratch that. The index is actually renamed in the original patch, the cause for this bug must be different.

Changed in malone:
importance: High → Critical
Deryck Hodge (deryck) wrote :

We fixed this by reverting the hot_bugtasks to hot_bugs change. Fix is in db-devel now.

Changed in malone:
status: Triaged → Fix Committed
Ursula Junque (ursinha) on 2010-01-27
tags: added: current-rollout-blocker
removed: oops
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers