[Support $support_id] should be added only if it isn't in the subject line already

Bug #50565 reported by Diogo Matsubara
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Medium
Francis J. Lacoste

Bug Description

When someone replies to a support notification, they usually generate a subject such as: "Re: [Support XX] ..." Now when we send out the notification about the comment, we simply add another [Support $id] prefix,
resulting in a subject like: "[Support 42] Re: [Support 42] ...".

We should add [Support $Support_id] only if it isn't already in the subject, just like mailman and other mailing list system do.

This bug is similar to bug 37454

Changed in launchpad-support-tracker:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Changed in launchpad-support-tracker:
assignee: nobody → flacoste
Changed in launchpad-support-tracker:
status: Confirmed → In Progress
Revision history for this message
Francis J. Lacoste (flacoste) wrote :

Fixed in RF 4524.

Changed in launchpad-support-tracker:
status: In Progress → Fix Committed
Revision history for this message
Francis J. Lacoste (flacoste) wrote :

Released on Valentine's day roll-out.

Changed in launchpad-support-tracker:
status: Fix Committed → Fix Released
Revision history for this message
Alex Muntada (alex.muntada) wrote :

Wasn't this supposed to be fixed already? Reporting just in case.

X-Launchpad-Question: distribution=ubuntu; sourcepackage=None; status=Answered;
 assignee=None; priority=Normal; language=en
References: <email address hidden>
To: <email address hidden>
From: williamts99 <email address hidden>
Subject: Re: [Support #3115]: Re: [Support #3115]: Re: [Support #3115]: Re:
 [Support #3115]: Re: [Support #3115]: Re: [Support
 #3115]: Re: [Support #3115]: Re: [Support #3115]:
 Re: [Support #3115]: Re: [Support #3115]: Re: [Support
 #3115]: Re: [Support #3115]: Re: [Support #3115]: Re: [Support #3115]: Re:
 [Support #3115]: Re: Can't get on line
Message-Id: <20070219233248.2764.86348.launchpad@<email address hidden>>
Date: Mon, 19 Feb 2007 23:32:48 -0000

Revision history for this message
Francis J. Lacoste (flacoste) wrote :

Yeah, this is fixed.

The problem is that the fix doesn't include data migration for tickets created before February 14th (when the fix was rolled out.)

This means that previous subjects (with the bug) are used for outgoing messages.

But the bug shouldn't manifest itself on tickets created on or after February 14th.

If you think we should do something about the previous ones, just file a new bug report.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers