Save original question when using 'Edit question'

Bug #50562 reported by Diogo Matsubara on 2006-06-21
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Now that a question is editable by any logged in user, we might see cases where a user wrongly edited the question of another user, rendering it useless.
I spotted this on https://launchpad.net/products/launchpad/+ticket/1085 and fixed it. I was only able to fix it because I have an email archive of all questions about launchpad.

We should implement an activity log or at least something similar to what bug reports have.

Changed in launchpad-support-tracker:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Francis J. Lacoste (flacoste) wrote :

Another solution would be to make the support request title and description read-only. Is there a reason to allow editing of them. A support request is really more like a conversation than like a bug report where the description summarizes the bug.

One reason I can think of for letting people edit the support request title and description is to make it easier to find for other people having a similar issue.
That way when people are about to file a new support request, the findSimilar() method would have a better chance to find it.

description: updated
Pierre Slamich (pierre-slamich) wrote :

I added in the dupe how my question was twisted (I had kept the history in Gmail)

Curtis Hovey (sinzui) on 2009-05-16
Changed in launchpad-answers:
importance: Medium → Low

I think that saving the original description and providing an "original description" link like bugs have would be a better solution than restricting who can edit question descriptions, not just because of the reason that Diogo Matsubara raises, but for another reason as well: Sometimes people edit their own question descriptions in such a way as to render a pristine original useful. I have seen two subcases of this. On the one hand, people frequently add things to their question descriptions that would have been better provided by posting in the question, and that can make the original question confusing. On the other hand, occasionally people replace the *entire* content of their own question's description with an answer to a request for information, which makes the question extremely difficult or impossible to work on without getting back (or having the asker reconstruct) the original description. This happened recently in a question in which I requested information.

Paweł (pmreez) on 2017-09-16
Changed in launchpad:
status: Triaged → Fix Released
assignee: nobody → Paweł (pmreez)
Colin Watson (cjwatson) on 2017-09-16
Changed in launchpad:
assignee: Paweł (pmreez) → nobody
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers