Unable to subscribe team to branch that I'm not a member of

Bug #497501 reported by Cody A.W. Somerville on 2009-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Tim Penhey

Bug Description

I'm unable to subscribe a team to branch that I'm not a member of. This is problematic since subscriptions double as access control for private branches.

Related branches

Curtis Hovey (sinzui) wrote :

This behaviour is correct since I do not think you want rivial to subscribe to your private branches. The owners of the branch are correct parties to add you.

affects: launchpad → launchpad-registry
Changed in launchpad-registry:
status: New → Incomplete

I am a member of the owning team. The issue is that I can't subscribe another team that I'm not a member of to the branch.

Curtis Hovey (sinzui) on 2010-04-08
affects: launchpad-registry → launchpad-code
Changed in launchpad-code:
status: Incomplete → New
Tim Penhey (thumper) wrote :

This was a design decision at the time, probably for no good reason. Can clearly fix this.

Changed in launchpad-code:
status: New → Triaged
importance: Undecided → High
tags: added: subscriptions trivial
Changed in launchpad-code:
milestone: none → 10.05
Tim Penhey (thumper) wrote :

To do this properly it isn't trivial. As if you add the wrong team by mistake you want to be able to remove that subscription (even if you aren't a member of that team), however you shouldn't be able to just remove any team, only those you added.

tags: removed: trivial
Changed in launchpad-code:
assignee: nobody → Tim Penhey (thumper)

If you're the owner of the branch, you should be able to un-subscribe anybody since subscriptions double as ACL for private branches.

On Tue, 25 May 2010 08:48:13 you wrote:
> If you're the owner of the branch, you should be able to un-subscribe
> anybody since subscriptions double as ACL for private branches.

That sounds reasonable.

Jonathan Lange (jml) wrote :

So, if we implement https://dev.launchpad.net/LEP/BetterPrivacy (touch wood), this bug won't matter quite so much.

Tim Penhey (thumper) wrote :

On Tue, 25 May 2010 09:21:25 you wrote:
> So, if we implement https://dev.launchpad.net/LEP/BetterPrivacy (touch
> wood), this bug won't matter quite so much.

Perhaps.

However this is an area where branch subscriptions differ from bug
subscriptions, and something I've been meaning to fix for around three years
now.

Tim Penhey (thumper) on 2010-05-29
Changed in launchpad-code:
status: Triaged → In Progress
Tim Penhey (thumper) on 2010-05-31
Changed in launchpad-code:
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2010-06-01
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-06-02
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers