Reporting duplicate bugs leads to receiving notifications for every duplicate of the original bug

Bug #418659 reported by NoahY
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Deryck Hodge

Bug Description

I recently reported a bug for Ubuntu:

https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/416767

and have found that since then, I have received notification of every fellow duplicate of the original bug, simply telling me that the other bugs were all duplicates of the original bug. Not only does that clog up my inbox, but it seems to be totally useless information to me. Is it really necessary to send emails to let everyone know that a fellow duplicate bug is also duplicate?

Related branches

affects: launchpad → malone
Revision history for this message
William King (quentusrex) wrote :

This also effects: https://bugs.launchpad.net/bugs/429322

I reported a bug, which turned out to be a duplicate of that bug. Now I get my inbox flooded with reports of other people having duplicates....

I only care about progress on this bug, not who is reporting duplicates of it.

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Confirmed.

Changed in malone:
status: New → Confirmed
Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Actually, Triaged, as this was acknowledged by the higher ups.

The following is a response from a dupe report of this one:

"We're working on a fix for this bug.

In this meantime, if you want to know which bug is biting you, go to your personal page in Launchpad, then Bugs, then List reported bugs. The link should be something like https://bugs.launchpad.net/~your_username/+reportedbugs. The bugs won't show up because duplicate bugs are hidden by default. So in that page click in Advanced Search, and uncheck Hide duplicate bugs. The bug should now show up, and you'll see that you're a direct subscriber of it because you reported it. To unsubscribe, click on Unsubscribe in the right of the bug page. This should stop the flood.

Sorry the inconvenience!"

Changed in malone:
status: Confirmed → In Progress
Changed in malone:
status: In Progress → Confirmed
Revision history for this message
Deryck Hodge (deryck) wrote :

BjornT confirms that a dupe subscriber currently should *not* receive notifications when the main bug adds another dupe. The bugs team will look into whether or not this works this week (I assume not) and look into getting a fix in place to ensure the behavior is right and well-tested.

Changed in malone:
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Björn Tillenius (bjornt) wrote : Re: [Bug 418659] Re: Reporting duplicate bugs leads to receiving notifications for every duplicate of the original bug

On Wed, Dec 09, 2009 at 02:03:03PM -0000, Deryck Hodge wrote:
> BjornT confirms that a dupe subscriber currently should *not* receive
> notifications when the main bug adds another dupe. The bugs team will
> look into whether or not this works this week (I assume not) and look
> into getting a fix in place to ensure the behavior is right and well-
> tested.

FWIW, the original bug report was bug 46237.

Revision history for this message
Brian Murray (brian-murray) wrote :

Does this bug report cover the case of the "main bug" receiving an e-mail for every bug that gets marked as a duplicate of it? If not what bug does or shall I report a different one?

tags: added: ubuntu-qa
Deryck Hodge (deryck)
Changed in malone:
assignee: nobody → Deryck Hodge (deryck)
status: Triaged → In Progress
Revision history for this message
Deryck Hodge (deryck) wrote :

This one was a bit of a pain to work out what was going wrong. For those who want the ins and outs of what was happening and how this will change, take a look at the linked branch merge proposal.

The short story is that once this change lands only subscribers of a duplicate will receive email about activity on that duplicate. Anyone subscribed via the master bug (be it directly or from another duplicate) will not be notified of changes to a duplicate. Also, there will be much more work continuing on making bug subscriptions better in the next couple months.

Deryck Hodge (deryck)
Changed in malone:
milestone: none → 10.06
Graham Binns (gmb)
tags: added: story-better-bug-notification
Revision history for this message
Ursula Junque (ursinha) wrote : Bug fixed by a commit
Changed in malone:
milestone: 10.06 → 10.05
status: In Progress → Fix Committed
tags: added: qa-needstesting
Ursula Junque (ursinha)
Changed in malone:
milestone: 10.05 → 10.06
Revision history for this message
Deryck Hodge (deryck) wrote :

Tested on staging and confirmed that adding a comment to a duplicate does not send mail to a person who is subscribed to the master bug. This will cover all other cases, since all the dupe subscribers who had been notified about actions on other duplicates (not their own) were being considered subscribed by the master bug.

tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui)
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions