Allow mass changing of bugs' statuses

Bug #41702 reported by Matthew Paul Thomas on 2006-04-27
104
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

It should be possible to change the status of multiple bugs at once. This should probably be done with a checkbox to the left of each bug in bug listings, and controls at the bottom of the list for manipulating the list.

For example, when a milestone is released, someone should be able to search for all Fix Committed bugs with the corresponding milestone, and mark them all as Fix Released.

See also bug 76083 about allowing the same thing for tags, and bug 4153 for assignees.

Martin Pool (mbp) wrote :

I can't believe no one asked for this before :-)

Changed in malone:
status: Unconfirmed → Confirmed
description: updated
Joey Stanford (joey) wrote :

Launchpad release admins need this as well.

Christian Reis (kiko) on 2007-06-02
Changed in malone:
importance: Medium → High
Changed in malone:
assignee: nobody → allenap
Changed in malone:
assignee: allenap → bjornt
Changed in malone:
assignee: bjornt → jsk
Björn Tillenius (bjornt) wrote :

The work will be specced out in 1.1.8, but implemented in 1.1.9.

Jonathan Knowles (jsk) wrote :

Re-targeting to milestone 1.1.10 in line with re-targeting of mass-bug-editing-phase-1.

Christian Reis (kiko) on 2007-10-29
Changed in malone:
milestone: 1.1.10 → 1.1.12
Jonathan Knowles (jsk) wrote :

I've prepared a fix for this bug.
Reassigned to Gavin Panella for final testing and landing.

Changed in malone:
assignee: jsk → allenap
status: Confirmed → In Progress
Gavin Panella (allenap) on 2008-01-30
Changed in malone:
milestone: 1.1.12 → none
Changed in malone:
assignee: allenap → nobody
status: In Progress → Confirmed
John A Meinel (jameinel) wrote :

Any update to the status? The last update says that there is a fix reading approximately 1 year ago, but it doesn't seem to have ever landed.

@jameinel, that fix wasn't really appropriate, and will not land anymore. In the short term, we're turning a lot of the bug listings into dynamically editable, which will make life much easier for you (though will still require many clicks). Longer-term, we will also try to find a good solution for mass-editing of bugs.

John A Meinel (jameinel) wrote :

Currently bzr uses "Fix Released" to mean a change has landed in development trunk, "Fix Committed" to mean it has been committed in a user's branch, and doesn't really use "In Progress".

It would make sense to move them all up a level, and change "Fix Released" so that it is in an actually Release/Release Candidate.

We haven't yet, pending this bug. I suppose if all the bugs on a Milestone page have a drop down that lets you quickly change Fix Committed => Fix Released, that might be sufficient. Certainly it would be ~2 clicks per bug, rather than about ~6+ as it stands now.

@jameinel, did you consider writing a script using the Launchpad webservice API to do that? There's a python library which makes it very easy to access the service. I'll be happy to give you give you a hand.

Bug #163694 may be related to this one.

Deryck Hodge (deryck) on 2009-08-26
tags: added: milestone-management
Steve Magoun (smagoun) on 2010-03-05
tags: added: oem-services
Robert Collins (lifeless) wrote :

@Martin we used to have this - it was removed because it was 'ugly'. This is is a feature request.

tags: added: feature

On 19 November 2010 02:03, Robert Collins <email address hidden> wrote:
> @Martin we used to have this - it was removed because it was 'ugly'.
> This is is a feature request.

You do realize the comment from me was over four and a half years ago? :-)

--
Martin

Robert Collins (lifeless) wrote :

On Fri, Nov 19, 2010 at 1:40 PM, Martin Pool <email address hidden> wrote:
> On 19 November 2010 02:03, Robert Collins <email address hidden> wrote:
>> @Martin we used to have this - it was removed because it was 'ugly'.
>> This is is a feature request.
>
> You do realize the comment from me was over four and a half years ago?
> :-)

Yes :(

Bryce Harrington (bryce) wrote :

The Redmine tracker has an interesting ui for doing this. You can Ctrl+click on multiple items within a bug listing view, then right-click to get a context menu which gives options for setting various parameters.

http://www.redmine.org/projects/redmine/issues

Joey Stanford (joey) on 2011-08-02
tags: added: linaro
Curtis Hovey (sinzui) on 2011-10-22
Changed in launchpad:
importance: High → Low
David Paleino (dpaleino) wrote :

I'd really like to re-raise the importance of this bug.

I just released wicd 1.7.1 after almost two years of development, and moving all the "Fix committed" bugs to "Fix released" is becoming tedious. :/

This really is a must-have.

Kindly,
David

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions