Bug subscription won't accept unsubscribe command

Bug #286193 reported by wulf solter on 2008-10-20
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Wouldn't it be nice if people could unsubscribe from bugreport emails simply by sending an email back with "unsubscribe"

I am sure there are people who entered their email addresses with best intentions, unaware what they were submitting to, and are now getting spammed with bugreports - some threads have almost 100 messages!

We can keep pointing people to the appropriate areas to unsubscribe, or we could make "reply with unsubscribe to unsubscribe" WORK!

Update: dupe bug 356571 has suggestions on how to approach this situation.

Hugh Winkler (hughw) wrote :

Agree. Just make Launchpad unsubscribe people if they send the single word message "unsubscribe" via email.

See https://bugs.launchpad.net/ubuntu/+source/compiz-fusion-plugins-main/+bug/183685

for an example. The noise from the unsubscribe messages is so great it obscures messages relevant to the bug.

Chris Halse Rogers (raof) wrote :

Invalidating the Ubuntu task, moving to Launchpad Bugs. This isn't an Ubuntu bug :).

It's worth noting that Launchpad *does* allow people to send an email to unsubscribe, but it requires
a) That it be all alone on a line, and preceeded by a space, like
"""
 unsubscribe
"""
and
b) A GPG signed email.

Given that it's fairly easy to spoof an email address, it's probably not a good idea to allow unsigned emails to unsubscribe.

Perhaps a way to achieve this goal would be to have a link to the "unsubscribe" page in the footer of the email notifications.

wulf solter (wulfsolter) wrote :

Sorry Chris, didn't realise id put it under Ubuntu bugs!

Like the idea of footer link. :)

or having an autoreply sent to the user email with a link and/or email address hash to unsubscribe like mailman does.

Ursula Junque (ursinha) on 2009-04-06
description: updated
Chris Jones (cmsj) wrote :

See Bug #356157 for a really perfect example of this. Users are using the Ubuntu problem reporting tools en masse, resulting in 61 duplicates in half a day, and a huge list of subscribers who have descended into a spiral of unsubscribe emails, with any useful discourse being totally lost in the noise.
(as it happens the bug is Fix Released, but the noise appears to have become self-sustaining).

This is also a powerful argument for the ability to lock down a bug, but that's a different discussion!

summary: - Mailing list wont accept unsubscribe
+ Bug subscription wont accept unsubscribe command

For the click-averse, this is the comment I made in dupe bug 356571:

---
On the more "popular" bugs, some users appear to be confused into thinking that they can unsubscribe either by sending mail to the bug with "unsubscribe" as the subject or message body.

How about we:

 a) let them
and
 b) minimise/hide those mails in the web UI
or
 c) Place an unsubscribe link at the bottom of bugmail. The existing rationale text is useful if you are familiar with Launchpad, but appears to fail to speak fully to some users.
---

I actually changed my thinking a little since I wrote that, I know think a), b) and c) should all be done, at the very least c) should be done. It needs to be an actual unsubscription link, not just a link to the bug. People have become used to a unique link to unsubscribe them from things.

James Troup (elmo) wrote :

unsubscribe

Matt Wheeler (funkyhat) wrote :

At the least I think emails that just contain ' unsubscribe', ' unsubscribe' and quoted text or unsubscribe in the subject should not be displayed on the bug as comments.

In the case of #356157 I think most people that tried to unsubscribe because the number of 'me too' and 'yay fixed thanks' messages was getting quite annoying. In the end the mass of 'unsubscribe' emails were even more annoying!

Matthew Paul Thomas (mpt) wrote :

(Locking down a bug report is bug 73122.)

Chris Jones (cmsj) wrote :

bug 48863 is very closely related to this, being simply about adding an unsubscribe link to emails.

On Tuesday 07 April 2009 14:04:46 James Troup wrote:
> unsubscribe

U need a "space" before it, and to send a PGP signed email (with a key already on LP)

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Martin Pool (mbp) wrote :

I think bug 357340 is a dupe of this too.

tags: added: ubuntu-qa
Curtis Hovey (sinzui) on 2010-01-18
Changed in malone:
status: New → Triaged
importance: Undecided → Low
tags: added: email
Graham Binns (gmb) on 2010-06-02
tags: added: story-better-bug-notification
Graham Binns (gmb) wrote :

This bug should be fixed at the same time as bug 357340

Brian Murray (brian-murray) wrote :

I was curious about how many of these unsubscribe messages might come and it what they look like. So I checked my ever so handy local ubuntu-bugs mailing list archive and searched for "^unsubscribe *$" with the following results.

2008-01
0
2008-02
0
2008-03
0
2008-04
3
2008-05
2
2008-06
0
2008-07
0
2008-08
2
2008-09
16
2008-10
89
2008-11
12
2008-12
0
2009-01
0
2009-02
0
2009-03
1
2009-04
52
2009-05
1
2009-06
10
2009-07
0
2009-08
0
2009-09
2
2009-10
3
2009-11
0
2009-12
1
2010-01
0
2010-02
0
2010-03
0
2010-04
1
2010-05
0
2010-06
0

I don't think is as big of an issue as it used to be.

summary: - Bug subscription wont accept unsubscribe command
+ Bug subscription won't accept unsubscribe command
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers