compiz.real crashed with SIGSEGV

Bug #183685 reported by don hardaway on 2008-01-17
This bug affects 178 people
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-main (Ubuntu)
Medium
Unassigned
Nominated for Dapper by sycylian

Bug Description

I'm sorry, I can report a bug automaticly but I do not understand more. Have you a french collector ?

Binary package hint: compiz

it just crashed for some unknown reason.

ProblemType: Crash
Architecture: amd64
Date: Wed Jan 16 22:19:09 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: nvidia
Package: compiz-core 1:0.6.99+git20080102-0ubuntu4
PackageArchitecture: amd64
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --loose-binding --sm-client-id default0 ccp
ProcCwd: /home/hardaway
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=C
 SHELL=/bin/bash
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? () from /usr/lib/compiz/libworkarounds.so
 ?? () from /usr/lib/compiz/libworkarounds.so
 ?? () from /usr/lib/compiz/libezoom.so
 ?? () from /usr/lib/compiz/libvpswitch.so
 ?? () from /usr/lib/compiz/libfade.so
Title: compiz.real crashed with SIGSEGV
Uname: Linux ubuntu 2.6.24-4-generic #1 SMP Mon Jan 14 18:19:11 UTC 2008 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev scanner video

don hardaway (don-hardaway) wrote :

StacktraceTop:workaroundsRemoveFromFullscreenList (w=0x18a5830) at workarounds.c:140
workaroundsHandleEvent (d=0x64e810, event=0x7fffb81da170) at workarounds.c:555
zoomHandleEvent (d=0x64e810, event=0x7fffb81da170) at ezoom.c:1907
vpswitchHandleEvent (d=0x64e810, event=0x7fffb81da170) at vpswitch.c:347
fadeHandleEvent (d=0x64e810, event=0x7fffb81da170) at ../../plugins/fade.c:537

Changed in compiz:
importance: Undecided → Medium
Changed in compiz:
assignee: nobody → compiz
status: New → Confirmed
Michael Vogt (mvo) wrote :

This seems to be reproducable by activating the gnome screensaver and then unlock the screen.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This should be fixed with the upload of compiz-fusion-plugins-main version 0.6.99+git20080121-0ubuntu1 in hardy.

Cheers,
 Michael

Changed in compiz:
assignee: compiz → mvo
status: Confirmed → Fix Released

Hi Michael,
I cant confirm that this can be reproduced with the method you say
because I had already installed the update before I read this message.
If u need me to roll back to verify that your method to reproduce this
is right on my system, I can. I just tried it and it was fine, so I
can confirm that the bug is not reproduceable in this way with the
latest patch....
Not terribly helpful I know.
Let me know if u want me to roll back the plugin package, ok?

Thanks
Keith

On Jan 21, 2008 6:21 AM, Michael Vogt <email address hidden> wrote:
> This seems to be reproducable by activating the gnome screensaver and
> then unlock the screen.
>
> --
> compiz.real crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/183685
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

kyleabaker (kyleabaker) wrote :

Yes, I got an email earlier that this bug was fixed with the latest patch.
I've had no problems since either.

On Mon, 21 Jan 2008 22:36:59 -0500, WorkingOnWise
<email address hidden> wrote:

> Hi Michael,
> I cant confirm that this can be reproduced with the method you say
> because I had already installed the update before I read this message.
> If u need me to roll back to verify that your method to reproduce this
> is right on my system, I can. I just tried it and it was fine, so I
> can confirm that the bug is not reproduceable in this way with the
> latest patch....
> Not terribly helpful I know.
> Let me know if u want me to roll back the plugin package, ok?
>
> Thanks
> Keith
>
> On Jan 21, 2008 6:21 AM, Michael Vogt <email address hidden> wrote:
>> This seems to be reproducable by activating the gnome screensaver and
>> then unlock the screen.
>>
>> --
>> compiz.real crashed with SIGSEGV
>> https://bugs.launchpad.net/bugs/183685
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>

--
kyle alexander baker

Sebastien Bacher (seb128) wrote :

The crash is still there but harder to trigger now

Changed in compiz:
status: Fix Released → Confirmed
Kjell Braden (afflux) wrote :

I'll assign this bug to compiz-fusion-plugins-main as the bug seems to be in the workarounds plugin.

Qchacho (ajmateusg) wrote :

The aplications in use at moment ocurred error: x-terminal, Downloader for X, Firefox, Nautilus and Synaptic.

Viggo (viggo) wrote :

compiz.real crashed when updating list of updates in updates manager. A crash report was uploaded, but i don't know where it went.

Chad Bernier (berniercr) wrote :

Compiz crashed several times a day for me when I installed Hardy a few days ago. That's how I found this bug. However, it has been updated a couple times since then. Compiz has not crashed at all today or yesterday. I currently have no real problems with hardy. I would like a more stable flash plugin, but that's a whole different issue. hardy is pretty much the same as Gutsy was.

Chad Bernier (berniercr) wrote :

I spoke too soon. it crashed again today. I was just using firefox as normal and it crashed. a crashed compiz really messed up my AWN.

I just wanted to say that I ve the same probleme with gusty as with Hardy...
I didn't in stall any extra packages for compiz on both system.
I've a HP pavillion dv9646 laptop

Malinen (malinmip) wrote :

Crashes on startup, submitted the report.

Same behavior. It crashes on startup.

Will Brady (wbrady4927) wrote :

I got the same crash on startup and I submitted the report.

Creak (romain-failliot) wrote :

Same crash, same stacktrace. But it's not always on startup, though it's often just a bit after.

didine23 (didine23) wrote :

The applications in use when errors appears: Firefox, Nautilus

Felix Martin Arrieta (nekete) wrote :

·Mine crashed while I was usin shift switcher (Covere mode)

Richard Craig (richard1gb) wrote :

Crashed when I opened Synaptic Package Manger and clicked cancel on the password prompt.

RedHeron (ray-jenson) wrote :

Crashed in Hardy when doing a mass-update.

Assid (assid) wrote :

Acutally i can confirm. After recovering from a standby or hibernate, it just crashes.

zegenie (zegenie) wrote :

Compiz crashes whenever I'm doing anything related to package management here, or whenever I do anything related to the software repositories ...

Chad Bernier (berniercr) wrote :

the lastest update appears to have helped. Before that update, it crashed randomly, as evidenced by everyone else above. After the update, it has crashed for me twice, both times at the same time firefox crashed. We'll see how that goes. I wish i could get firefox to stop crashing.

also, since the last updates of compiz and AWN, awn comes right back up properly once compiz is restarted.

Putinocchio (putinocchio) wrote :

Crashed at start up after: was messing with screenlets then restarted - compiz crashed :(

Ugrael (ugrael) wrote :

im use firefox when crashed.

dont know if im writing in the right thread but, im on arch 32bit desktop on a update-manager -d, after updating to the new kernel today compiz crashed for a split second after login, and posted nautilus cant be used at the moment cause of a failure..... or something like that, running Hardy by the way, kernel 2.6.24-7-generic

Kind regards Michael( MikeDK on freenode)

Sergey Tuchkin (amazon) wrote :

I wanna share my observations relative to spontaneous compiz crashes.

1. This crash occurs only under conditions of hi load average and insufficient free RAM:

top - 18:45:56 up 1 day, 1:46, 4 users, load average: 6.41, 6.37, 4.32
Tasks: 140 total, 5 running, 135 sleeping, 0 stopped, 0 zombie
Cpu(s): 19.4%us, 4.0%sy, 0.8%ni, 68.0%id, 7.1%wa, 0.3%hi, 0.6%si, 0.0%st
Mem: 515608k total, 506132k used, 9476k free, 7632k buffers
Swap: 2345436k total, 542644k used, 1802792k free, 119528k cached

2. Usually such conditions reached when many applications loaded, and I try to switch between them or start new big application (such as firefox or evolution)

3. Also I've mentioned that probability of a crash increases during installation of new packages (i.e. .deb packets being unpacked and installed). I suppose that working dpkg/aptitude consume much CPU/RAM in parallel with heavy input-output, which leads to abnormally hi load average

4. Before every crash the system becomes completely unresponsive for a few seconds. It also may occur because of hi load, but maybe compiz freezes just before crash?

Sorry for so many letters

Chad Bernier (berniercr) wrote :

Thank you for reporting that. You are not the first person to notice this, but you are the first to say so in this bug. Hardy has been under a much higher load all the time for me, just using firefox, flash, and compiz keeps this thinkpad r51 quite busy. Earlier versions of ubuntu ran just fine, usually the CPU was throttled down, and I got much longer battery life. Hardy needs to be updated everyday, even twice a day, which stresses it alot too. I first want the compuz fixed, than i hope they reduce resource usage. I won't be buying a new laptop until I really need it. I bought the thinkpad because they don't break, so it could be awhile.

JK (jke) wrote :

Hi,
Im having a lot of hassle with hardy on regular PCs too. That-s
something we have to go through, On my laptop, its a toshiba, I'm
considering installing a separate home using a live CD and going back to
feisty.

Chad Bernier wrote:
> Thank you for reporting that. You are not the first person to notice
> this, but you are the first to say so in this bug. Hardy has been under
> a much higher load all the time for me, just using firefox, flash, and
> compiz keeps this thinkpad r51 quite busy. Earlier versions of ubuntu
> ran just fine, usually the CPU was throttled down, and I got much longer
> battery life. Hardy needs to be updated everyday, even twice a day,
> which stresses it alot too. I first want the compuz fixed, than i hope
> they reduce resource usage. I won't be buying a new laptop until I
> really need it. I bought the thinkpad because they don't break, so it
> could be awhile.
>
>

apopovas (apopovas) wrote :

I was forced to do that already. As my laptop is toshiba and Hardy still
doesn't support toshiba's touchpad. It was quite difficult to work with it
as at work I don't connect mouse.

On 13/02/2008, JK <email address hidden> wrote:
>
> Hi,
> Im having a lot of hassle with hardy on regular PCs too. That-s
> something we have to go through, On my laptop, its a toshiba, I'm
> considering installing a separate home using a live CD and going back to
> feisty.
>
>
>

--
Sincerelly,
Andrius Popovas

Kyubutsu (jf) wrote :

still confirmed.
on update completion via update-manager.
simultaneous crash with emerald.
gateway mt3422 . 8.04 x86_64 - 2.6.24-7

Kyubutsu (jf) wrote :

on the high load subject, my mt-3422 is a dual core 64bit system; crash is detected even if only one app is running (in this case update-manager itself).

reh4c (gene-hoffler) wrote :

I only had synaptic and the game Powermanga running when the crash occurred.

Sergey Tuchkin (amazon) wrote :

Very good) I'll try to reproduce the crash with only synaptic running.
My system is Sempron 2800+ with 512MB DDR400 and Radeon 9800 with single
monitor

On Срд, 2008-02-13 at 11:32 +0000, Gene Hoffler wrote:
> I only had synaptic and the game Powermanga running when the crash
> occurred.
>

Cal Brower (sabrebutt) wrote :

Just crashed for me out of no where.

Kyubutsu (jf) wrote :

compiz crash after update/restart
last updated 02.14.2008
x86 2.6.24-7 celeron 2.0 [desktop]

Adam Weiss (cseadam) wrote :

happened to me with only synaptic running

2.6.24-7-generic #1 SMP Thu Feb 7 01:29:58 UTC 2008 i686 GNU/Linux

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Fri Feb 15 08:09:49 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: ath_hal nvidia cdrom
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --loose-binding --replace ccp
ProcCwd: /home/adam

Chad Bernier (berniercr) wrote :

here is a weird one. I load up a video in VLC, fine. I make it full screen, fine. I set it back to windowed mode, and it crashes instantly. when it's triggered this way, there is no crash report.

Kjell Braden (afflux) on 2008-02-17
Changed in compiz-fusion-plugins-main:
status: Confirmed → Triaged
Changed in compcomm-plugins-main:
status: Unknown → New
Changed in compcomm-plugins-main:
status: New → Fix Released
Kjell Braden (afflux) on 2008-02-21
Changed in compiz-fusion-plugins-main:
status: Triaged → Fix Released
description: updated
Kjell Braden (afflux) on 2008-09-13
description: updated
Changed in compcomm-plugins-main:
importance: Unknown → Undecided
status: Fix Released → New
Kjell Braden (afflux) on 2008-10-03
Changed in compcomm-plugins-main:
importance: Undecided → Unknown
status: New → Unknown
Changed in compcomm-plugins-main:
status: Unknown → Fix Released
Changed in compiz-fusion-plugins-main:
status: Fix Released → Confirmed
Changed in compiz-fusion-plugins-main:
assignee: mvo → pvillavi
Changed in compiz-fusion-plugins-main:
assignee: pvillavi → mvo
Kjell Braden (afflux) on 2008-10-16
Changed in compiz-fusion-plugins-main:
assignee: mvo → nobody
status: Confirmed → Fix Released
Changed in compcomm-plugins-main:
importance: Unknown → Undecided
status: Fix Released → New
Kjell Braden (afflux) on 2008-10-17
Changed in compcomm-plugins-main:
importance: Undecided → Unknown
status: New → Unknown
Changed in compcomm-plugins-main:
status: Unknown → Fix Released
bas328 (bas328) on 2008-10-23
Changed in compcomm-plugins-main:
importance: Unknown → Undecided
status: Fix Released → New
Kjell Braden (afflux) on 2008-10-23
Changed in compcomm-plugins-main:
importance: Undecided → Unknown
status: New → Unknown
Changed in compcomm-plugins-main:
status: Unknown → Fix Released
Pattrick (pattrick) on 2009-02-20
description: updated
delinux (denizerdogann) on 2009-06-10
Changed in compiz-fusion-plugins-main (Ubuntu):
status: Fix Released → Confirmed
ali medina (alimedina) on 2009-06-11
Changed in compcomm-plugins-main:
importance: Unknown → Undecided
status: Fix Released → New
Changed in compiz-fusion-plugins-main (Ubuntu):
status: Confirmed → Invalid
Changed in compcomm-plugins-main:
status: New → Invalid
Erich Stark (stark) on 2009-06-12
Changed in compiz-fusion-plugins-main (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Fix Released
505 comments hidden view all 549 comments
1 comments hidden view all 549 comments

Good Morning,

From the *24th October 2018*, my NEW physical address is:
*4A March Avenue,*
*Hayborough,*
*Victor Harbor, SA 5211*

Please note that all email and phone numbers remain the same.

A *map* for your convenience is below:
[image: image.png]

It is business as usual,along with a better premise and workshop area.

Note that I am right behind the *new ALDI store*.
[image: image.png]

Kind Regards,
Peter
--
*Peter Bowey*
Web Developer, Programmer & IT Engineering

Peter Bowey Computer Solutions

4A March Avenue,
Hayborough, South Australia, Australia
Tel.: 08 8552 8630
Email: <email address hidden> <email address hidden>
Web: http://www.pbcomp.com.au/ <http://www.pbcomp.com.au/>

<http://www.pbcomp.com.au/>
Making Windows, Macintosh & Linux work for you! <http://www.pbcomp.com.au/>

This email and any attachment is intended only for the exclusive and
confidential use of the addressee(s).

If you are not the intended recipient, any use, interference with,
disclosure or copying of this material is unauthorised and prohibited.
Notify us by a <http://www.pbcomp.com.au/>return email
<email address hidden> and then delete this message without copying or
publishing any privileged information contained therein.

Consider the environment before printing this e-mail.

Displaying first 40 and last 40 comments. View all 549 comments or add a comment.