Karma listing should link to activity and show more than 25 items

Bug #275938 reported by Sam Williams
510
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

When looking at the listing of Karma events you will see that you are limited to a single page of 25 items. In addition none of the Karma events are links to any actitivies, such as opening or closing bug reports, answering questions etc... For the listing to be useful each karma event entry should link to the actual activity that earned the credit. I believe this is particularly true in the case of a bug being rejected. It would be really nice to see what and why caused a rejection.

--- originally ---
Recently I logged into Launchpad looking for the status of a report I had opened. Sadly I was unable to find anything except under "Karma" showing that a bug was rejected. I have no idea if this bug was the one that was rejected but I was surprised to learn that the Karma activity list was limited to only one screen of 25 entries. I believe this option should provide more screens then this, otherwise what is the point?

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

This makes sense only in combination with bug 275941. The karma listing is barely useful at all, batched or not, without linking to the actual things you did.

Revision history for this message
Stuart Bishop (stub) wrote :

Karma was never intended to provide an audit trail (and cannot do so in its current design and implementation). What is the point of extending the karma activity log more than 25 entries?

Changed in malone:
status: New → Incomplete
Revision history for this message
Karl Fogel (kfogel) wrote :

But then what is the point of having the 25-entry log at all?

IOW, if Karma is not to be an audit trail, then it shouldn't show an audit trail :-). But if it is going to show something that looks like an audit trail, that trail could at least be useful in the ways users would expect -- namely, by each entry linking to what it refers to.

IRC conversation between Stu and me just now:

  <kfogel> https://edge.launchpad.net/~kfogel/+karma

  <kfogel> There's some recent activity there, but none of it gives
               details or links.

  <kfogel> It says "Bug Comment Added 2009-02-18 12:25:36 EST 21
               hours ago" but doesn't say which bug/comment. It's odd
               that we'd give such detailed information but leave out
               the key detail.

  <stub> kfogel: Lots of people want the Karma system to be an
               audit trail, but it isn't going to be one. It might be a
               reason to develop one though (separate from Karma)

  <kfogel> stub: agree that it's not necessary for karma to be an
               audit trail, but then it probably shouldn't include an
               audit trail on the karma page :-).

  <stub> kfogel: +1 :)

  <stub> I think whoever wrote that page wanted it to be an audit
               trail too ;)

Revision history for this message
Martin Pool (mbp) wrote :

Tim said in bug 333421 that "by design, the karma events don't map back to what caused the karma to come into existence.". If this is true, and since people commonly expect that it will link back, I'd like to at least see a Launchpad FAQ explaining why it's better that they don't.

I think I've heard that one reason is that database constraints would mean that an object could not be deleted if there are still karma events referring to it, which would mean in practice that objects could never be deleted. If this is the reason why we're not doing it let's just say so and dispel the uncertainty. On the other hand that does not seem technically insurmountable.

In this and other bugs people have said that the karma activity is "not meant to be an audit log". OK, but what precisely do you mean by "audit log" that distinguishes it from the karma view? The name connotes that it's security related or highly trusted; that doesn't seem strictly necessary for the karma log to be more useful.

If Launchpad is going to get some kind of Timeline view (per bug 261628) then presumably karma would just be presented as an annotation to the timeline view.

I think the main use case here is this: we present karma as an indication of how active a person has been in a project. A user viewing that number may want to click through to see what the person's really been doing: ok, they've filed a lot of bugs but are they sensible bugs? Are they a core developer or just a persistent gadfly? The user gets the impression that Launchpad must have this data but is refusing to disclose it, which is annoying.

Changed in malone:
status: Incomplete → Confirmed
description: updated
Revision history for this message
Martin Pool (mbp) wrote :

And the other related use case, though not specifically for karma, is in bug 315533, where users want to find out what they did recently. At least some of them are finding karma as a likely place for this, then being frustrated.

Revision history for this message
Martin Pool (mbp) wrote :

I don't think this is malone-specific.

affects: launchpad → launchpad-registry
tags: added: karma
Curtis Hovey (sinzui)
Changed in launchpad-registry:
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
era (era) wrote :

If the listing could indicate which package an activity occurred in (where pertinent) it would already help me at least.

I can imagine there are maintainers who only make changes within a small number of packages, and would not be helped by such a change, but for the rest of us, it might make the karma page a bit less infuriating and pointless.

Revision history for this message
Joel Pickett (jpickett) wrote :

Yeah at the moment the latest karma events could do with a bit more individual info.

miked (miked11)
Changed in launchpad:
status: Triaged → Opinion
Martin Pool (mbp)
Changed in launchpad:
status: Opinion → Triaged
杨敏 (mandy9337)
Changed in launchpad:
status: Triaged → Incomplete
status: Incomplete → Invalid
William Grant (wgrant)
Changed in launchpad:
status: Invalid → Triaged
Revision history for this message
Nathan Heafner (nathan1465-5) wrote :

Tim said in bug 333421 that "by design, the karma events don't map back to what caused the karma to come into existence."

if it did, users would have an incentive to work on higher yielding tasks first, creating an imbalance.

Revision history for this message
Jonathan Lange (jml) wrote : Re: [Bug 275938] Re: Karma listing should link to activity and show more than 25 items

On Wed, Dec 28, 2011 at 3:27 AM, Nathan nolast
<email address hidden> wrote:
> Tim said in bug 333421 that "by design, the karma events don't map back
> to what caused the karma to come into existence."
>
> if it did, users would have an  incentive to work on higher yielding
> tasks first, creating an imbalance.
>

If higher-yielding tasks had more value to a project, what would be
the problem with that?

jml

liu bo (1300733887-9)
Changed in launchpad:
status: Triaged → Fix Released
assignee: nobody → liu bo (1300733887-9)
Curtis Hovey (sinzui)
Changed in launchpad:
status: Fix Released → Triaged
Adolfo Jayme (fitojb)
Changed in launchpad:
assignee: liu bo (1300733887-9) → nobody
Revision history for this message
Curtis Hovey (sinzui) wrote :

liu bo, I see you have assigned yourself this task. I do not think this can be fixed by a novice developer. Launchpad does not have the information to make links about the activities. There might be information about the project the activity is, but it will not be possible to link to a bug or branch.

The +karma page could use the batch navigator to show more than the most recent 25, which is something a new developer can accomplish.

rosa maria (ceryscloe)
Changed in launchpad:
assignee: nobody → rosa maria (ceryscloe)
William Grant (wgrant)
Changed in launchpad:
assignee: rosa maria (ceryscloe) → nobody
Changed in launchpad:
status: Triaged → Fix Released
Colin Watson (cjwatson)
Changed in launchpad:
status: Fix Released → Triaged
Revision history for this message
mack thomas (mar76282) wrote :

Changed in launchpad:
status: Fix Released → Triaged

MrJOHN (johntin1988)
Changed in launchpad:
status: Triaged → Fix Released
Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

MrJohn, why did you change it to fix released?

Colin Watson (cjwatson)
Changed in launchpad:
status: Fix Released → Triaged
pangkit (skits168)
Changed in launchpad:
status: Triaged → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

pangkit, if you're actually working on this then feel free to explain. However, do pay attention to https://bugs.launchpad.net/launchpad/+bug/275938/comments/11 first.

Changed in launchpad:
status: In Progress → Triaged
api.ng (hektve)
Changed in launchpad:
assignee: nobody → HECTOR DAVID (hektve)
William Grant (wgrant)
Changed in launchpad:
assignee: HECTOR DAVID (hektve) → nobody
Adam Mc Cloud (dardamus)
Changed in launchpad:
status: Triaged → Fix Released
Colin Watson (cjwatson)
Changed in launchpad:
status: Fix Released → Triaged
information type: Public → Public Security
Colin Watson (cjwatson)
information type: Public Security → Public
information type: Public → Public Security
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Kadir Selçuk (turkdevops)
Changed in ubuntu:
assignee: nobody → Kadir Selçuk (turkdevops)
status: New → Fix Committed
Revision history for this message
Bernard Stafford (bernard010) wrote :

"When looking at the listing of Karma events you will see that you are limited to a single page of 25 items" ' Quote from Original Bug report.' I Translate Language, between 100 to 1500
Translations in 24 Hours. The Karma aspect should hold at least 3000 in the server cache for Translations & Code to reflect the actual Karma count. Some Code are in multiple pages long. Some translations start with all of the different version of Ubuntu that have not been translated thus far.
9 hours ago evince source package in Hirsute
13 hours ago exiv2 source package in Yakkety
13 hours ago exiv2 source package in Cosmic
13 hours ago exiv2 source package in Utopic
13 hours ago exiv2 source package in Trusty
13 hours ago exiv2 source package in Saucy
13 hours ago exiv2 source package in Raring
13 hours ago exiv2 source package in Quantal
13 hours ago exiv2 source package in Precise
For one example of only 100 translations.
Which does not reflect anything after I go past 25 entries to reflect for Karma Total.
I as others multi task. Some translations to Ubuntu Answers back to translations.
I Thank every one for all of your hard work and dedication for Launchpad and Ubuntu.

Changed in ubuntu:
status: Fix Committed → New
assignee: Kadir Selçuk (turkdevops) → nobody
Changed in launchpad:
assignee: Kadir Selçuk (turkdevops) → nobody
status: In Progress → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Colin Watson (cjwatson)
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers