DSP:+filebug ignores setting package name to "I don't know"

Bug #1847647 reported by tom on 2019-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Colin Watson

Bug Description

1. You can't easily go to report a bug on launchpad.net.

Go to https://bugs.launchpad.net/ubuntu/
Click Report a Bug
Expected Behavior: report a bug
Actual behavior: Taken to stupid words
Fix: Put a link on ALL major launchpad.net pages where you can click on "Report a Bug" and actually @#$(*& report a @#$( bug. Change all link text to https://help.ubuntu.com/community/ReportingBugs to "How to report bugs" or "Bug reporting FAQ", not "Report a bug".

2. You can't report a bug in "I don't know" package.

This bug is proof.
Got to report a bug. Click "I don't know" radio for "In what package did you find this bug?"
Optional: delete the package in unselected radio button below "I don't know"
Bug will still be filed under a package; in this case, evince. It should be filed under NO PACKAGE or DONTKNOW or some placeholder package for all the unknown-package bugs.

Related branches

tom (tombuntus) wrote :

Screenshot -- I promise I just clicked submit IMMEDIATELY after this screenshot, no funny business like retyping "evince" in the unselected radio button text field and selecting it...

Paul White (paulw2u) on 2019-10-12
affects: evince (Ubuntu) → launchpad
Colin Watson (cjwatson) wrote :

The behaviour when reporting bugs on Ubuntu (and only there) is a special case requested by Ubuntu in order to steer people towards using "ubuntu-bug" instead, because they were getting too many bug reports with insufficient information, and ubuntu-bug did a better job of collecting more useful details up-front. While this special case is implemented in Launchpad's code, the policy is not something that Launchpad can unilaterally change; a change to that would have to be discussed and agreed through Ubuntu's community processes.

I can confirm the "I don't know" part of this, though. Things work fine if you're starting from https://bugs.launchpad.net/ubuntu/+filebug?no-redirect, but if you're starting from https://bugs.launchpad.net/ubuntu/+source/evince/+filebug?no-redirect then the form processing code inappropriately uses field.packagename even though packagename_option is set to "none" in the submitted form. This is odd because FileBugViewBase.submit_bug_action is certainly trying to take packagename_option=none into account, so we'll need to dig into that and figure out what's going on. I'm repurposing this bug to cover just that part of your report.

summary: - Launchpad report bug is broken in so many ways
+ DSP:+filebug ignores setting package name to "I don't know"
Changed in launchpad:
importance: Undecided → Low
status: New → Triaged
tags: added: confusing-ui lp-bugs ui
Colin Watson (cjwatson) on 2019-10-14
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I've started a discussion about the bug-filing UX on https://lists.ubuntu.com/archives/ubuntu-devel/2019-October/040820.html. (Further comments should be in follow-ups there rather than here, so that they're all in one place.)

Download full text (3.2 KiB)

It's ok to hide/obscure Report a Bug. I figured it was for the reason you
said, and that's understandable to not want so many insufficient bug
reports. But it's not OK to mislabel FAQ as Report a Bug. That's misleading
and frankly infuriating. I've had so much trouble from that mislabeling.
Should I open another bug for that mislabeling?

On Mon, Oct 14, 2019, 03:41 Colin Watson <email address hidden> wrote:

> The behaviour when reporting bugs on Ubuntu (and only there) is a
> special case requested by Ubuntu in order to steer people towards using
> "ubuntu-bug" instead, because they were getting too many bug reports
> with insufficient information, and ubuntu-bug did a better job of
> collecting more useful details up-front. While this special case is
> implemented in Launchpad's code, the policy is not something that
> Launchpad can unilaterally change; a change to that would have to be
> discussed and agreed through Ubuntu's community processes.
>
> I can confirm the "I don't know" part of this, though. Things work fine
> if you're starting from https://bugs.launchpad.net/ubuntu/+filebug?no-
> redirect, but if you're starting from
> https://bugs.launchpad.net/ubuntu/+source/evince/+filebug?no-redirect
> then the form processing code inappropriately uses field.packagename
> even though packagename_option is set to "none" in the submitted form.
> This is odd because FileBugViewBase.submit_bug_action is certainly
> trying to take packagename_option=none into account, so we'll need to
> dig into that and figure out what's going on. I'm repurposing this bug
> to cover just that part of your report.
>
> ** Summary changed:
>
> - Launchpad report bug is broken in so many ways
> + DSP:+filebug ignores setting package name to "I don't know"
>
> ** Changed in: launchpad
> Importance: Undecided => Low
>
> ** Changed in: launchpad
> Status: New => Triaged
>
> ** Tags added: confusing-ui lp-bugs ui
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1847647
>
> Title:
> DSP:+filebug ignores setting package name to "I don't know"
>
> Status in Launchpad itself:
> Triaged
>
> Bug description:
> 1. You can't easily go to report a bug on launchpad.net.
>
> Go to https://bugs.launchpad.net/ubuntu/
> Click Report a Bug
> Expected Behavior: report a bug
> Actual behavior: Taken to stupid words
> Fix: Put a link on ALL major launchpad.net pages where you can click on
> "Report a Bug" and actually @#$(*& report a @#$( bug. Change all link text
> to https://help.ubuntu.com/community/ReportingBugs to "How to report
> bugs" or "Bug reporting FAQ", not "Report a bug".
>
> 2. You can't report a bug in "I don't know" package.
>
> This bug is proof.
> Got to report a bug. Click "I don't know" radio for "In what package did
> you find this bug?"
> Optional: delete the package in unselected radio button below "I don't
> know"
> Bug will still be filed under a package; in this case, evince. It should
> be filed under NO PACKAGE or DONTKNOW or some placeholder package for all
> the unknown-package bugs.
>
> To manage notifications about this bug go to:
> htt...

Read more...

Colin Watson (cjwatson) wrote :

On Mon, Oct 14, 2019 at 03:32:04PM -0000, tom wrote:
> It's ok to hide/obscure Report a Bug. I figured it was for the reason you
> said, and that's understandable to not want so many insufficient bug
> reports. But it's not OK to mislabel FAQ as Report a Bug. That's misleading
> and frankly infuriating. I've had so much trouble from that mislabeling.
> Should I open another bug for that mislabeling?

The existing https://bugs.launchpad.net/launchpad/+bug/873769 is
adequate for this; there's no need for a new one. And, as I noted, I
already started a discussion about this in a more appropriate place.

tom (tombuntus) wrote :

That bug is for the absence of a Report a Bug link, which Ubuntu community
purposely decided to leave off main pages. What I'm reporting is the
presence of mislabeled anchor text on the bug reporting FAQ link.

On Mon, Oct 14, 2019, 10:31 Colin Watson <email address hidden> wrote:

> On Mon, Oct 14, 2019 at 03:32:04PM -0000, tom wrote:
> > It's ok to hide/obscure Report a Bug. I figured it was for the reason you
> > said, and that's understandable to not want so many insufficient bug
> > reports. But it's not OK to mislabel FAQ as Report a Bug. That's
> misleading
> > and frankly infuriating. I've had so much trouble from that mislabeling.
> > Should I open another bug for that mislabeling?
>
> The existing https://bugs.launchpad.net/launchpad/+bug/873769 is
> adequate for this; there's no need for a new one. And, as I noted, I
> already started a discussion about this in a more appropriate place.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1847647
>
> Title:
> DSP:+filebug ignores setting package name to "I don't know"
>
> Status in Launchpad itself:
> In Progress
>
> Bug description:
> 1. You can't easily go to report a bug on launchpad.net.
>
> Go to https://bugs.launchpad.net/ubuntu/
> Click Report a Bug
> Expected Behavior: report a bug
> Actual behavior: Taken to stupid words
> Fix: Put a link on ALL major launchpad.net pages where you can click on
> "Report a Bug" and actually @#$(*& report a @#$( bug. Change all link text
> to https://help.ubuntu.com/community/ReportingBugs to "How to report
> bugs" or "Bug reporting FAQ", not "Report a bug".
>
> 2. You can't report a bug in "I don't know" package.
>
> This bug is proof.
> Got to report a bug. Click "I don't know" radio for "In what package did
> you find this bug?"
> Optional: delete the package in unselected radio button below "I don't
> know"
> Bug will still be filed under a package; in this case, evince. It should
> be filed under NO PACKAGE or DONTKNOW or some placeholder package for all
> the unknown-package bugs.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/launchpad/+bug/1847647/+subscriptions
>

Colin Watson (cjwatson) wrote :

On Mon, Oct 14, 2019 at 04:36:59PM -0000, tom wrote:
> That bug is for the absence of a Report a Bug link, which Ubuntu community
> purposely decided to leave off main pages. What I'm reporting is the
> presence of mislabeled anchor text on the bug reporting FAQ link.

I understand what you're reporting, but it's all part of the same thing.

Colin Watson (cjwatson) on 2019-12-16
Changed in launchpad:
status: In Progress → Fix Released
tom (tombuntus) on 2019-12-16
Changed in launchpad:
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

As I already mentioned here, the other part of this bug is being tracked elsewhere (specifically https://bugs.launchpad.net/launchpad/+bug/873769).

Changed in launchpad:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers