Code imports from sourceforge fails

Bug #1690613 reported by Karl Ellis on 2017-05-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

Hi,
 today i try to import my code from sf and after 5 attempts now i have import blocked.
This is the log:

2017-05-14 06:39:27 INFO Starting job.
2017-05-14 06:39:27 INFO Getting exising bzr branch from central store.
2017-05-14 06:39:27 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2017-05-14 06:39:27 INFO 35 bytes transferred
2017-05-14 06:39:32 INFO analyzing repository layout 0/99
2017-05-14 06:39:32 INFO
2017-05-14 06:39:33 INFO analyzing repository layout 0/99
2017-05-14 06:39:33 INFO
2017-05-14 06:39:35 INFO analyzing repository layout 0/99
2017-05-14 06:39:35 INFO
2017-05-14 06:39:36 INFO analyzing repository layout 0/99
2017-05-14 06:39:36 INFO
2017-05-14 06:39:37 INFO Importing branch.
2017-05-14 06:39:37 INFO determining revisions to fetch 0/99
2017-05-14 06:39:37 INFO
2017-05-14 06:39:37 INFO copying revision 0/2
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended by signal 11.

Thanks.
karl

Karl Ellis (soylent-tv) wrote :
no longer affects: truckliststudio
Karl Ellis (soylent-tv) wrote :

The branch is an import of the Subversion branch from

https://svn.code.sf.net/p/truckliststudio/svn/trunk.

Thanks.
karl

Colin Watson (cjwatson) wrote :

This appears to be due to a bug in the serf library used by Subversion, fixed in this upstream commit:

  https://svn.apache.org/viewvc?view=revision&revision=1712790

I'm preparing a backport for use by Launchpad's code import systems.

Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Critical
status: New → In Progress
tags: added: lp-code regression
Colin Watson (cjwatson) wrote :

We've rolled out the fix now, and your import is fixed.

Changed in launchpad:
status: In Progress → Fix Released
Karl Ellis (soylent-tv) wrote :

Thanks a lot Colin Watson!

Have a good day.
karl.

Tony (toekneemi) on 2017-08-22
Changed in launchpad:
assignee: Colin Watson (cjwatson) → Tony (toekneemi)
Colin Watson (cjwatson) on 2017-08-23
Changed in launchpad:
assignee: Tony (toekneemi) → Colin Watson (cjwatson)

Will be watching
On Wed, Aug 23, 2017 at 09:16 Colin Watson <email address hidden> wrote:

> ** Changed in: launchpad
> Assignee: Tony (toekneemi) => Colin Watson (cjwatson)
>
> --
> You received this bug notification because you are subscribed to
> Launchpad itself.
> Matching subscriptions: ppa me
> https://bugs.launchpad.net/bugs/1690613
>
> Title:
> Code imports from sourceforge fails
>
> Status in Launchpad itself:
> Fix Released
>
> Bug description:
> Hi,
> today i try to import my code from sf and after 5 attempts now i have
> import blocked.
> This is the log:
>
> 2017-05-14 06:39:27 INFO Starting job.
> 2017-05-14 06:39:27 INFO Getting exising bzr branch from central
> store.
> 2017-05-14 06:39:27 INFO [chan bzr SocketAsChannelAdapter] Opened
> sftp connection (server version 3)
> 2017-05-14 06:39:27 INFO 35 bytes transferred
> 2017-05-14 06:39:32 INFO analyzing repository layout 0/99
> 2017-05-14 06:39:32 INFO
> 2017-05-14 06:39:33 INFO analyzing repository layout 0/99
> 2017-05-14 06:39:33 INFO
> 2017-05-14 06:39:35 INFO analyzing repository layout 0/99
> 2017-05-14 06:39:35 INFO
> 2017-05-14 06:39:36 INFO analyzing repository layout 0/99
> 2017-05-14 06:39:36 INFO
> 2017-05-14 06:39:37 INFO Importing branch.
> 2017-05-14 06:39:37 INFO determining revisions to fetch 0/99
> 2017-05-14 06:39:37 INFO
> 2017-05-14 06:39:37 INFO copying revision 0/2
> Import failed:
> Traceback (most recent call last):
> Failure: twisted.internet.error.ProcessTerminated: A process has ended
> with a probable error condition: process ended by signal 11.
>
> Thanks.
> karl
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/launchpad/+bug/1690613/+subscriptions
>

dmoore (damien-moore) wrote :

How do I go about getting this import fixed?

https://code.launchpad.net/~codeblocks-devs/codeblocks/trunk

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions