soyuz emails are vague about why they are being sent to a given user

Bug #117155 reported by Julian Edwards on 2007-05-27
10
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Colin Watson

Bug Description

After the upload-notifications branch is landed, Soyuz emails will contain a footer saying:

You are receiving this email because you are the uploader, maintainer or
signer of the above package.

which is good, but not optimal. It's best if the rationale is customised based
on the recipient. We have a helper class INotificationRecipientSet that can
be used to implement this.

See also bug #3797.

Related branches

lp:~cjwatson/launchpad/upload-mail
William Grant: Approve (code) on 2015-08-26
description: updated
Changed in soyuz:
status: Unconfirmed → Confirmed
Celso Providelo (cprov) on 2009-04-29
Changed in soyuz:
importance: Undecided → High
milestone: none → pending
status: Confirmed → Triaged
visibility: private → public
summary: - Soyuz emails should describe better the reason for receiving them.
+ soyuz emails are vague about why they are being sent to a given user
Robert Collins (lifeless) wrote :

There are essentially three separate implicit subscriptions here, one for uploader, one for maintainer, one for signer, and if we had a notification service doing the actual sending this would just fall out from that.

tags: added: notifications
Colin Watson (cjwatson) on 2015-08-25
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-08-26
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-09-01
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers