Launchpad doesn't use specified revision of nest-part branch in recipes

Bug #949829 reported by Mantas Kriaučiūnas on 2012-03-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
bzr-builder
Medium
Unassigned
launchpad-buildd
Low
Unassigned

Bug Description

I need to build package using specified revision of nest-part branch, see:

https://code.launchpad.net/~baltix-members/+recipe/indicator-sensors-dev

Firstly I've created this recipe:
nest-part packaging lp:~alexmurray/indicator-sensors/packaging debian debian revno:9

But it seems this recipe simply uses latest brach of lp:~alexmurray/indicator-sensors/packaging instead of revision 9 (which has correct build dependencies - libnotify4-dev), so, I got a build error, see https://launchpadlibrarian.net/90424230/buildlog.txt.gz

I've read https://help.launchpad.net/Packaging/SourceBuilds/Recipes#Specifying_revisions but there is only example about merge, not about nest-part :(

Aaron Bentley (abentley) said in Question #185183 that I should report a bug :)

Curtis Hovey (sinzui) on 2012-03-08
Changed in launchpad:
status: New → Triaged
importance: Undecided → Low
tags: added: recipe
Jelmer Vernooij (jelmer) on 2012-03-08
Changed in bzr-builder:
status: New → Triaged
importance: Undecided → Medium
Colin Watson (cjwatson) on 2014-07-31
affects: launchpad → launchpad-buildd
Jelmer Vernooij (jelmer) wrote :

It looks like the as_text() method on nest-part is broken.

This patch should fix it:

=== modified file 'recipe.py'
--- recipe.py 2011-12-15 17:26:04 +0000
+++ recipe.py 2014-08-05 00:54:25 +0000
@@ -750,7 +750,7 @@
             target_revid_part = " %s%s" % (
                 target_subdir, revid_part)
         elif self.target_subdir is not None:
- target_revid_part = " %s" % self.target_subdir
+ target_revid_part = revid_part
         else:
             target_revid_part = ""
         return "%s %s %s %s%s" % (

Though it obviously also needs test, etc.

Martin Schläffer (mschlaeffer) wrote :

Any progress on this? Since this bug also affects me, I could test.

Changed in bzr-builder:
status: Triaged → Confirmed
status: Confirmed → Invalid
status: Invalid → Opinion
William Grant (wgrant) on 2015-09-21
Changed in bzr-builder:
status: Opinion → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers