Misleading symlink in shared folder vanishes peerindex (folders)

Bug #188587 reported by Riksha on 2008-02-03
2
Affects Status Importance Assigned to Milestone
Lanshark
Undecided
Jonas Wagner

Bug Description

A misleading symlink in a shared folder vanishes the index of shared folders of the affected peer in the GUI.
Webinterface returns a "404 - File not found" error.

Jonas Wagner (veers) wrote :

Hi Riksha,
Thank you for your bug report. I was able to reproduce and fix it!
Created commit 019c70d: Fixes https://bugs.launchpad.net/lanshark/+bug/188587
- Jonas

Changed in lanshark:
assignee: nobody → veers
status: New → Fix Committed
Tim LePes (luvdownbabylon) wrote :

I was about to submit a new bug report but thought this *could* be the same issue. I get the 404 errors in web interface (forgot to mention that in the text I had prepared), so that caught my attention. I also use symlinks so I checked and lo, there be a naughty broken symlink. I removed the scoundrel and flazaam... it is working fine now! So I can confirm the behavior here. I am happy to have my share working and glad to know the bug is fixed for the next release. God, you don't get this level of support from commercial vendors. Same day I find a bug I find it fixed, with a good lead for how to work around it. Awesome. Well it is lucky timing too but still the openness and response time are worlds apart on the whole. Kudos and keep up the good work! And yes, I have been running open source for years. But the development model still deserves to be recognized. Don't want to become so used to it that I forget to appreciate what we have. Thanks for all the great work!

Tim

Tim LePes (luvdownbabylon) wrote :

eh... well i guess i didn't notice but it was 1yr ago, not the same day :/ and after i got all glowy/praisey. well, i still think the program is neat and like some of the ideas.. and i am still happy to have the answer to my problem.

peace

pioruns (pioruns) wrote :

Somebody still developing this application? Or it is already dead? O_o

Jonas Wagner (veers) wrote :

I think I'm still alive ;) But I was indeed to lazy to make a release. But it is fixed in the git version so if you are affected use that one.

Jonas

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers