landscape-config --help doesn't work without being root

Bug #613256 reported by Jamu Kakar on 2010-08-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Medium
Free Ekanayaka
landscape-client (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

It would be nice if 'landscape-config --help' always worked.

Jamu Kakar (jkakar) on 2010-08-03
Changed in landscape-client:
milestone: none → 1.6.0
Changed in landscape-client:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Free Ekanayaka (free.ekanayaka)
Changed in landscape-client:
status: In Progress → Fix Committed
Changed in landscape-client:
milestone: 1.6.0 → 1.5.5
Andreas Hasenack (ahasenack) wrote :

Confirmed fixed on maverick's package.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in Lucid and Karmic packages

Colin Watson (cjwatson) wrote :

landscape-client (1.5.5-0ubuntu0.10.10.0) maverick; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).

 -- Andreas Hasenack <email address hidden> Wed, 08 Sep 2010 15:34:09 -0400

Changed in landscape-client (Ubuntu):
status: New → Fix Released
Changed in landscape-client:
milestone: 1.5.5 → 1.5.5.1
Andreas Hasenack (ahasenack) wrote :

The nomination for Maverick can be dropped as it was fixed in 1.5.5.

Changed in landscape-client (Ubuntu):
status: Fix Released → Fix Committed

Accepted landscape-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in landscape-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted landscape-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in landscape-client (Ubuntu Karmic):
status: New → Fix Committed
Changed in landscape-client (Ubuntu Jaunty):
status: New → Fix Committed
Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the lucid 1.5.5.1 package in proposed.

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the 1.5.5.1-0ubuntu0.9.04.0 package from proposed (jaunty).

Andreas Hasenack (ahasenack) wrote :

Confirmed fixed in the karmic package from proposed (1.5.5.1-0ubuntu0.9.10.0)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.10.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.10.04.0) lucid-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.10.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.10.0) karmic-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.5.5.1-0ubuntu0.9.04.0

---------------
landscape-client (1.5.5.1-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * The client network plugin would send erroneous data if a network
    interface was removed (and its kernel module removed as well) and
    then readded (LP: #641264).

landscape-client (1.5.5-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream version (LP: #633468)

    - The --help command line option can now be used without being
      root (LP: #613256).

    - The client Unix sockets and symlinks are now cleaned up at shutdown.
      Without this cleaning, the client could refuse to start because of a PID
      collision (LP: #607747).

    - The network traffic plugin didn't use to take into account integer
      overflows. This would cause the plugin to send negative values
      sometimes (LP: #615371).

    - If a payload had many user activities in it, only the last one would be
      carried out (LP: #617624).

    - The Eucalyptus plugin was not enabled by default, which means the Cloud
      Topology feature of Landscape was not available (LP: #614493).
 -- Andreas Hasenack <email address hidden> Mon, 20 Sep 2010 13:52:49 -0300

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers