KDE 4.6.1: KMail can't connect to KWallet

Bug #731835 reported by Alvin on 2011-03-09
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned
Ubuntu
Undecided
Unassigned
openSUSE
Unknown
Medium

Bug Description

In each user session, KMail fails to connect to KWallet and asks for passwords.
This error appears:

KDE Wallet Service
There have been repeated failed attempts to gain acess to a wallet. An application may be misehaving.

KMail will also no longer store the given passwords. In the next session, they will be asked again.

Version: 1.13.6 (using KDE 4.6.1)
OS: Linux

Since I updatet KDE from 4.6.0 to 4.6.1, Kmail (I use it with kontact) doesn't connect to kwallet any more. It fails at the beginning of my user session and asks every few minutes again for password. Always after some unsuccessful connections to kwallet, a small window appears with some message like "kmail couldn't connnect to kwallet a few times, maybe a bug in the program"(my DE is german). Other programs such as kopete or quassel are still working well with kwallet.

Reproducible: Always

Steps to Reproduce:
→ Enter new user session
→ enter kwallet password
→ try to check mails

Actual Results:
kmail connecting to kwallet fails and asks for a password manually.

Expected Results:
kmail should connect correctly to kwallet and use its stored password to check the mails.

Happend after update: KDE 4.6.0 → 4.6.1
Kmail wasn't updatet.

J have the same problem:-(

After switching from KDE 4.4.5 to 4.6.1 (still using the old KMail 4.4.10) I had to remove KMail from automatic starting during login b/c it is too fats for the kwallet.
Starting KMail manually after I logged in however works

I agree, kmail/kontact does not wait for me to enter the password of kwallet but it starts immediately.

Romain Perier (rperier) wrote :

- which kubuntu version do you use ?
- Is there additional information in ~/.xsession-errors ?

thanks in advance

Changed in opensuse:
importance: Unknown → Medium
status: Unknown → New

On Wednesday 09 March 2011 10:38:32 Romain Perier wrote:
> - which kubuntu version do you use ?
10.10 (Maverick)

> - Is there additional information in ~/.xsession-errors ?

Nothing useful on first sight. I'll attach the file.

Alvin (alvind) on 2011-03-10
description: updated
Asraniel (asraniel) wrote :

I have the same problem on two of my computers. Really annoying. Is there a way to go back to kde 4.6.0 ? 4.6.1 seems really buggy. There are also other bugs related to kontact, but i'm going to search for the corresponding bugs.

Same problem here on two computers.
I tried to remove the kwallet password (setting it to empty) so that it open imediately. This did not help. Kwallet tells me that an application tried to use it several time without success.

The same happens when trying to add a new mail account. Checking store IMAP password results in a popup saying that KWallet is not available when kwalletd is clearly running and the wallet manager runs fine.

Hi, i have the same Problem. I'm using Kubuntu 10.10 (Maverick) with the Kubuntu-ppa (ppa:kubuntu-ppa/backports).
For me, the bug only appears when I start Kmail the first time after booting kubuntu. So Kmail can access the KWallet after closing and starting it again.

Can't reproduce that any more (KDE 4.6.2, KDEPIM 4.11). The only difference now is, that kontact asks for kwallet password not only when checking mails at the beginning, but also when sending a mail the first time in a session. If that's what it should be or not, I don't know.

(Sorry, of course I mean KDEPIM 4.4.11 …)

(In reply to comment #2)
> After switching from KDE 4.4.5 to 4.6.1 (still using the old KMail 4.4.10) I
> had to remove KMail from automatic starting during login b/c it is too fats for
> the kwallet.
> Starting KMail manually after I logged in however works

FWIW:
This was solved by recompiling the Gentoo package with USE flag +semantic-desktop (https://bugs.gentoo.org/show_bug.cgi?id=363683)

Georgi (gkourtev) wrote :

I have it also on a Kubuntu 11.04, KDE 4.6.2, Kontact 4.4.10, Kmail 1.13.6

I can confirm this for KMail 1.13.6 (Kontact 4.4.10) on KDE 4.6.3 (Kubuntu 11.04 64-bit).

My first IMAP account (set up back on KDE 4.4.2) behaves as expected, but with my second IMAP account (set up a few days ago) I got the message that KWallet was unavailable when setting up the account, and having declined the option to have KMail store it in its own configuration files, I got asked for the password every time I started Kontact, and the error about KWallet not being available every time I closed it.

However, I have managed to workaround the problem (touch wood) using the first account as a template. With Kontact/KMail closed:
1. Open ~/.kde/share/config/kmailrc.
2. Locate the configuration block for the offending account and change 'store-passwd=false' to 'store-passwd=true' (and save).
3. Note the numeric identity for the account at the start of that configuration block (say, Account 1234567890)
4. Open up KDE Wallet Manager, and the default wallet
5. Find the entry 'kmail', select 'Passwords' and right-click or press Ins to add new entry.
6. Name the entry after the numeric account identity (e.g. account-123457890) and add the password (and save).

I presume this means that KMail now has a problem with writing passwords to KWallet, and won't change the 'store-passwd' setting until it has, but that it has no trouble reading from KWallet.

Torsten Krah (tkrah) wrote :

Same problem, standard natty install.

Kristof Bajnok (kristof-bajnok) wrote :

Since upgrading to Natty, after a couple of hours of normal usage, kwallet starts complaining about the repeated failed attempts, then kmail stops getting access to the saved passwords. After restarting kmail, everything becomes OK for another couple of hours.

I've found nothing spectacular in .xsession-errors, but I can attach if it would be any help.

Changed in ubuntu:
status: New → Invalid
Torsten Krah (tkrah) wrote :

Hi Fabio - may it be possible to know, why you marked this as "invalid"?

(In reply to comment #9)
> I presume this means that KMail now has a problem with writing passwords to
> KWallet, and won't change the 'store-passwd' setting until it has, but that it
> has no trouble reading from KWallet.

Same experience here in Kubuntu 11.04, KDE SC 4.6.4 KMail 1.13.6.

I have 2 IMAP accounts that works OK but when I added a new POP3 account KMail can communicate with KWallet. I'll try your workaround and see if it works for me.

Created attachment 60989
Error msg screenie

*** This bug has been confirmed by popular vote. ***

Changed in opensuse:
status: New → Confirmed

Same here on Kubuntu 11.04 with KDE 4.6
and on my notebook running KDE 4.7 and KDEPIM 4.7 (KMail2)

The workaround doesn't work, as i already have saved them but changing is impossible because of this bug.

I also get a notice that some application is failing accessing kwallet many times

This looks like a duplicate of the (older) https://bugs.kde.org/show_bug.cgi?id=261559 .

Jürgen (j-w-ott) wrote :

kmail has become close to unusable too bad

Torsten Krah (tkrah) on 2012-04-26
Changed in ubuntu:
status: Invalid → Confirmed

Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.

Changed in opensuse:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.