Unofficial Package Updates for Kubuntu

OpenGL composition broken after KDE 4.5 update using the Kubuntu backports

Reported by Ricardo Sansores Aguilar on 2010-08-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned

Bug Description

After upgrading to KDE 4.5 using the Kubuntu backports after a normal reboot (no crashes), Kwin composition was broken. If I activate and deactivate the composition I get this message in the notification icon:

The following desktop effects could not be activated:

Blur
Desktop Cube Animation
Sticky Windows, etc., etc, etc....

If I change the composition method to Xrender it works just fine. But if I return to OpenGL I get the message mentioned. If I disable the functionality verification and try OpenGL I get a completely black screen.

I have an Nvidia GeForce GTS 360M card using the official Nvidia drivers (256.35). Kubuntu 10.04 x64. No problems before this update, I haven't changed the Nvidia driver in a couple of months so this bug must have relationship with the KDE 4.5 update.

If you need more information just ask for logs (giving me the place to look for them :) please)

PD: One day before this behavior I worked with an external monitor. After using it everything appeer to be working ok. Im not sure if this can have any relation.

Rave[N]Black (blackravener) wrote :

similar situation here. I even reinstalled Kubuntu from scratch. It worked fine, but as soon as KDE 4.5 is loaded - compositing is gone.

I tried enabling Xrender which works but is extremely slow. After enabling Xrender I cannot switch back to the OpenGL, so I have no compositing at all.

I tried compositing with radeon drivers and with oficial ATI drivers, but nothing worked.

I have ATI HD Radeon 4670 on Dell Studio XPS 1645 with i7 CPU, running Kubuntu 10.04 x64

guillem (serra-guillem) wrote :

Same problem here with nvidia Geforce FX 5500 after updating to KDE 4.5. When enabling Composite and OpenGL X start to blink. Before updating composite worked flawlessly.

When Compositing disabled, the problem disappears.

$glxinfo

ame of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
    GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float,
    GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap,
    GLX_EXT_framebuffer_sRGB, GLX_NV_present_video
GLX version: 1.3
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer,
    GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5500/AGP/SSE2
OpenGL version string: 2.1.2 NVIDIA 173.14.27
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
OpenGL extensions:

.xsession-errors

Rave[N]Black (blackravener) wrote :
Download full text (4.6 KiB)

Just installed Kubuntu 10.10 Beta on a different laptop with ATI Radeon X2100 card.

Can't enable desktop effects with KDE 4.5.0

Upgraded to KDE 4.5.1 and still can't enable desktop effects.

The only thing I get under Desktop Effects in Settings is "Desktop effects are not available on this system due to the following technical issues:" and no mention of that the issues are.

$glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_INTEL_swap_event
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap,
    GLX_INTEL_swap_event
GLX version: 1.4
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap, GLX_INTEL_swap_event
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RS690 791F) 20090101 x86/MMX+/3DNow!+/SSE2 NO-TCL DRI2
OpenGL version string: 1.5 Mesa 7.8.2
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_half_float_vertex, GL_ARB_imaging, GL_ARB_multisample,
    GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_provoking_vertex, GL_ARB_shadow, GL_ARB_shadow_ambient,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_MESAX_texture_float,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_array_bgra,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements...

Read more...

Reiger (jm-ouwerkerk) wrote :

For info see also:
http://blog.martin-graesslin.com/blog/2010/09/driver-dilemma-in-kde-workspaces-4-5/
http://blog.martin-graesslin.com/blog/2010/09/demystifying-opengl-desktop-effects/

So to summarise according to Mr. Graesslin some drivers incorrectly report support for features that they do not support properly at all, and -as I understand it- when kwin tests the reported functionality it crashes. This crash is then detected and kwin disables desktop effects.

¿Some way to disable the hardware checks mentioned in the article? In KDE 4.4 I was able to use the composition without a single crash for weeks, so bypass this validations wouldn't be a problem for me. Im using the latest official Nvidia drivers with the same behaivior and the article mentions that this should not happend.

Quoting Martin:

"Apparently not when it comes to the free graphics drivers (please note and remember: we do not see such problems with the proprietary NVIDIA driver!)"

Mikael Bergqvist (mikaelb) wrote :

I see the same behaviour with AMD Catalyst drivers, as well as with radeon (on the same computer). Before upgrade Composition worked well, now I see the same as #3:

"Desktop effects are not available on this system due to the following technical issues:", with no mentioning of the reason.

Yves Glodt (yglodt) wrote :

Same thing here as in comment #7. Compositing with radeon r600 has been broken since somewhere in the betas of 10.04 for me. Hope I will get it back one day ;-)

Yves Glodt (yglodt) wrote :

Oops, it worked in 10.04 in fact, but broken when I updated to 10.10 beta, and never came back. I run natty now and nothing has changed.

Mikael Bergqvist (mikaelb) wrote :

There is a discussion about this at:
http://kubuntuforums.net/forums/index.php?topic=3113529

The suggested workaround there by "Rog131" worked for me.

>Editing the ~/kde/share/config/kwinrc.
>
>Before:
>Code:
>...
>DisableChecks=false
>...
>OpenGLIsUnsafe=true
>
>After:
>Code:
>...
>DisableChecks=true
>...
>OpenGLIsUnsafe=false
>...

Yves Glodt (yglodt) wrote :

The workaround works for me as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers