Comment 7 for bug 1823741

Ron Burkey (rburkey) wrote :

Yesterday I had checked about 30 or so schematics, Jon, with perhaps 2/3 of them passing ERC and 1/3 failing. (That's just a general idea, not exact counts.) I only rechecked 5 of them with last night's build. 4 that failed yesterday still fail today, and 1 that passed yesterday still passes. It's probably of no use to you, but their URLs are:

* Fail 1: https://github.com/virtualagc/virtualagc/tree/schematics/Schematics/1006556r
* Fail 2: https://github.com/virtualagc/virtualagc/tree/schematics/Schematics/1006557D
* Fail 3: https://github.com/virtualagc/virtualagc/tree/schematics/Schematics/2003305B
* Fail 4: https://github.com/virtualagc/virtualagc/tree/schematics/Schematics/2005269-
* Success: https://github.com/virtualagc/virtualagc/tree/schematics/Schematics/1006559D

Unfortunately, I don't understand the build system, so I don't really understand how to verify that the latest build I just installed (from PPA "deb http://ppa.launchpad.net/js-reynaud/ppa-kicad/ubuntu xenial main") incorporates your fix or not. There always seems to be a delay of a few days or even a week from when I see notices that a fix is incorporated to when I can actually verify it is working properly.

Application: kicad
Version: 5.1.0-unknown-ca7aec2~82~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.11 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-53-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON