EESchema ERC did not flag lose hanging label

Bug #1802008 reported by NhatKhai on 2018-11-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jon Evans

Bug Description

ERC did not detect or warning for net label that that not connect to anything, or connect the the net wire that lose on the other end.

Application: kicad
Version: (5.0.1)-3, release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Seth Hillbrand (sethh) on 2018-11-06
Changed in kicad:
importance: Undecided → Wishlist
status: New → Triaged
Rene Poeschl (poeschlr) wrote :

Related bugs:
 - for hierarchical pins: https://bugs.launchpad.net/kicad/+bug/1781725
 - for power ports (power symbols): https://bugs.launchpad.net/kicad/+bug/1639400

Jeff Young (jeyjey) on 2019-04-01
Changed in kicad:
importance: Wishlist → Medium
Jon Evans (craftyjon) on 2019-04-01
Changed in kicad:
assignee: nobody → Jon Evans (craftyjon)
milestone: none → 6.0.0-rc1
tags: added: eeschema erc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers