Edit Reference Highlight Has Changed

Bug #1782382 reported by Leandro Heck on 2018-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

Hitting E, over the reference field in Eeschema has changed.
Now, hole reference text is highlighted. <R?>
Previously only the question mark was highlighted like R<?>.

previews highlight option was faster since it is only necessary to hit E and type the new value.

Can this be a bug or a new feature?
If it is a new feature it is not as good as the previews way.

Using
Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build

Wayne Stambaugh (stambaughw) wrote :

This is definitely a regression.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 5.1.0

I can’t reproduce it in 5.1. Is it fixed there, or is it Linux-specific?

> On 18 Jul 2018, at 16:22, Wayne Stambaugh <email address hidden> wrote:
>
> This is definitely a regression.
>
> ** Changed in: kicad
> Status: New => Triaged
>
> ** Changed in: kicad
> Importance: Undecided => Low
>
> ** Changed in: kicad
> Milestone: None => 5.1.0
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1782382
>
> Title:
> Edit Reference Highlight Has Changed
>
> Status in KiCad:
> Triaged
>
> Bug description:
> Hitting E, over the reference field in Eeschema has changed.
> Now, hole reference text is highlighted. <R?>
> Previously only the question mark was highlighted like R<?>.
>
> previews highlight option was faster since it is only necessary to hit
> E and type the new value.
>
> Can this be a bug or a new feature?
> If it is a new feature it is not as good as the previews way.
>
> Using
> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions

Wayne Stambaugh (stambaughw) wrote :

It's broken in master. I confirmed this on windows and the bug
submitter is using ubuntu. I'm running a git bisect now to see if I can
pin down the commit that caused the issue.

On 7/18/2018 1:06 PM, Jeff Young wrote:
> I can’t reproduce it in 5.1. Is it fixed there, or is it Linux-
> specific?
>
>> On 18 Jul 2018, at 16:22, Wayne Stambaugh <email address hidden> wrote:
>>
>> This is definitely a regression.
>>
>> ** Changed in: kicad
>> Status: New => Triaged
>>
>> ** Changed in: kicad
>> Importance: Undecided => Low
>>
>> ** Changed in: kicad
>> Milestone: None => 5.1.0
>>
>> --
>> You received this bug notification because you are a member of KiCad Bug
>> Squad, which is subscribed to KiCad.
>> https://bugs.launchpad.net/bugs/1782382
>>
>> Title:
>> Edit Reference Highlight Has Changed
>>
>> Status in KiCad:
>> Triaged
>>
>> Bug description:
>> Hitting E, over the reference field in Eeschema has changed.
>> Now, hole reference text is highlighted. <R?>
>> Previously only the question mark was highlighted like R<?>.
>>
>> previews highlight option was faster since it is only necessary to hit
>> E and type the new value.
>>
>> Can this be a bug or a new feature?
>> If it is a new feature it is not as good as the previews way.
>>
>> Using
>> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions
>

Wayne Stambaugh (stambaughw) wrote :

The guilty commit is 06bf958bf1953220f813d9f8f22e0fe42e11818c.

Jeff Young (jeyjey) wrote :

So it looks like it’s platform-specific to anything-but-OSX.

In 5.1 we delay setting the initial focus until after the dialog is displayed (because OSX refuses to SetFocus to a non-visible window). However, this delay puts the SetFocus call after TransferDataToWindow, where the selection is set to the ‘?’. On OSX setting the focus doesn’t change the selection, but I’m guessing that on Win and Linux it does.

> On 18 Jul 2018, at 19:43, Wayne Stambaugh <email address hidden> wrote:
>
> The guilty commit is 06bf958bf1953220f813d9f8f22e0fe42e11818c.
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1782382
>
> Title:
> Edit Reference Highlight Has Changed
>
> Status in KiCad:
> Triaged
>
> Bug description:
> Hitting E, over the reference field in Eeschema has changed.
> Now, hole reference text is highlighted. <R?>
> Previously only the question mark was highlighted like R<?>.
>
> previews highlight option was faster since it is only necessary to hit
> E and type the new value.
>
> Can this be a bug or a new feature?
> If it is a new feature it is not as good as the previews way.
>
> Using
> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
Wayne Stambaugh (stambaughw) wrote :

Maybe the selection should be handled in a set focus event for the text
control. AFAIK, TransferDataToWindow is only called when the dialog is
initialized. Moving the selection code into a set focus event would
work anytime the control receives that focus such as tabbing through the
controls.

On 7/18/2018 3:03 PM, Jeff Young wrote:
> So it looks like it’s platform-specific to anything-but-OSX.
>
> In 5.1 we delay setting the initial focus until after the dialog is
> displayed (because OSX refuses to SetFocus to a non-visible window).
> However, this delay puts the SetFocus call after TransferDataToWindow,
> where the selection is set to the ‘?’. On OSX setting the focus doesn’t
> change the selection, but I’m guessing that on Win and Linux it does.
>
>
>> On 18 Jul 2018, at 19:43, Wayne Stambaugh <email address hidden> wrote:
>>
>> The guilty commit is 06bf958bf1953220f813d9f8f22e0fe42e11818c.
>>
>> --
>> You received this bug notification because you are a member of KiCad Bug
>> Squad, which is subscribed to KiCad.
>> https://bugs.launchpad.net/bugs/1782382
>>
>> Title:
>> Edit Reference Highlight Has Changed
>>
>> Status in KiCad:
>> Triaged
>>
>> Bug description:
>> Hitting E, over the reference field in Eeschema has changed.
>> Now, hole reference text is highlighted. <R?>
>> Previously only the question mark was highlighted like R<?>.
>>
>> previews highlight option was faster since it is only necessary to hit
>> E and type the new value.
>>
>> Can this be a bug or a new feature?
>> If it is a new feature it is not as good as the previews way.
>>
>> Using
>> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions
>
>
> ** Changed in: kicad
> Assignee: (unassigned) => Jeff Young (jeyjey)
>

Jeff Young (jeyjey) wrote :

I was going to make the SetInitialFocus stuff OSX-specific, but I like your idea better.

> On 18 Jul 2018, at 20:28, Wayne Stambaugh <email address hidden> wrote:
>
> Maybe the selection should be handled in a set focus event for the text
> control. AFAIK, TransferDataToWindow is only called when the dialog is
> initialized. Moving the selection code into a set focus event would
> work anytime the control receives that focus such as tabbing through the
> controls.
>
> On 7/18/2018 3:03 PM, Jeff Young wrote:
>> So it looks like it’s platform-specific to anything-but-OSX.
>>
>> In 5.1 we delay setting the initial focus until after the dialog is
>> displayed (because OSX refuses to SetFocus to a non-visible window).
>> However, this delay puts the SetFocus call after TransferDataToWindow,
>> where the selection is set to the ‘?’. On OSX setting the focus doesn’t
>> change the selection, but I’m guessing that on Win and Linux it does.
>>
>>
>>> On 18 Jul 2018, at 19:43, Wayne Stambaugh <email address hidden> wrote:
>>>
>>> The guilty commit is 06bf958bf1953220f813d9f8f22e0fe42e11818c.
>>>
>>> --
>>> You received this bug notification because you are a member of KiCad Bug
>>> Squad, which is subscribed to KiCad.
>>> https://bugs.launchpad.net/bugs/1782382
>>>
>>> Title:
>>> Edit Reference Highlight Has Changed
>>>
>>> Status in KiCad:
>>> Triaged
>>>
>>> Bug description:
>>> Hitting E, over the reference field in Eeschema has changed.
>>> Now, hole reference text is highlighted. <R?>
>>> Previously only the question mark was highlighted like R<?>.
>>>
>>> previews highlight option was faster since it is only necessary to hit
>>> E and type the new value.
>>>
>>> Can this be a bug or a new feature?
>>> If it is a new feature it is not as good as the previews way.
>>>
>>> Using
>>> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>>>
>>> To manage notifications about this bug go to:
>>> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions
>>
>>
>> ** Changed in: kicad
>> Assignee: (unassigned) => Jeff Young (jeyjey)
>>
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1782382
>
> Title:
> Edit Reference Highlight Has Changed
>
> Status in KiCad:
> Triaged
>
> Bug description:
> Hitting E, over the reference field in Eeschema has changed.
> Now, hole reference text is highlighted. <R?>
> Previously only the question mark was highlighted like R<?>.
>
> previews highlight option was faster since it is only necessary to hit
> E and type the new value.
>
> Can this be a bug or a new feature?
> If it is a new feature it is not as good as the previews way.
>
> Using
> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions

Jeff Young (jeyjey) on 2018-07-19
Changed in kicad:
status: Triaged → Fix Committed
Leandro Heck (leoheck) wrote :

Thanks, it is fixed.

Version: 6.0.0-rc1-unknown-da35b16~65~ubuntu18.04.1

On Thu, Jul 19, 2018 at 8:25 PM Jeff Young <email address hidden>
wrote:

> ** Changed in: kicad
> Status: Triaged => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1782382
>
> Title:
> Edit Reference Highlight Has Changed
>
> Status in KiCad:
> Fix Committed
>
> Bug description:
> Hitting E, over the reference field in Eeschema has changed.
> Now, hole reference text is highlighted. <R?>
> Previously only the question mark was highlighted like R<?>.
>
> previews highlight option was faster since it is only necessary to hit
> E and type the new value.
>
> Can this be a bug or a new feature?
> If it is a new feature it is not as good as the previews way.
>
> Using
> Version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu18.04.1, release build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1782382/+subscriptions
>

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers