assert "volDummy.empty() && pathDummy.empty()" failed

Bug #1558486 reported by Hermann Kleier on 2016-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

I am running a git-cloned debug build:

KICAD_BUILD_VERSION "(2016-03-16 BZR 6624, Git aa5a1d1)"
BOOST_VERSION 105800
wxVERSION_STRING wxT("wxWidgets 3.0.2")

on

Linux b4 4.2.0-34-generic #39-Ubuntu SMP Thu Mar 10 22:13:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I used the following steps to end up with the given message:

Start kicad: /usr/local/bin/kicad

Click on the “Schematic library editor” icon. The “Part Library Editor: no library selected” opens.

Click on the “Import component” icon. This results in the assertion. I opened another project and the result was the same.

I append: A screenshot and the backtrace provided by the application. Because the problem is reproducible and because I have a debug build it should be easy to provide more infos.

Related branches

Hermann Kleier (hermann-kleier) wrote :
Chris Pavlina (pavlina-chris) wrote :

I can't reproduce this myself, and unfortunately the backtraces emitted by the wxwidgets assertion dialogs are a bit useless. Do you know how to attach a debugger and get a proper backtrace? If so, would you be able to do that at the time the assertion dialog appears?

Changed in kicad:
status: New → Incomplete
Wayne Stambaugh (stambaughw) wrote :

I could not duplicate this but I think I figured out where the issue was and committed a fix for it in the product branch r6675. Please test this and let me know if the assertion is resolved.

Changed in kicad:
status: Incomplete → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments