OpenGL canvas doesn't highlight net on all layers

Bug #1486993 reported by Art on 2015-08-20
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
KiCad
Wishlist
Unassigned

Bug Description

When you go to highlight a net on default canvas in high contrast display mode, it is highlighted on all layers, which makes it extremely convenient to trace it. In OpenGL canvas it is highlighted only on the current layer. No bueno.

See pictures attached

Running KiCad 6097 on Windows 7 64 bit

Related branches

Art (diametrix) wrote :
description: updated
description: updated
Art (diametrix) on 2015-08-20
description: updated
Changed in kicad:
importance: Undecided → Wishlist
tags: added: cern gal
Art (diametrix) wrote :

I don't know about "importance: Undecided → Wishlist"

To me personally it would be a showstopper in switching to OpenGL flavor. I use highlight net functionality all the time and in a busy design it's a must. Clearly this feature is not functioning properly and you mark it as a wishlist item?!

On a side note, I'm getting a feeling that I'm wasting my time here submitting bug reports. It is like I saw in Dilbert comics strip I saw once (see attachment)

Maciej Suminski (orsonmmz) wrote :

Hi Art,

It was not a message that we consider your report not important, but highlighting was implemented in this way on purpose. I would like you to look at the problem from another point f view - as a developer I have already experienced dozens of cases when trying to adjust pcbnew's behavior basing on a bug report I was getting another one asking why have I changed it.

For the moment I keep it as a wishlist to see if there are other people supporting the idea, and if so - then probably it should be changed. If you prefer a comic strip: https://xkcd.com/1172/. I apologize if you feel offended, it was not my intention.

Regards,
Orson

Art (diametrix) wrote :

Orson,

You didn't offend me at all. I just completely disagree with the logic behind highlighting the net in OpenGL canvas. You normally would want to highlight a net to see where it is going or where it came from. The way it works now in OpenGL makes it completely useless. For example, I have a four layer board. I try to highlight the track that comes up from a lower layer and connects to a pad on the top layer. The same track goes on the inner layer somewhere else on the board. If I highlight it in the normal contrast mode you might still see some of it in the breaks between ground pours. But not much. I personally spend about 99% of my time in the high contrast mode. In this mode you can't see the highlighted track on other layers at all! Thus making the tool completely useless. So you implemented this Highlight Net tool like that on purpose?! The tool that doesn't really highlight a net, or at least not that you can see? You might want to change to tool name to something more appropriate then. Something like "Partial Net Highlight"

Trust me, there is going to be nobody unhappy if you change this highlight behavior.

Tomasz Wlostowski (twlostow) wrote :

Art,

There's as many opinions as the users. For instance, I sincerely hate the old way of highlighting - where the difference between a highlighted and non-highlitghted net is barely visible, especially when there are zones around. What's worse, items that are grayed out are still movable and editable (as opposed to GAL). Try editing a board with 12 densely routed layers like this.

Also, don't you think calling someone's work "completely useless" might be considered offensive?

The highlighting mechanism in GAL is different from the Legacy also because of the way OpenGL works - in legacy, all items are drawn in immediate mode, so you can just compare each item's net code with the highlight net code to determine the color when drawing. In GAL, the geometry is stored in the memory of the graphics card to speed up rendering. Per-item (as opposed to per-layer) highlight is of course possible, but needs a bit more of coding than just a dumb comparison. Given that we're already 1.5 moths late with the stable release, I wouldn't consider it a very serious bug. Or even a bug at all. This is the purpose of the wishlist. We'll implement it one day, you can speed this up by submitting a patch. If we didn't want to listen to your feedback, the bug would've been marked as invalid.

For the moment, disabling zones and using normal display mode lets you highlight an entire net on all layers with pretty decent contrast.

Tom

Art (diametrix) wrote :

Tomasz

I was not a big fan of previous highlight as well for the same reason - low contrast. However I would take low contrast any day against no visibility at all. Like I said previously - I do 99% of all of my work in high contrast mode, so your solution wouldn't work for me, even if I had been inclined to delete fills in my zones.

If a particular tool or feature is useless I call it the same. If it offends the developer, hopefully it will motivate him to improve it. I'm not being intentionally rude - just trying to provide honest feedback.

I can understand and accept the explanation that you are behind the schedule and that it would be more effort to make it work right. Just say so in the first place. What I have hard time accepting that it is the intended behavior and that's exactly how it was supposed to work.

I don't think I'm ready for this new and improved mode yet. If figured I would give it a try and help out with the bug finding while I'm at it. I just don't have the time to argue common sense issues on top of that.

firewalker (firew4lker) wrote :

Maybe it could work both ways. Controlled by an option.

Art (diametrix) wrote :

You could put a selection like that in the settings. But I still fail to understand WHY would you want to have a NET highlight tool that DOES NOT highlight the NET?

@Orson

If you are really trying to see if other people support the idea, I would suggest you would start a thread on the KiCad forum and see what feedback you get from the users. Nobody really reads these bugs reports here except for a few concerned developers.

svofski (svofski) wrote :

+1 to highlight entire net, single layer highlight is not useful to me.

Aaron (aaron-r-mcfarland) wrote :

I would also recommend highlighting the full net in high-contrast mode. I currently find I bounce in and out of GAL during layout due to the current highlight function.

Changed in kicad:
status: New → Fix Committed
Art (diametrix) wrote :

It didn't really fix much. The desired behavior would be to bring the highlighted track to the forefront, just like it is in the default mode. Currently if you have a multilayer board you still can't see the track that goes under. BTW the same goes for the normal contrast mode only in that case it is even worse.

Changed in kicad:
status: Fix Committed → Confirmed
status: Confirmed → New

Aaron, have you tried highlighting the net in GAL by Ctrl+clicking?

Maciej Suminski (orsonmmz) wrote :

Art,

Your request is going to be reconsidered during our work on UI improvements [1] draft.

Regards,
Orson

1. http://www.ohwr.org/projects/cern-kicad/wiki/UI_improvements#Layout-editor

Art (diametrix) wrote :

Thanks, Orson!

Jon Evans (craftyjon) on 2018-03-07
tags: added: missing-gal-tool
Jeff Young (jeyjey) wrote :

Seth fixed this a couple of weeks ago....

Changed in kicad:
status: New → Fix Committed
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers