Unable to edit pins in "Schematic library editor"

Bug #1431391 reported by Kiril on 2015-03-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Undecided
Unassigned

Bug Description

Since a recent system update I am unable to add or edit pins of library components in the "Schematic library editor". This is on Arch Linux with XFCE.

When I hover a pin and hit "e" or right-click and select "Edit" the editor starts acting as if a modal dialog is open, but the form with pin properties and settings doesn't show up. Instead, the editor cannot be closed and I have to kill the kicad process.

Kicad was built from bzr, r5507. The bug is reproducible with all my builds since r5464. It's also reproducible with all KiCAD projects that I tried it on. I am attaching an archive of my project anyway,

Version information:
Application: kicad
Version: (2015-03-11 BZR 5507)-product Release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1002,GCC 4.9.2,wx containers,compatible with 2.8)
Platform: Linux 3.18.6-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=OFF
         KICAD_SCRIPTING_MODULES=OFF
         KICAD_SCRIPTING_WXPYTHON=OFF
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON
         KICAD_USE_WEBKIT=OFF

Kiril (kiril-zyapkov) on 2015-03-12
tags: added: eeschema

I cannot reproduce this issue.
Are you using Ubuntu on Unity ?

Changed in kicad:
status: New → Incomplete
Kiril (kiril-zyapkov) wrote :

Sorry, I missed that. I'm using Arch Linux, system is up-to-date, building this package:

https://aur.archlinux.org/packages/kicad-bzr/

Using this under XFCE.

This is very likely caused by some dependency (wx, boost?) since it worked fine before with a build which now fails. I would provide more info/tracebacks/whatever, but I'm not sure how to obtain those.

Kiril (kiril-zyapkov) on 2015-03-12
description: updated
Kiril (kiril-zyapkov) wrote :

The bug is not reproducible under Gnome 3 on the same system. It only manifests itself with XFCE.

Can you test the rev 5512 (I just commit a fix for Unity) ?
Clearly, this bug happens only with a few Windows managers.
I was able to reproduce it on Ubuntu 10.10 with Unity.
It also depend on Eeschema is started (from Kicad or stand alone).

Kiril (kiril-zyapkov) wrote :

Yep, that fixed it. Thanks!

Changed in kicad:
status: Incomplete → Fix Committed
Jon Neal (reportingsjr) on 2015-09-25
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers