eeschema: graphic line type

Bug #1405026 reported by sugeng anto
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Wishlist
Unassigned

Bug Description

I think the graphic line in eeschema needs other type than solid line : dots, dashed, dash dot.
This is useful for drawing mechanically connected parts, eg: double potentiometer, relays, contactors, motor + encoder, etc
This also useful for drawing enclosing box outside circuits.

Tags: eeschema
Revision history for this message
sugeng anto (anthos1984) wrote :
Changed in kicad:
importance: Undecided → Wishlist
Revision history for this message
Chris Pavlina (pavlina-chris) wrote :

+1 for this. Sometimes one wants to make a self-documenting schematic, with annotations and plots and the whole nine yards!

Revision history for this message
firewalker (firew4lker) wrote :

At the moment the is only dashed line? I didn't find a way to edit the dashed line. The user should also be able to change the width of a graphic line.

Revision history for this message
Wayne Stambaugh (stambaughw) wrote :

You are correct. At some point, someone changed the line type from solid to dashed which I think was a step in the wrong direction but what do I know? The problem is that the schematic file format does not support multiple line types or widths. Since the schematic file format will change during the next development cycle, there is no incentive to change the existing format.

Revision history for this message
Nick Østergaard (nickoe) wrote :
xzcvczx (xzcvczx)
tags: removed: feature.request
Revision history for this message
Evan Shultz (evan-shultz) wrote :

Has there been any action on this in the last two years? (I assume not or there would be comments above.) Schematic symbols would also greatly benefit from having various line types. Currently we compose dashed lines as a series of short solid lines, which is lame and bloats the library files.

Revision history for this message
Wayne Stambaugh (stambaughw) wrote : Re: [Bug 1405026] Re: eeschema: graphic line type

There will be no action on this until the new schematic and symbol
library file formats are written. This would require a change to the
current schematic and symbol library file format which are going to be
deprecated. This wont happen for the stable 5 release but should happen
shortly after.

On 8/29/2017 7:31 PM, Evan Shultz wrote:
> Has there been any action on this in the last two years? (I assume not
> or there would be comments above.) Schematic symbols would also greatly
> benefit from having various line types. Currently we compose dashed
> lines as a series of short solid lines, which is lame and bloats the
> library files.
>

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Not just in Eeschema, but also in Pcbnew https://bugs.launchpad.net/kicad/+bug/594059

Revision history for this message
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision b576189a0010452886765d057455c97ded4f93a4
https://git.launchpad.net/kicad/patch/?id=b576189a0010452886765d057455c97ded4f93a4

Changed in kicad:
status: New → Fix Committed
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Yes, in Eeschema works. Missing now in Pcbnew.

Changed in kicad:
status: Fix Committed → Fix Released
Revision history for this message
leo (leo-inid-readers) wrote :

Linetype options should also be available in the symbol and footprint editor.
Why they are missing is beyond me, the file format seems to support it...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments