Keystone lower-constraints job failure due to PyMySQL==0.10.0

Bug #1888886 reported by Vishakha Agarwal
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Fix Released
High
Vishakha Agarwal

Bug Description

Changed in keystone:
importance: Undecided → High
assignee: nobody → Vishakha Agarwal (vishakha.agarwal)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (master)

Fix proposed to branch: master
Review: https://review.opendev.org/742956

Changed in keystone:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (master)

Reviewed: https://review.opendev.org/742956
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=3de085b1eb9750cb0d0d25cb468250cf34804eaf
Submitter: Zuul
Branch: master

commit 3de085b1eb9750cb0d0d25cb468250cf34804eaf
Author: Vishakha Agarwal <email address hidden>
Date: Fri Jul 24 19:58:30 2020 +0530

    Fix lower-constraint for PyMySQL

    keystone does not have any lower constraint for PyMySQL so the
    latest version 0.10.0 is picked by the job which is failing [1]
    In OpenStack, PyMySQL upper constraint is .9.3 means that version
    is tested not 0.10.0 [2] let's add PyMySQL lower constraint also
    so that we test lower-constraint job with correct lower version.

    [1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
    [2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

    Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
    Closes-Bug: #1888886

Changed in keystone:
status: In Progress → Fix Released
Revision history for this message
Matthew Thode (prometheanfire) wrote : Re: Keystone gate failure due to PyMySQL==0.10.0
Revision history for this message
Matthew Thode (prometheanfire) wrote :

does not look like it's fixed

Changed in keystone:
status: Fix Released → Confirmed
Revision history for this message
Colleen Murphy (krinkle) wrote :

This bug was about the lower-constraints job not having pymysql pinned in the lower-constraints file. Raising the upper-constraint is a different issue.

summary: - Keystone gate failure due to PyMySQL==0.10.0
+ Keystone lower-constraints job failure due to PyMySQL==0.10.0
Changed in keystone:
status: Confirmed → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (stable/ussuri)

Fix proposed to branch: stable/ussuri
Review: https://review.opendev.org/744759

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (stable/ussuri)

Reviewed: https://review.opendev.org/744759
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=300e79e93b9966e988ec92a74bf9b49b71d77d1b
Submitter: Zuul
Branch: stable/ussuri

commit 300e79e93b9966e988ec92a74bf9b49b71d77d1b
Author: Vishakha Agarwal <email address hidden>
Date: Fri Jul 24 19:58:30 2020 +0530

    Fix lower-constraint for PyMySQL

    keystone does not have any lower constraint for PyMySQL so the
    latest version 0.10.0 is picked by the job which is failing [1]
    In OpenStack, PyMySQL upper constraint is .9.3 means that version
    is tested not 0.10.0 [2] let's add PyMySQL lower constraint also
    so that we test lower-constraint job with correct lower version.

    [1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
    [2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

    Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
    Closes-Bug: #1888886
    (cherry picked from commit 3de085b1eb9750cb0d0d25cb468250cf34804eaf)

tags: added: in-stable-ussuri
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (stable/train)

Fix proposed to branch: stable/train
Review: https://review.opendev.org/745757

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (stable/stein)

Fix proposed to branch: stable/stein
Review: https://review.opendev.org/748474

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (stable/train)

Reviewed: https://review.opendev.org/745757
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=fb7d54543fd69e046a5136ca4028f4e128b947c2
Submitter: Zuul
Branch: stable/train

commit fb7d54543fd69e046a5136ca4028f4e128b947c2
Author: Vishakha Agarwal <email address hidden>
Date: Fri Jul 24 19:58:30 2020 +0530

    Fix lower-constraint for PyMySQL

    keystone does not have any lower constraint for PyMySQL so the
    latest version 0.10.0 is picked by the job which is failing [1]
    In OpenStack, PyMySQL upper constraint is .9.3 means that version
    is tested not 0.10.0 [2] let's add PyMySQL lower constraint also
    so that we test lower-constraint job with correct lower version.

    [1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
    [2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

    Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
    Closes-Bug: #1888886
    (cherry picked from commit 3de085b1eb9750cb0d0d25cb468250cf34804eaf)
    (cherry picked from commit 300e79e93b9966e988ec92a74bf9b49b71d77d1b)

tags: added: in-stable-train
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (stable/stein)

Reviewed: https://review.opendev.org/748474
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=56c95ce78598aee306b8fcdb720bbbdd8efc040f
Submitter: Zuul
Branch: stable/stein

commit 56c95ce78598aee306b8fcdb720bbbdd8efc040f
Author: Lance Bragstad <email address hidden>
Date: Wed Sep 9 13:48:30 2020 -0500

    Update amqp and PyMySQL lower constraints

    Newer versions of kombu rely on updated versions of amqp [0]. Keystone's
    lower-constraints job is failing consistently across multiple branches
    because it's referencing amqp 2.2.2 when we should be relying on a newer
    version (5.0.0+).

    You can verify this by using `pip3 check` with the lower-constraints tox
    environment.

    Without this patch, you'll likely see the test_notifications tests fail
    with something like:

      ModuleNotFoundError: No module named 'vine.five'

    Which spirals into subsequent failures mocking messaging drivers.

    This commit also fixes the lower-constraint for PyMySQL.

    keystone does not have any lower constraint for PyMySQL so the
    latest version 0.10.0 is picked by the job which is failing [1]
    In OpenStack, PyMySQL's upper constraint is 0.9.3. Version 0.10.0 is
    not tested [2]. Let's add PyMySQL lower constraint also so that we test
    lower-constraint job with correct lower version.

    Both of these fixes were proposed separate reviews in newer branches,
    but due to a circular failure, they're being proposed together. The
    amqp fix fails lower-constraints jobs because the PyMySQL issue and vice
    versa.

    [0] https://github.com/celery/celery/issues/3547
    [1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
    [2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

    Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
    Closes-Bug: #1888886
    (cherry picked from commit c495defc2bd4f2ef5a38d2a9e4d5aac5653fb406)
    (cherry picked from commit 12891a039fb1dae7ba22884cf78ad7d1faa8569d)
    (cherry picked from commit b7c3458b6f11ade0ce54889ae5f782fbac4a9a2e)
    (cherry picked from commit 255b6cdd70db654ce8112cef0b86361c34d9993b)
    (cherry picked from commit 3de085b1eb9750cb0d0d25cb468250cf34804eaf)
    (cherry picked from commit 300e79e93b9966e988ec92a74bf9b49b71d77d1b)
    (cherry picked from commit fb7d54543fd69e046a5136ca4028f4e128b947c2)
    (cherry picked from commit 32967a8105efd2a0934ab123eb10f33df7f581c5)

tags: added: in-stable-stein
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/keystone 16.0.2

This issue was fixed in the openstack/keystone 16.0.2 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/keystone 17.0.1

This issue was fixed in the openstack/keystone 17.0.1 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.