Jenkins jobs fail because of incompatibility between sqlalchemy-migrate and the newest sqlalchemy-0.8.0b1

Bug #1073569 reported by Ionuț Arțăriși on 2012-10-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Sean Dague
Folsom
Critical
Sean Dague
Glance
Critical
Sean Dague
Folsom
Critical
Sean Dague
OpenStack Compute (nova)
Undecided
Unassigned
Folsom
Critical
Sean Dague
OpenStack Identity (keystone)
Undecided
Ionuț Arțăriși
Folsom
Critical
Sean Dague
cinder (Ubuntu)
Undecided
Unassigned
Quantal
Critical
Unassigned
glance (Ubuntu)
Undecided
Unassigned
Precise
Critical
Unassigned
Quantal
Critical
Unassigned
keystone (Ubuntu)
Precise
Critical
Unassigned
Quantal
Critical
Unassigned
nova (Ubuntu)
Precise
Critical
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Jenkins jobs currently fail with this error:

09:52:21 ERROR: test_create_endpoint_404 (test_backend_sql.SqlCatalog)
09:52:21 ----------------------------------------------------------------------
09:52:21 Traceback (most recent call last):
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/tests/test_backend_sql.py", line 42, in setUp
09:52:21 self.catalog_man = catalog.Manager()
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/catalog/core.py", line 67, in __init__
09:52:21 super(Manager, self).__init__(CONF.catalog.driver)
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/common/manager.py", line 36, in __init__
09:52:21 self.driver = importutils.import_object(driver_name)
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/openstack/common/importutils.py", line 40, in import_object
09:52:21 return import_class(import_str)(*args, **kwargs)
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/openstack/common/importutils.py", line 30, in import_class
09:52:21 __import__(mod_str)
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/catalog/backends/sql.py", line 21, in <module>
09:52:21 from keystone.common.sql import migration
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/keystone/common/sql/migration.py", line 23, in <module>
09:52:21 from migrate.versioning import api as versioning_api
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/migrate/versioning/api.py", line 33, in <module>
09:52:21 from migrate.versioning import (repository, schema, version,
09:52:21 File "/home/jenkins/workspace/gate-keystone-python27/.tox/py27/local/lib/python2.7/site-packages/migrate/versioning/schema.py", line 10, in <module>
09:52:21 from sqlalchemy import exceptions as sa_exceptions
09:52:21 ImportError: cannot import name exceptions

From the sqlalchemy-migrate webpage: SQLAlchemy-migrate 0.7.2 is compatible with SQLAlchemy 0.6.x and 0.7.x.

From SQLAlchemy's 0.8.0b1 Release Notes:

[general] [removed] The “sqlalchemy.exceptions” synonym for “sqlalchemy.exc” is removed fully.(link)

Related branches

CVE References

Changed in glance:
assignee: nobody → Sean Dague (sdague-b)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/15103

Changed in cinder:
assignee: nobody → Sean Dague (sdague-b)
status: New → In Progress
Sean Dague (sdague) on 2012-10-31
Changed in nova:
status: New → Fix Committed
summary: - sqlalchemy migrate is incompatible with newest sqlalchemy-0.8.0b1
+ Jenkins jobs fail because of incompatibility between sqlalchemy-migrate
+ and the newest sqlalchemy-0.8.0b1
Changed in keystone:
assignee: nobody → Ionuț Arțăriși (mapleoin)
status: New → In Progress

Fix proposed to branch: stable/folsom
Review: https://review.openstack.org/15107

Changed in keystone:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/15099
Committed: http://github.com/openstack/keystone/commit/c53ffe59863a02861c3872fbc3190e7e536222a1
Submitter: Jenkins
Branch: master

commit c53ffe59863a02861c3872fbc3190e7e536222a1
Author: Ionuț Arțăriși <email address hidden>
Date: Wed Oct 31 14:32:04 2012 +0100

    pin sqlalchemy to 0.7

    sqlalchemy 0.8.0b1 breaks some dependencies such as sqlalchemy-migrate, pin the version until we fix them

    Fixes bug #1073569

    Change-Id: I6620276bf8f0a7cbc1d51aa226cd33c512e59a48

Fix proposed to branch: stable/folsom
Review: https://review.openstack.org/15112

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/15103
Committed: http://github.com/openstack/cinder/commit/04794c28b783193ec051e0bb1fd0293763a4a402
Submitter: Jenkins
Branch: master

commit 04794c28b783193ec051e0bb1fd0293763a4a402
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 10:10:29 2012 -0400

    pin sqlalchemy to the 0.7 series

    sqlalchemy 0.8 beta has hit mirrors, and changes dependencies, thus
    breaking jenkins. This pins it to 0.7 series until all the projects
    agree to move forward to 0.8.

    Fixes bug #1073569

    Change-Id: If11f39d311ba9ef5cb2b198c9649a8997b2a52b5

Alan Pevec (apevec) on 2012-10-31
tags: added: folsom-backport

Reviewed: https://review.openstack.org/15098
Committed: http://github.com/openstack/glance/commit/22a004da17199fecce110e73fff1c7f9ba460f31
Submitter: Jenkins
Branch: master

commit 22a004da17199fecce110e73fff1c7f9ba460f31
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 09:25:10 2012 -0400

    pin sqlalchemy to the 0.7 series

    sqlalchemy 0.8 beta has hit mirrors, and changes dependencies, thus
    breaking jenkins. This pins it to 0.7 series until all the projects
    agree to move forward to 0.8.

    Fixes bug #1073569

    Change-Id: I7b13ef48730e6499442a4a2a9d28b59e0121acf0

Changed in glance:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/15107
Committed: http://github.com/openstack/nova/commit/804f858bfc1c14f7347161975a55c79f0596a7ad
Submitter: Jenkins
Branch: stable/folsom

commit 804f858bfc1c14f7347161975a55c79f0596a7ad
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 11:25:19 2012 -0400

    pin sqlalchemy to the 0.7.x series

    sqlalchemy 0.8beta is now out and has internal changes
    which mean it's not an in place seemless upgrade. This pins
    sqlalchemy to the 0.7.x series to avoid those breaks.

    Fixes bug #1073569

    Change-Id: I35803bc2f2fe6331e18073ff923b74779a7514b5

Reviewed: https://review.openstack.org/15109
Committed: http://github.com/openstack/glance/commit/ddad2752b3afb480f5be1352cd2ef56739d3cdad
Submitter: Jenkins
Branch: stable/folsom

commit ddad2752b3afb480f5be1352cd2ef56739d3cdad
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 11:38:47 2012 -0400

    pin sqlalchemy to the 0.7.x series

    sqlalchemy 0.8beta is now out and has internal changes
    which mean it's not an in place seemless upgrade. This pins
    sqlalchemy to the 0.7.x series to avoid those breaks.

    Fixes bug #1073569

    Change-Id: Ia8976843a7e0a132fe38e80f2bcb01a16e12b8de

Reviewed: https://review.openstack.org/15110
Committed: http://github.com/openstack/cinder/commit/1c99b242e97ebc8b46e2a9175091dbe0d117a26c
Submitter: Jenkins
Branch: stable/folsom

commit 1c99b242e97ebc8b46e2a9175091dbe0d117a26c
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 11:39:40 2012 -0400

    pin sqlalchemy to the 0.7.x series

    sqlalchemy 0.8beta is now out and has internal changes
    which means it's not an in place seemless upgrade. This pins
    sqlalchemy to the 0.7.x series to avoid those breaks.

    Fixes bug #1073569

    Change-Id: If204690569eb92b9077833a5da121fc072c6dcfa

Reviewed: https://review.openstack.org/15112
Committed: http://github.com/openstack/keystone/commit/ee645e62033c1cd97cfa902c41031eb521315009
Submitter: Jenkins
Branch: stable/folsom

commit ee645e62033c1cd97cfa902c41031eb521315009
Author: Ionuț Arțăriși <email address hidden>
Date: Wed Oct 31 14:32:04 2012 +0100

    pin sqlalchemy to 0.7

    sqlalchemy 0.8.0b1 breaks some dependencies such as sqlalchemy-migrate, pin the version until we fix them

    Fixes bug #1073569

    Change-Id: I6620276bf8f0a7cbc1d51aa226cd33c512e59a48

Brian Waldon (bcwaldon) on 2012-10-31
Changed in glance:
importance: Undecided → Critical

Reviewed: https://review.openstack.org/15565
Committed: http://github.com/openstack/glance/commit/e6be0615b7c5648da2a96b4addeb11e330628685
Submitter: Jenkins
Branch: stable/essex

commit e6be0615b7c5648da2a96b4addeb11e330628685
Author: Sean Dague <email address hidden>
Date: Wed Oct 31 09:25:10 2012 -0400

    pin sqlalchemy to the 0.7 series

    sqlalchemy 0.8 beta has hit mirrors, and changes dependencies, thus
    breaking jenkins. This pins it to 0.7 series until all the projects
    agree to move forward to 0.8.

    Fixes bug #1073569

    Change-Id: I7b13ef48730e6499442a4a2a9d28b59e0121acf0

tags: added: in-stable-essex
Thierry Carrez (ttx) on 2012-11-21
Changed in glance:
milestone: none → grizzly-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-11-21
Changed in nova:
milestone: none → grizzly-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-11-22
Changed in keystone:
milestone: none → grizzly-1
status: Fix Committed → Fix Released
Changed in cinder:
milestone: none → grizzly-1
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/16648
Committed: http://github.com/openstack/keystone/commit/025b1d52e61fff4dff913fc58d0de81712b808b6
Submitter: Jenkins
Branch: stable/essex

commit 025b1d52e61fff4dff913fc58d0de81712b808b6
Author: Ionuț Arțăriși <email address hidden>
Date: Wed Oct 31 14:32:04 2012 +0100

    pin sqlalchemy to 0.7

    sqlalchemy 0.8.0b1 breaks some dependencies such as sqlalchemy-migrate, pin the version until we fix them

    Essex backport note: lower bound is not defined, Essex is known to work
    with older sqlalchemy versions e.g. precise has 0.7.4

    Fixes bug #1073569

    Change-Id: I6620276bf8f0a7cbc1d51aa226cd33c512e59a48

Changed in glance (Ubuntu):
status: New → Fix Released
Changed in glance (Ubuntu Quantal):
status: New → Confirmed
Changed in cinder (Ubuntu Quantal):
status: New → Confirmed
Changed in cinder (Ubuntu):
status: New → Fix Released
Changed in glance (Ubuntu Quantal):
importance: Undecided → Critical
Changed in cinder (Ubuntu Precise):
status: New → Invalid
Changed in keystone (Ubuntu Precise):
importance: Undecided → Critical
status: New → Confirmed
Changed in nova (Ubuntu Precise):
importance: Undecided → Critical
status: New → Confirmed
Changed in cinder (Ubuntu Quantal):
importance: Undecided → Critical
Changed in glance (Ubuntu Precise):
importance: Undecided → Critical
status: New → Confirmed
Changed in keystone (Ubuntu Precise):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in glance (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in glance (Ubuntu Precise):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in keystone (Ubuntu Quantal):
importance: Undecided → Critical
status: New → Fix Committed
Changed in nova (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in nova (Ubuntu Quantal):
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in cinder (Ubuntu Quantal):
status: Confirmed → Fix Released

Hello Ionuț, or anyone else affected,

Accepted cinder into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cinder/2012.2.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in nova (Ubuntu):
status: New → Fix Committed
Changed in keystone (Ubuntu):
status: New → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Ionuț, or anyone else affected,

Accepted glance into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glance/2012.2.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Clint Byrum (clint-fewbar) wrote :

Hello Ionuț, or anyone else affected,

Accepted keystone into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/keystone/2012.2.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Clint Byrum (clint-fewbar) wrote :

Hello Ionuț, or anyone else affected,

Accepted nova into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nova/2012.2.1+stable-20121212-a99a802e-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 2012.2.1-0ubuntu1

---------------
glance (2012.2.1-0ubuntu1) quantal-proposed; urgency=low

  * Dropped patches, applied upstream:
    - debian/patches/CVE-2012-4573.patch
    - debian/patches/CVE-2012-4573b.patch
  * Resynchronize with stable/folsom (199783ce) (LP: #1085255):
    - [49408e9] Glance image-delete HTTPInternalServerError HTTP 500
      (LP: #1075580)
    - [91aaa48] Image fails to upload to swift: TypeError: object of type
      'CooperativeReader' has no len( (LP: #1057322)
    - [a296a5b] Return 403 when admin deletes a deleted image (LP: #1060944)
    - [3e58a6a] Disallow updating deleted images. (LP: #1060930)
    - [26c8085] admins can see deleted images in v2 api (LP: #1071446)
    - [8321ca6] No exclude option to skip tests in run_tests.sh (LP: #1065758)
    - [c3bea11] Badly named stable/folsom Glance tarballs (LP: #1059634)
    - [fc0ee76] Non-admin users can cause public glance images to be deleted
      from the backend storage repository in the v2 api (LP: #1076506)
    - [90bcdc5] Non-admin users can cause public glance images to be deleted
      from the backend storage repository (LP: #1065187)
    - [7841cc9] FakeAuth not always admin
    - [ddad275] Jenkins jobs fail because of incompatibility between sqlalchemy-
      migrate and the newest sqlalchemy-0.8.0b1 (LP: #1073569)
    - [1d5c651] nosetest options cause no such option errors (LP: #1056420)
    - [ac223e2] Set defaultbranch in .gitreview to stable/folsom
 -- Adam Gandelman <email address hidden> Tue, 04 Dec 2012 09:19:35 -0800

Changed in glance (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2012.2.1-0ubuntu1

---------------
keystone (2012.2.1-0ubuntu1) quantal-proposed; urgency=low

  * Ubuntu updates:
    - debian/control: Ensure keystoneclient is upgraded with keystone,
      require python-keystoneclient >= 1:0.1.3. (LP: #1073273)
    - Dropped patches, applied upsteram:
      - debian/patches/CVE-2012-5563.patch
      - debian/patches/CVE-2012-5571.patch
      - debian/patches/fix-ssl-tests-lp1068851.patch
  * Resynchronize with stable/folsom (7869c3ec) (LP: #1085255):
    - [f9d4766] token expires time incorrect for auth by one token
      (LP: #1079216)
    - [80d63c8] keystone throws error when removing user from tenant.
      (LP: #1078497)
    - [37308dd] Removing user from a tenant isn't invalidating user access to
      tenant (LP: #1064914)
    - [bec9b68] Redo part of bp/sql-identiy-pam undone by bug 968519
      (LP: #1068674)
    - [ee645e6] Jenkins jobs fail because of incompatibility between sqlalchemy-
      migrate and the newest sqlalchemy-0.8.0b1 (LP: #1073569)
    - [094c494] Non PKI Tokens longer than 32 characters can never be valid
      (LP: #1060389)
    - [3cd343b] Openssl tests rely on expired certificate (LP: #1068851)
    - [2f9807e] Set defaultbranch in .gitreview to stable/folsom
 -- Adam Gandelman <email address hidden> Tue, 04 Dec 2012 09:19:41 -0800

Changed in keystone (Ubuntu Quantal):
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/22943
Committed: http://github.com/openstack/nova/commit/87361d34878618a0ffb1cb79bb8ec5a022c82d5f
Submitter: Jenkins
Branch: stable/essex

commit 87361d34878618a0ffb1cb79bb8ec5a022c82d5f
Author: Jeremy Stanley <email address hidden>
Date: Tue Feb 26 02:51:48 2013 +0000

    Force earlier version of sqlalchemy

    Fixes bug 1073569

    Backported from https://review.openstack.org/15097

    Set the version of sqlalchemy to be earlier than the 0.8 beta as it
    is incompatible with the latest available sqlalchemy-migrate and as
    a result run_tests.sh does not run any tests.

    Change-Id: I3cb367306c4e3801c9979bba0bd03a11fcea9aa2

Thierry Carrez (ttx) on 2013-04-04
no longer affects: glance/grizzly
Thierry Carrez (ttx) on 2013-04-04
Changed in keystone:
milestone: grizzly-1 → 2013.1
Thierry Carrez (ttx) on 2013-04-04
no longer affects: glance/grizzly
Thierry Carrez (ttx) on 2013-04-04
no longer affects: cinder (Ubuntu Precise)
no longer affects: glance/grizzly
Changed in cinder:
milestone: grizzly-1 → 2013.1
Changed in nova:
milestone: grizzly-1 → 2013.1
Changed in glance:
milestone: grizzly-1 → 2013.1

Hello Ionuț, or anyone else affected,

Accepted glance into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glance/2012.1.3+stable-20130423-74b067df-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Ionuț, or anyone else affected,

Accepted nova into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nova/2012.1.3+stable-20130423-e52e6912-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Ionuț, or anyone else affected,

Accepted keystone into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/keystone/2012.1.3+stable-20130423-f48dd0fc-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Please find the attached test log from the Ubuntu Server Team's CI infrastructure. As part of the verification process for this bug, Nova has been deployed and configured across multiple nodes using precise-proposed as an installation source. After successful bring-up and configuration of the cluster, a number of exercises and smoke tests have be invoked to ensure the updated package did not introduce any regressions. A number of test iterations were carried out to catch any possible transient errors.

Please Note the list of installed packages at the top and bottom of the report.

For records of upstream test coverage of this update, please see the Jenkins links in the comments of the relevant upstream code-review(s):

Trunk review: https://review.openstack.org/15098
Stable review: https://review.openstack.org/22943

As per the provisional Micro Release Exception granted to this package by the Technical Board, we hope this contributes toward verification of this update.

Yolanda Robla (yolanda.robla) wrote :

Test coverage log.

Yolanda Robla (yolanda.robla) wrote :

Please find the attached test log from the Ubuntu Server Team's CI infrastructure. As part of the verification process for this bug, Nova has been deployed and configured across multiple nodes using precise-proposed as an installation source. After successful bring-up and configuration of the cluster, a number of exercises and smoke tests have be invoked to ensure the updated package did not introduce any regressions. A number of test iterations were carried out to catch any possible transient errors.

Please Note the list of installed packages at the top and bottom of the report.

For records of upstream test coverage of this update, please see the Jenkins links in the comments of the relevant upstream code-review(s):

Trunk review: https://review.openstack.org/15098
Stable review: https://review.openstack.org/22943

As per the provisional Micro Release Exception granted to this package by the Technical Board, we hope this contributes toward verification of this update.

Yolanda Robla (yolanda.robla) wrote :

Test coverage log.

Yolanda Robla (yolanda.robla) wrote :

Please find the attached test log from the Ubuntu Server Team's CI infrastructure. As part of the verification process for this bug, Glance has been deployed and configured across multiple nodes using precise-proposed as an installation source. After successful bring-up and configuration of the cluster, a number of exercises and smoke tests have be invoked to ensure the updated package did not introduce any regressions. A number of test iterations were carried out to catch any possible transient errors.

Please Note the list of installed packages at the top and bottom of the report.

For records of upstream test coverage of this update, please see the Jenkins links in the comments of the relevant upstream code-review(s):

Trunk review: https://review.openstack.org/15098
Stable review: https://review.openstack.org/22943

As per the provisional Micro Release Exception granted to this package by the Technical Board, we hope this contributes toward verification of this update.

Yolanda Robla (yolanda.robla) wrote :

Test coverage log.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

James Page (james-page) on 2014-03-07
no longer affects: keystone (Ubuntu)
no longer affects: nova (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers