knetworkmanager gets disabled

Bug #514775 reported by wader on 2010-01-30
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
KDE Network
New
Undecided
Unassigned

Bug Description

I use the Kubuntu 10.04 Image from January 28.

I made all updates, the software is working i did reboot and things are just working great. I leave my laptop alone for a while and the screen is black when I come. I have to turn the laptop off and when I reboot the network manager is "disabled" and I have no clue how to get it activated again. I tried to kill the process and restart it, that did not work.

Has anyone an idea?

wader (schwickardt) wrote :

OK, I tried to fix it myself. I booted in recovery mode with networking. It found my cable and went online. I could startx and the knetmanager was still disabled. I installed WiCd and rebooted.

I can now access the internet via cable but my WiFi is not accessible. I installed aircrack-ng, since it is the only other way I know to test if my WiFi card is working. Aircrack found my card and was able to find my router.

What is going wrong here?

wader (schwickardt) wrote :

I used synaptic to get rid of three of the knetworkmanager packages. I manually set WiCd to control Wlan0 in the preferences and it started working again.

I use now WiCd instead of Knetworkmanager, I like it that way, but I would think that a small patch could help. I consider using WiCd as a workaround.

I hope this helps others, that have the same problem.

crysys (crysysone) wrote :

This happened to me today. I don't know if it's related or not but the problem did not manifest itself until after I attempted, and failed, to suspend to ram and had to do a hard boot. Running knetworkmanager manually from the command line does nothing and returns no errors. The panel icon just continues to report that network management is disabled. So I killall'd knetworkmanager and ran it with the --nofork option and am attaching a command line dump of what I got, I hope it helps.

crysys (crysysone) wrote :

http://osdir.com/ml/debian-bugs-dist/2010-01/msg07864.html

That bug seems to describe this one perfectly. The second solution presented worked for me on lucid with one caveat:

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

At this point knetworkmanager still did not work properly, I restarted the computer and it worked. Restarting the session, ie: logging out and back in, probably would have worked also but I did not try this.

Sanjaya Karunasena (sanjayak) wrote :

I had the same issue and this solution work for me. Thanks.

Lothar (lothar-tradescape) wrote :

I (and a friend) had this problem once.

Lothar (lothar-tradescape) wrote :

And the workaround in comment #4 fixed it for us.

Uwe Geuder (ubuntulp-ugeuder) wrote :

Reproducible with Kubuntu Lucid beta 2 and all updates

ii network-manager 0.8-0ubuntu3 network management framework daemon
ii network-manager-kde 1:0.9~svn1112085-0ubuntu1 KDE system tray applet for controlling Netwo

What happened:

- I run out of battery (laptop)
- I believe Kubuntu tried to suspend to disk, but that failed, the system froze
- after reboot the system tray applet just told "network manager disabled" without any (obvious) way the enable it.
- workaround in comment #4 worked (logout and login is indeed enough)

Berk_Boss (4390410-gmail) wrote :

#4 is a definite fix for this. I deleted the file and put my computer into suspended mode all night. This morning it still locked up and I had to shut my computer all the way down and reboot but the networkmanager disabled is now gone!!!

Thanks

Dhaval Patel (dhuv) wrote :

Instructions in comment #4 worked for me. Perhaps that files should be cleared out on a reboot?

Dave T. Johnson (hedgefighter) wrote :

Same problem after a failed suspend in the 10.04 final release. The solution in #4 fixed it.

Kevin Shenk (batonac) wrote :

I had the exact same problem in 10.04 after my computer mysteriously froze and I forcibly rebooted. Comment #4 fixed this for me as well. Should checking for and deleting /var/lib/NetworkManager/NetworkManager.state be integrated into the network-manager start up script?

For the average Linux newbie, this one has to be a real killer.

jkclarkson (jkclarkson) wrote :

sudo dolphin
navigate to /var/lib/NetworkManager/
open NetworkManager.state with kate
reset NetworkingEnabled=false to true
save
close kate and dolphin
reboot

I had the same issue: suspended to RAM at low batt and back without network (KNetworkManager disabled).

The workarround of comment #4 works fine.

Alassane (alassane-maiga) wrote :

There is something easier : install nm-applet. there is an option to re-enable networking :
1- open konsole
2- killall knetworkmanager
3- nm-applet &
4- disown
5- close console

right click on the nm-applet icon an enable networking

if you don't want to enconter this problem uninstall knetworkmanager

I think knetworkmanager is still lacking, we should give it some time before using it daily

Changed in kubuntu-de.org-website:
assignee: nobody → Arthur Schiwon (blizzz)
description: updated
Arthur Schiwon (blizzz) on 2010-06-27
affects: kubuntu-de.org-website → kdenetwork
Changed in kdenetwork:
assignee: Arthur Schiwon (blizzz) → nobody
MountainX (dave-mountain) wrote :

this might be relevant:

https://bugs.launchpad.net/ubuntu/+bug/555571

This fixed my problem:
    service network-manager stop
    rm /var/lib/NetworkManager/NetworkManager.state
    service network-manager start

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers