Network Management disabled

Reported by Dani Rey on 2010-04-05
376
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Lucid by crazydave
Nominated for Maverick by Kavius

Bug Description

Network Manager worked in the beginning after patching and rebooting the KNetworkManager showed "Network Management disabled". No option to enable it again was available.

The issue was caused by
  NetworkingEnabled=false
in
 /var/lib/NetworkManager/NetworkManager.state

After changing it back to
 NetworkingEnabled=true
in
 /var/lib/NetworkManager/NetworkManager.state
and running
 sudo service network-manager restart
everything worked fine again.

Full content of /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

root@ltdar2:/etc/NetworkManager# lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

network-manager:
  Installed: 0.8-0ubuntu2
  Candidate: 0.8-0ubuntu2
  Version table:
 *** 0.8-0ubuntu2 0
        500 http://ch.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: network-manager 0.8-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Mon Apr 5 09:48:24 2010
EcryptfsInUse: Yes
Gconf:

InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
IpRoute:
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.44 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.1.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager

Dani Rey (dani-rey-ch) wrote :
Hans Meine (hans-meine) wrote :

I had the same problem with a Lucid beta system.

I have no idea how the NM got disabled in the first place. Also I wonder if KNetworkManager should have an option to (re-)enable NM if it is found disabled?!

As you might have guessed, I have only just started to use NetworkManager (coming from Gentoo) and I have no idea how this enabled/disabled state is usually controlled. I cannot believe that editing a .state-file of a running daemon under /var is the right way to do this..

Kilz (kilz) wrote :

Thank you for the work around Dani! I updated today, rebooted, no internet, not even with a cable. Network manager wont start in the menu.

Dani Rey (dani-rey-ch) wrote :

@Hans Meine
Of course this is not the idea, but just a workaround. NetworkManager should not be disabled, at most it should not be used at all by switching the Network Management Backend. (see System Settings -> Advanced -> Hardware -> Network Management Backend.

@Kilz
You are welcome!

@all
I found this to happen every time a resume from suspend (to ram or disk) crashes.

Manuel Schmidt (manuelschmidt) wrote :

Hi,

i had the same problem with "Kubuntu 10.4 LTS Beta 2".

This olso only happend after a suspend crashes. After Hard Reset, no NM.

Bart (bart-schelstraete) wrote :

I had exactly the same problem:

--
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid
--

Changing /var/lib/NetworkManager/NetworkManager.state worked, thank you Dani!

Woko (wolfram-koehn) wrote :

Same problem here with "Kubuntu 10.4 LTS Beta 2", thank you Dani !
I hope this will be fixed in the final release.

Christian Mangold (neversfelde) wrote :

I can confirm.

Changed in ubuntu:
status: New → Confirmed
mtemp (mtemp) wrote :

also in the final release of Kubuntu 10.4 LTS I had that nasty bug

Andrew Black (bux23) wrote :

Yes, it still exists and it is a really unpleasent bug because it prevents me from using standby on my laptop.

Is it possible that bug #563106 (and probably also bug #549134) are duplicates of this one?

effected me as well, running Kubuntu 10.04 LTS (which was upgraded from Karmic)
the above solution worked to get networking back up and running.

the last I had the laptop on it was suspended to ram where it eventually ran out of batteries over the weekend and turned off.
this morning i booted it back up and after checking the discs on startup i came to this related issue and found this ticket.

after enabling networking...

i performed a suspension to ram and networking was still enabled upon re-entry.

i performed a suspension to disc and networking was still enabled upon re-entry.

later i can suspend to ram and remove the battery to duplicate what had last happened.

Thorsten Werner (seeadler) wrote :

Same problem is here. In my case a suspend to ram crashed while trying to suspend. After a restart the network (cable) wasn't active anymore.
Really nasty if you have no conclusion why the network isn't working.

Ditto.

ASUS P80VC laptop. System won't reawaken from suspend. After a power cycle, Network Management was disabled as described above.

Kubuntu 10.4, original RC3, later updated to release.
network-manager-vpnc - 0.9~svn1112085-0ubuntu4 (amd64)

$ lspci -v | less
...
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
        Subsystem: Intel Corporation Device 1201
        Flags: bus master, fast devsel, latency 0, IRQ 32
        Memory at fdffe000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

$ uname -a
Linux nathanael-laptop 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

--Nathanael

Ganton (ganton) wrote :

The same happened to me, and I found in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566891 people with the same case:
"I restarted my laptop because it could not be resumed: only a black screen with the shell cursor is shown on the top left."
"Network-manager-kde systray says that "network management disabled""
"This fixed my problem:
    service network-manager stop
    rm /var/lib/NetworkManager/NetworkManager.state
    service network-manager start
"

zibeltbg (zibeltbg) wrote :

Same problem is for me- Kubuntu 10.04 LTS on my desktop-after suspend to disk i don t have network. Some time this happen after suspend to ram and i do new install Kubuntu 10.04 LTS.

GordonSchumacher (eleccham) wrote :

Alas, apparently not fixed in final release - I just lost about two hours to this.

Documented in Debian base:
http://bugs.debian.org/566891

And in Arch:
http://bbs.archlinux.org/viewtopic.php?pid=666399

And SuSE:
http://forums.opensuse.org/get-help-here/network-internet/429000-network-management-disabled-after-start-11-2-a.html

I really, really hope this is an easy fix, because for some reason, installing Linux has disabled "hibernate/suspend to disk" on my laptop (in both Linux *and* Windows...!?!) so "sleep/suspend to RAM" is all I have left...

Ronald (ronald-2000) wrote :

I have had the problem today after my T61 does not come back from the suspend mode.

/var/lib/NetworkManager/NetworkManager.state

NetworkingEnabled was set to false

After I changed to true it works again

Trisha (baudie) wrote :

I had this same issue after a reboot. Both wired and wireless were disabled in terminal.
yet only the wired network in /var/lib/NetworkManager/NetworkManager.state was disabled.

Ganton's post/link fixed it.

"I restarted my laptop because it could not be resumed: only a black screen with the shell cursor is shown on the top left."
"Network-manager-kde systray says that "network management disabled""
"This fixed my problem:
    service network-manager stop
    rm /var/lib/NetworkManager/NetworkManager.state
    service network-manager start
"

Andrew (9andrey) wrote :

But what can I do if "NetworkingEnabled" is already "true" ??

Peter Antoniac (pan1nx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 524454, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

MountainX (dave-mountain) wrote :

My experience is exactly the same as comment 18

I quote:

I had this same issue after a reboot.

Ganton's post/link fixed it.

"I restarted my laptop because it could not be resumed: only a black screen with the shell cursor is shown on the top left."
"Network-manager-kde systray says that "network management disabled""
"This fixed my problem:
    service network-manager stop
    rm /var/lib/NetworkManager/NetworkManager.state
    service network-manager start
"

MountainX (dave-mountain) wrote :

When I posted my comment, I got a message that said, "Remember, this bug report is a duplicate of bug #524454. Comment here only if you think the duplicate status is wrong." So I read bug #524454. That bug does not describe my problem. This bug describes my exact problem as well as the resolution. So these do not appear to be duplicates (to me).

Scott (zephyr3-14) wrote :

Same thing happened to me running 10.04 on an Asus UL30. Took me forever to find this fix (most forums had me changing .conf files etc). The fix described above by changing (or just removing) the state variable works.

This is NOT a copy of bug #524454. You cannot right click on network manager and the only fix that worked for me (after trying dozens of things from dozens of forums) was the state variable trick. Network manager just says "unmanaged" and there is no option to click anywhere.

Leon Maurer (leon-n-maurer) wrote :

I ran in to this problem after upgrading to KDE 4.5. Thanks for the fix. This bug wasted an inordinate amount of time (couldn't fix without internet access, and it took me a while to remember how to get it from the command line), so hopefully the root cause of this can be fixed.

shaun bonner (bontauri) wrote :

i got a tricky work around..../right click on the icon an enable networking....or ya can do it the hard way

John Mathis (jrmathis) on 2010-09-02
description: updated
jtingkir (jtingkir) wrote :

Same problem here, solved with NetworkManager.state

Darkz (nate1hansen) wrote :

I have the same problem as post 18. To clarify this usually isn't a problem with "Gnomes" Network Applet, generally this happens when KDE's Applet is used. Several times i was forced to log off switch to gnome enable networking that way then revert to KDE to use my wireless. This fix should save me a lot of time. I can't fathom as to why this is being switched to false. I am running KDE 10.04 LTS, and normal Ubuntu. KDE is my default display manager.

Gary Trujillo (gst-btlonline) wrote :

This problem arose for me when my laptop went into some sort of dormant state (sleep or hibernate, I reckon). I was very pleased to find Dani's posting. For a full description of my experience, please see what I wrote at https://answers.launchpad.net/ubuntu/+question/126770 , starting with the posting that begins "Well, I have mixed results to report - and a new variable
thrown into the mix. Here's what happened."

I suspect there are other ways to get the Network Manager into this state, but I found one - do a complete purge of system power (on a laptop, in my case) when Linux is in such a dormant state, when I suspect it deliberately disables the eth0 and wlan0 devices.

frank vollmer (fvoll123) wrote :

Hello

Im a new Ubuntu user and i see people posting that

service network-manager stop
    rm /var/lib/NetworkManager/NetworkManager.state
    service network-manager start

fixes the problem but i don't have a clue to what this is. If some one would be kind enough to step by step this that would be great.

Thanks in advance

Frank

It's a bit drastic perhaps but you can fix this this problem permanently by making your /var/lib/NetworkManager/NetworkManager.state file look like so:

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

And then running this magical command as root:

chattr +i /var/lib/NetworkManager/NetworkManager.state

In case that doesn't makes sense, you're essentially fixing the configuration options and then making the file immutable (i.e not even the root user can change it)

rmada (rmada19) wrote :

hello
i have the same problem but when i try to write the first command "/var/lib/NetworkManager/NetworkManager.state"
it said permision denied

Monika Eggers (monikakrug) wrote :

@rmada: This is not a command, it is a file. You need to edit it with a text editor with root authorizations. For example (assuming you have KDE) run "kdesu kate" and enter your password. Then select File - Open and open "/var/lib/NetworkManager/NetworkManager.state". Now you can edit and save the file.

Marked this as not a duplicate of 524454, because there it is possible to enable the network by clicking on the KNetworkManager icon and enabling it. Seems to be a completely different issue (cause).

I had the same problem with Kubuntu 10.04 on my computer about a month ago (August 2010). Today it happened with my husband's computer. It happened after a reboot, not after suspend. Other than that It's exactly as described by others above:
- Both wired networking and wireless networking do not work.
- When left-clicking or right-clicking on the KNetorkManager icon, it says in gray "Netzwerkverwaltung deaktiviert" (which means network management disabled).
- There are no entries in that menu and no other point-and-click way to enable networking.
- Restarting KNetworkManager does not help.
- Rebooting the computer does not help.
- In /var/lib/NetworkManager/NetworkManager.state NetworkingEnabled is set to false.
- In the same file, WirelessEnabled is true, but WLAN does not work anyway.
- The workaround of editing /var/lib/NetworkManager/NetworkManager.state to change to NetworkingEnabled=true and then running sudo service network-manager restart works.

Sergei A. Beilin (sbeilin) wrote :

The problem still exists in 10.10 :(

By the way, the Gnome's network manager applet has a checkbox that allows the user to switch networking on and off.
Adding an appropriate functionality to KDE's networkmanager widget will give us a stable workaround for this bug: we can always turn the networking on if the systems forgets to do this ;)

Grigory Rechistov (atakua) wrote :

Have 10.04.1 Ubuntu x86_64 with KDE4 installed.

After the last suspend procedure crashed I got knetworkamanger in unusable state. Haven't tried the fixes proposed here yet.

Terry (wearenotamused) wrote :

After reading most of both this bug and bug 524454, I think this actually is a duplicate of it.

I suspect the differences in people's reported ability/inability to re-enable network management through the applet are due to the difference between the Gnome and KDE applets described in comment #33. I don't see any comments in either bug that indicate they're using KDE AND are able to re-enable it through the applet. The underlying bug--the fact that networking is left disabled after a failure to resume--is common to both reports. Gnome users just have a more convenient workaround than KDE users due to a difference in features of the applets.

If that's wrong, someone straighten me out, but in the meantime I'll mark it as a duplicate again.

Terry (wearenotamused) wrote :

Transfer your "this bug affects me" vote over to bug 524454 and maybe we'll see the fix for Lucid released soon. :)

Manders L (lorussam) wrote :

Hello,

I have been having this problem and have tried various solutions. The common solution I have tried that seems to be working for everyone else is:

sudo service network-manager stop
sudo rm /var/lib/NetworkManager/NetworkManager.state

[here is where it trips up] It reports that there is no such file or directory. Therefore I assume I already removed it, but I still have a network that is disabled.

Any thoughts?

sudharsan (14sudharsan) wrote :

i have the same problem ... im using ubuntu 9.10 but there is no file available NetworkManager.state under this location #/var/lib/NetworkManager/NetworkManager.state

but each and every time i was giving network restart after system boot..after oly i can able to acces my network. can u guide me how to automatically start network while system booting

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.