do not announce ath_pci on systems where ath5k is running

Bug #346078 reported by Tobin Davis on 2009-03-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Jockey
Medium
Martin Pitt
Ubuntu Netbook Remix
Undecided
Martin Pitt
jockey (Ubuntu)
Medium
Martin Pitt
Jaunty
Medium
Martin Pitt

Bug Description

Jockey tries to load ath_pci on Acer Aspire One system, even though ath5k is loaded at boot. If allowed, jockey will load ath_pci without first removing ath5k.

dmesg output shows that ath_pci fails to properly detect or configure this hardware:
[ 328.979229] wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
[ 328.979292] ath_pci 0000:03:00.0: PCI INT A disabled

With the ath_pci driver loaded, no wireless commands work.

Alternatively, when the default ath5k driver is enabled, NetManager lists wireless networking on the menu (not selectable), and wireless connections can be established via brute force on the command line.

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :

This screen shot is with a working wireless connection established.

Tim Gardner (timg-tpi) wrote :

Tobin - can you attach a copy of /etc/modprobe.d/blacklist-ath_pci.conf ? Note that when you swizzle drivers with Jockey you typically need to reboot.

Changed in jockey (Ubuntu):
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → In Progress
milestone: none → ubuntu-9.04
Stefan Bader (smb) wrote :

On a standard desktop Jaunty install (todays daily), I could not confirm this. The only problem is a known issue that acer-wmi prevents the rfkill to be disabled. After unloading acer-wmi wireless works. What installation base is this? Also to clearify, was the problem occuring after enabling the restricted driver?

Tobin Davis (gruemaster) wrote :

Here is the default blacklist-ath_pci.conf file.

And yes, after letting jokey swizzle the drivers to use ath_pci instead, I did reboot. Still nothing from iwconfig. Also note that wireless works manually. removing acer-wmi does appear to make wireless work properly using the ath5k module. Will retest with ath_pci.

The build is the daily jaunty-netbook-remix-i386.img. Haven't checked today's.

Martin Pitt (pitti) wrote :

Jockey doesn not "load ath_pci". On current jaunty, both ath_pci and ath5k are available by default, with blacklist-ath_pci.conf blacklisting ath_pci (which your current file does). With that file, please do a clean boot, open a terminal, and give me the output of

  lsmod | grep ath

There should be ath5k, but not ath_pci.

If ath_pci still gets loaded, we need to find out what causes this, and fix that.

Changed in jockey:
assignee: nobody → pitti
status: New → Incomplete
Martin Pitt (pitti) wrote :

If the driver itself doesn't work due to the acer-wmi problem, this is a kernel bug. I reassing this to linux. We still have the jockey task, in case something is wrong with the blacklisting.

Ideally, of course, ath5k would work on your machine, then you wouldn't need ath_pci and fiddling with the driver at all.

Matt Zimmerman (mdz) wrote :

There's no kernel issue here, so closing the kernel task. I can confirm that ath5k is loaded and *not* ath_pci by default.

I do see that Jockey pops up and suggests using the madwifi driver. Selecting this causes ath_pci to be loaded, even though ath5k is already loaded. This does seem like a jockey bug.

Changed in linux (Ubuntu):
status: In Progress → Invalid
Changed in jockey:
importance: Undecided → Medium
status: Incomplete → Confirmed
Matt Zimmerman (mdz) wrote :

I should also mention that the ath5k driver works just fine for me, and so I think jockey probably should not have prompted me at all (since I don't need any additional drivers).

Martin Pitt (pitti) wrote :

Ah, I understand. Thanks for the explanation.

Changed in jockey (Ubuntu):
status: Invalid → In Progress
Changed in linux (Ubuntu):
assignee: stefan-bader-canonical → pitti
summary: - jockey prefers non-working ath_pci over working ath5k on Acer Aspire One
- with jaunty UNR
+ do not announce ath_pci on systems where ath5k is running
Tobin Davis (gruemaster) wrote :

I retested this with the recently released 2.6.29 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/. WMI issue is not fixed in this kernel either. Will file bug against acer-wmi upstream. Recommend blacklisting it for now.

Jockey issue remains with beta image.

On Wed, Mar 25, 2009 at 11:20:28PM -0000, TobinDavis wrote:
> I retested this with the recently released 2.6.29 kernel from
> http://kernel.ubuntu.com/~kernel-ppa/mainline/. WMI issue is not fixed
> in this kernel either. Will file bug against acer-wmi upstream.
> Recommend blacklisting it for now.

Note this is bug 319825

> Jockey issue remains with beta image.

...whereas this refers to this bug (346078).

--
 - mdz

Andreas Jonsson (sonofjon) wrote :

I've had similar problems as the OP on my laptop, and I just want to point out that on my system there is also a file /etc/modprobe.d/blacklist-local.conf which blacklists ath5k. The only way I can get my system to boot with ath5k is to remove this file.

Martin Pitt (pitti) on 2009-04-01
tags: added: regression-potential
Mike O'Connell (wundbread) wrote :

on my lenovo T61
ifi0: Atheros AR5424 chip found (MAC 10.3, PHY SChip 6.1, Radio 10.2)
ath_pci: wifi0: Atheros 5212: mem=0xdf2f0000, irq=17

ath5k results in very unreliable connections and the card will even drop off the pci bus (see bug# 342409)
but Jockey didn't show the madwifi driver as an option
My network card only worked when I manually blacklisted ath5k only then did the madwifi driver option show in jockey...

I think the madwifi driver should always show if they have an atheros card with the existing "don't install unless your networking is broken" warning unless of course we can be smart enough to automatically (which it sounds like is really hard).

Martin Pitt (pitti) wrote :

trunk r534.

Changed in jockey (Ubuntu Jaunty):
status: In Progress → Fix Committed
Changed in jockey:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5-0ubuntu7

---------------
jockey (0.5-0ubuntu7) jaunty; urgency=low

  * Add support for unannounced drivers, i. e. drivers which do not cause
    --check to report newly available drivers. This is a prerequisite for
    LP #346078. (Cherrypicked from trunk.)
  * data/handlers/madwifi.py: Only announce this driver through --check if
    ath5k is not loaded. (LP: #346078)
  * debian/control: Add alternative policykit-{gnome,kde} dependencies, to
    make it possible to install -kde on GNOME or -gnome on KDE.
  * jockey-gtk: Improve default height of driver list VPane, depending on
    number of available drivers. (Cherrypicked from trunk) (LP: #291028)

 -- Martin Pitt <email address hidden> Wed, 01 Apr 2009 11:03:44 +0200

Changed in jockey:
status: Fix Committed → Fix Released
Tobin Davis (gruemaster) wrote :

LP Cleanup.

Changed in netbook-remix:
status: New → Fix Released
assignee: nobody → Martin Pitt (pitti)
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers