Comment 8 for bug 346078

Jockey doesn not "load ath_pci". On current jaunty, both ath_pci and ath5k are available by default, with blacklist-ath_pci.conf blacklisting ath_pci (which your current file does). With that file, please do a clean boot, open a terminal, and give me the output of

  lsmod | grep ath

There should be ath5k, but not ath_pci.

If ath_pci still gets loaded, we need to find out what causes this, and fix that.