[Ubuntu 18.04] USB Type-C test failed on GLK

Bug #1758797 reported by quanxian on 2018-03-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
David Hereschler Shvo
Bionic
Undecided
Thadeu Lima de Souza Cascardo

Bug Description

[Impact]
USB Type-C ports would not be seen at ls /sys/class/typec/ some times, ie, driver probe would fail. The fix just changes a timeout setting, allowing the probe to succeed in those cases there is load on the system.

[Test Case]
During boot, with the system at load, the probe would fail some times. With the increased timeout for firmware responses, that doesn't happen after many reboots.

[Regression Potential]
This would only impact systems that have this specific ACPI node. As the probe runs on a work queue, this should not impact boot time.

Description:

Platform information:
Label: GLK02SDP
Processor: Silver N5000
Bios: GELKRVPA.X64.0083.B30.1801162142
OS: Ubuntu 18.04
Kernel: 4.15.0-10-generic

Details:
Bios: system setup -> system component -> USB Type-C <enabled>

root@GLK02:~# cat /boot/config-4.15.0-10-generic | grep -i ucsi
CONFIG_TYPEC_UCSI=m
CONFIG_UCSI_ACPI=m

root@GLK02:~# ls /sys/class/typec/
root@GLK02:~#

USB Type-C ports could not be seen.

CVE References

quanxian (quanxian-wang) wrote :

this should be a regression issue.

quanxian (quanxian-wang) on 2018-04-02
tags: added: 18.04-bug
quanxian (quanxian-wang) wrote :

we ever tried
CONFIG_TYPEC_UCSI=y
CONFIG_UCSI_ACPI=y

This setting will enable type-c correctly.

information type: Proprietary → Public

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1758797

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
quanxian (quanxian-wang) wrote :

modprobe ucsi_acpi
will work. Close it as won't fix.

Anyway, I still suggest to make m to be y in the config file. Or add the module auto loaded if possible.

Changed in intel:
status: New → Won't Fix
quanxian (quanxian-wang) wrote :

reopen it to track for Canonical update.

Changed in intel:
status: Won't Fix → New

The module already has an alias that should allow it to autoload:

alias: acpi*:PNP0CA0:*

What is the output of ls /sys/bus/acpi/devices/*PNP0CA0* on such a system?
Or grep -H . /sys/bus/acpi/devices/*PNP0CA0*/modalias?

Cascardo.

quanxian (quanxian-wang) wrote :

typec on GLK will work at rate 80% in Ubuntu Final Beta.
Intel upstream provide a patch will 100% pass.

I upload this patch. Intel Upstream is working on merge this patch into mainline. The time will be not defined.

Just keep watch.

tags: added: patch
description: updated
Changed in linux (Ubuntu Bionic):
status: Incomplete → In Progress
assignee: nobody → Thadeu Lima de Souza Cascardo (cascardo)
description: updated
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Daniele Dellafiore (ildella) wrote :

Hi. I am having trouble as my USB-C do not send video to DP1.2.
Also, where 17.10 did see the external monitor, 18.04 do not.
See https://askubuntu.com/questions/1022343/usb-c-video-xiaomi-laptop-to-dell-display-no-signal for 17.10 behavior and https://www.reddit.com/r/linux/comments/8cykbd/usbc_to_displayport_video/ for 18.10.

Can this regression/issue be related to this bug?

Have you tried the kernel from -proposed?

Thanks.
Cascardo.

Daniele Dellafiore (ildella) wrote :

Tried 4.15.0-17-generic from proposed.
Nothing changed. Xrandr do not see DP connected monitor, /sys/class/typec does not existis and this is still the ucsi is still:

CONFIG_TYPEC_UCSI=m
CONFIG_UCSI_ACPI=m

Can you send us dmesg after trying to load ucsi_acpi? The output of trying to load it might be useful as well. Thank you.

sudo modprobe ucsi_acpi
sudo dmesg

Daniele Dellafiore (ildella) wrote :
Daniele Dellafiore (ildella) wrote :

no output from
sudo modprobe ucsi_acpi

What is the output of ls /sys/bus/acpi/devices/*PNP0CA0* on such a system?
Or grep -H . /sys/bus/acpi/devices/*PNP0CA0*/modalias?
And the output of cat /sys/bus/acpi/devices/*PNP0CA0*/uevent?

Daniele Dellafiore (ildella) wrote :

"No such file or directory" for all 3 commands.
In that folder there is nothing that starts with PNP0CA
There are many folders starts with PNP0C

Daniele Dellafiore (ildella) wrote :

Everything is still the same BUT now the folder /sys/class/typec exists while in comment #11 did not even existed, and that was already with the .17.18 kernel. Now with .18.19 at least the folder exists. Is also empty but I can't try connect the monitor now, will do tomorrow morning.

If there's something more I can do to provide info, just let me know. Thanks.

quanxian (quanxian-wang) wrote :

patch has been merged into upstream:
b1b59e16075f5e5da2943ce8de724ab96bc3c6c2

quanxian (quanxian-wang) wrote :

comment #8

Launchpad Janitor (janitor) wrote :
Download full text (35.7 KiB)

This bug was fixed in the package linux - 4.15.0-19.20

---------------
linux (4.15.0-19.20) bionic; urgency=medium

  * linux: 4.15.0-19.20 -proposed tracker (LP: #1766021)

  * Kernel 4.15.0-15 breaks Dell PowerEdge 12th Gen servers (LP: #1765232)
    - Revert "blk-mq: simplify queue mapping & schedule with each possisble CPU"
    - Revert "genirq/affinity: assign vectors to all possible CPUs"

linux (4.15.0-18.19) bionic; urgency=medium

  * linux: 4.15.0-18.19 -proposed tracker (LP: #1765490)

  * [regression] Ubuntu 18.04:[4.15.0-17-generic #18] KVM Guest Kernel:
    meltdown: rfi/fallback displacement flush not enabled bydefault (kvm)
    (LP: #1765429)
    - powerpc/pseries: Fix clearing of security feature flags

  * signing: only install a signed kernel (LP: #1764794)
    - [Packaging] update to Debian like control scripts
    - [Packaging] switch to triggers for postinst.d postrm.d handling
    - [Packaging] signing -- switch to raw-signing tarballs
    - [Packaging] signing -- switch to linux-image as signed when available
    - [Config] signing -- enable Opal signing for ppc64el
    - [Packaging] printenv -- add signing options

  * [18.04 FEAT] Sign POWER host/NV kernels (LP: #1696154)
    - [Packaging] signing -- add support for signing Opal kernel binaries

  * Please cherrypick s390 unwind fix (LP: #1765083)
    - s390/compat: fix setup_frame32

  * Ubuntu 18.04 installer does not detect any IPR based HDD/RAID array [S822L]
    [ipr] (LP: #1751813)
    - d-i: move ipr to storage-core-modules on ppc64el

  * drivers/gpu/drm/bridge/adv7511/adv7511.ko missing (LP: #1764816)
    - SAUCE: (no-up) rename the adv7511 drm driver to adv7511_drm

  * Miscellaneous Ubuntu changes
    - [Packaging] Add linux-oem to rebuild test blacklist.

linux (4.15.0-17.18) bionic; urgency=medium

  * linux: 4.15.0-17.18 -proposed tracker (LP: #1764498)

  * Eventual OOM with profile reloads (LP: #1750594)
    - SAUCE: apparmor: fix memory leak when duplicate profile load

linux (4.15.0-16.17) bionic; urgency=medium

  * linux: 4.15.0-16.17 -proposed tracker (LP: #1763785)

  * [18.04] [bug] CFL-S(CNP)/CNL GPIO testing failed (LP: #1757346)
    - [Config]: Set CONFIG_PINCTRL_CANNONLAKE=y

  * [Ubuntu 18.04] USB Type-C test failed on GLK (LP: #1758797)
    - SAUCE: usb: typec: ucsi: Increase command completion timeout value

  * Fix trying to "push" an already active pool VP (LP: #1763386)
    - SAUCE: powerpc/xive: Fix trying to "push" an already active pool VP

  * hisi_sas: Revert and replace SAUCE patches w/ upstream (LP: #1762824)
    - Revert "UBUNTU: SAUCE: scsi: hisi_sas: export device table of v3 hw to
      userspace"
    - Revert "UBUNTU: SAUCE: scsi: hisi_sas: config for hip08 ES"
    - scsi: hisi_sas: modify some register config for hip08
    - scsi: hisi_sas: add v3 hw MODULE_DEVICE_TABLE()

  * Realtek card reader - RTS5243 [VEN_10EC&DEV_5260] (LP: #1737673)
    - misc: rtsx: Move Realtek Card Reader Driver to misc
    - updateconfigs for Realtek Card Reader Driver
    - misc: rtsx: Add support for RTS5260
    - misc: rtsx: Fix symbol clashes

  * Mellanox [mlx5] [bionic] UBSAN: Undefined behaviour in
    ./include/linux/net_dim.h (LP: #1...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Daniele Dellafiore (ildella) wrote :

I am on 4.15.0-20-generic now installed, reboot.
Same situation as before.
1. folder /sys/class/typec does not exists
2.
CONFIG_TYPEC_UCSI=m
CONFIG_UCSI_ACPI=m
3. xrandr do not see the external DP monitor
4. Finally, this output:

$ ls /sys/bus/acpi/devices/PNP0C*

'/sys/bus/acpi/devices/PNP0C02:00':
hid modalias path physical_node power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C02:01':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C02:02':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C02:03':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C02:04':
hid modalias path physical_node power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C02:05':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C04:00':
hid modalias path power status subsystem uevent

'/sys/bus/acpi/devices/PNP0C09:00':
ACPI0003:00 driver hid modalias path physical_node PNP0C0A:00 power status subsystem uevent

'/sys/bus/acpi/devices/PNP0C0A:00':
driver hid modalias path physical_node power power_supply status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0D:00':
driver hid input modalias path physical_node power status subsystem uevent

'/sys/bus/acpi/devices/PNP0C0E:00':
driver hid input modalias path physical_node power status subsystem uevent

'/sys/bus/acpi/devices/PNP0C0F:00':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:01':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:02':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:03':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:04':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:05':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:06':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C0F:07':
hid modalias path power status subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C14:00':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C14:01':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C14:02':
hid modalias path physical_node power subsystem uevent uid

'/sys/bus/acpi/devices/PNP0C14:03':
hid modalias path physical_node power subsystem uevent uid

This means you are not affected by this bug, because you don't have the relevant hardware. Can you open a new bug, so we can track your problem?

Thank you.
Cascardo.

quanxian (quanxian-wang) wrote :

just provide the commit id in 4.17

b1b59e16075f5e5da2943ce8de724ab96bc3c6c2

Same as comment#8

Changed in intel:
status: New → Fix Released
Changed in linux (Ubuntu):
assignee: Thadeu Lima de Souza Cascardo (cascardo) → David Hereschler Shvo (shvo123)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments