[Feature] KBL - New device ID for Kabypoint(KbP)

Bug #1591618 reported by XiongZhang on 2016-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Tim Gardner
Yakkety
Undecided
Tim Gardner
Zesty
Undecided
Unassigned

Bug Description

identify what new device IDs are required for Kabypoint (KBP): HS-UART,SPI, I2C, SMBUS,SPI-NOR,NPK,xHCI,usb device, SD

Platform: Kabylake-S with Kabypoint PCH

upstream schedule: 4.9

X-HWE-Bug: Bug #1622469

CVE References

XiongZhang (xiong-y-zhang) wrote :

The latest KBP DID patches are:
HS-UART and I2C: https://lkml.org/lkml/2016/7/4/403
SPI: 704d2b0 spi: pxa2xx: Add support for Intel Kaby Lake PCH-H (v4.8)
SMBUS:http://marc.info/?l=linux-i2c&m=146945783426903&w=2
NPK: 7a1a47c intel_th: pci: Add Kaby Lake PCH-H support (v4.8)
USBD:4491ed5 usb: dwc3: pci: add Intel Kabylake PCI ID (v4.8)

description: updated
description: updated
Anthony Wong (anthonywong) wrote :

> HS-UART and I2C: https://lkml.org/lkml/2016/7/4/403
Already in linux-next (19063e1)

> SPI: 704d2b0 spi: pxa2xx: Add support for Intel Kaby Lake PCH-H (v4.8)
In mainline since 4.8-rc1

> SMBUS:http://marc.info/?l=linux-i2c&m=146945783426903&w=2
No one responded to the submitted patch, but it is trivial.

> NPK: 7a1a47c intel_th: pci: Add Kaby Lake PCH-H support (v4.8)
Already in Xenial master-next

> USBD: 4491ed5 usb: dwc3: pci: add Intel Kabylake PCI ID (v4.8)
In mainline since 4.8-rc3

Phidias (phidias-chiang) wrote :

>> HS-UART and I2C: https://lkml.org/lkml/2016/7/4/403
> Already in linux-next (19063e1)
clean picked as SAUCE

>> SPI: 704d2b0 spi: pxa2xx: Add support for Intel Kaby Lake PCH-H (v4.8)
> In mainline since 4.8-rc1
Already in 4.4.0-36

>> SMBUS:http://marc.info/?l=linux-i2c&m=146945783426903&w=2
> No one responded to the submitted patch, but it is trivial.
Backported

>> NPK: 7a1a47c intel_th: pci: Add Kaby Lake PCH-H support (v4.8)
>Already in Xenial master-next

>> USBD: 4491ed5 usb: dwc3: pci: add Intel Kabylake PCI ID (v4.8)
> In mainline since 4.8-rc3
Also in 4.4.0-36

Changed in intel:
assignee: nobody → Phidias (phidias-chiang)
Phidias (phidias-chiang) on 2016-09-12
description: updated
Phidias (phidias-chiang) on 2016-09-13
Changed in intel:
status: New → In Progress
XiongZhang (xiong-y-zhang) wrote :

Please backport the following commits into 16.10, it just add some DID and is important for KBL platform with KBL-H PCH.
https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=19063e1b0aaa857f3a7b200d8332c10511e1b21d
http://marc.info/?l=linux-i2c&m=146945783426903&w=2

Anthony Wong (anthonywong) wrote :

@Xiong, that commit is now in 16.10 as well as xenial's master-next.

XiongZhang (xiong-y-zhang) wrote :

Please backport one fix into 16.10 for i2c on KBL-H PCH:
https://lkml.org/lkml/2016/9/29/123

Changed in intel:
status: In Progress → Fix Released
status: Fix Released → In Progress
XiongZhang (xiong-y-zhang) wrote :

hi, Tim & Anthony:
   As 16.04 and 16.10 have backported I2C patch for KBL-H PCH from https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=19063e1b0aaa857f3a7b200d8332c10511e1b21d, developer found this patch has issue and send a fix patch to ML, please backport it to 16.04 and 16.10.
 https://lkml.org/lkml/2016/9/29/123

Robert Hooker (sarvatt) on 2016-10-24
Changed in intel:
assignee: Phidias (phidias-chiang) → Robert Hooker (sarvatt)
Tim Gardner (timg-tpi) on 2016-10-26
information type: Proprietary → Public
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Yakkety):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Xenial):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Zesty):
status: New → Fix Released
Robert Hooker (sarvatt) on 2016-10-27
Changed in intel:
assignee: Robert Hooker (sarvatt) → nobody
Luis Henriques (henrix) on 2016-11-08
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Yakkety):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-yakkety' to 'verification-done-yakkety'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-yakkety
tags: added: verification-done-xenial verification-done-yakkety
removed: verification-needed-xenial verification-needed-yakkety

The verification of the Stable Release Update for linux-lts-xenial has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (22.5 KiB)

This bug was fixed in the package linux - 4.4.0-51.72

---------------
linux (4.4.0-51.72) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1644611

  * 4.4.0-1037-snapdragon #41: kernel panic on boot (LP: #1644596)
    - Revert "dma-mapping: introduce the DMA_ATTR_NO_WARN attribute"
    - Revert "powerpc: implement the DMA_ATTR_NO_WARN attribute"
    - Revert "nvme: use the DMA_ATTR_NO_WARN attribute"

linux (4.4.0-50.71) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1644169

  * xenial 4.4.0-49.70 kernel breaks LXD userspace (LP: #1644165)
    - Revert "UBUNTU: SAUCE: (namespace) fuse: Allow user namespace mounts by
      default"
    - Revert "UBUNTU: SAUCE: (namespace) fs: Don't remove suid for CAP_FSETID for
      userns root"
    - Revert "(namespace) Revert "UBUNTU: SAUCE: fs: Don't remove suid for
      CAP_FSETID in s_user_ns""
    - Revert "UBUNTU: SAUCE: (namespace) fs: Allow superblock owner to change
      ownership of inodes"
    - Revert "(namespace) Revert "UBUNTU: SAUCE: fs: Allow superblock owner to
      change ownership of inodes with unmappable ids""
    - Revert "UBUNTU: SAUCE: (namespace) security/integrity: Harden against
      malformed xattrs"
    - Revert "(namespace) Revert "UBUNTU: SAUCE: ima/evm: Allow root in s_user_ns
      to set xattrs""
    - Revert "(namespace) dquot: For now explicitly don't support filesystems
      outside of init_user_ns"
    - Revert "(namespace) quota: Handle quota data stored in s_user_ns in
      quota_setxquota"
    - Revert "(namespace) quota: Ensure qids map to the filesystem"
    - Revert "(namespace) Revert "UBUNTU: SAUCE: quota: Convert ids relative to
      s_user_ns""
    - Revert "(namespace) Revert "UBUNTU: SAUCE: quota: Require that qids passed
      to dqget() be valid and map into s_user_ns""
    - Revert "(namespace) vfs: Don't create inodes with a uid or gid unknown to
      the vfs"
    - Revert "(namespace) vfs: Don't modify inodes with a uid or gid unknown to
      the vfs"
    - Revert "UBUNTU: SAUCE: (namespace) fuse: Translate ids in posix acl xattrs"
    - Revert "UBUNTU: SAUCE: (namespace) posix_acl: Export
      posix_acl_fix_xattr_userns() to modules"
    - Revert "(namespace) vfs: Verify acls are valid within superblock's
      s_user_ns."
    - Revert "(namespace) Revert "UBUNTU: SAUCE: fs: Update posix_acl support to
      handle user namespace mounts""
    - Revert "(namespace) fs: Refuse uid/gid changes which don't map into
      s_user_ns"
    - Revert "(namespace) Revert "UBUNTU: SAUCE: fs: Refuse uid/gid changes which
      don't map into s_user_ns""
    - Revert "(namespace) mnt: Move the FS_USERNS_MOUNT check into sget_userns"

linux (4.4.0-49.70) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1640921

  * Infiniband driver (kernel module) needed for Azure (LP: #1641139)
    - SAUCE: RDMA Infiniband for Windows Azure
    - [Config] CONFIG_HYPERV_INFINIBAND_ND=m
    - SAUCE: Makefile RDMA infiniband driver for Windows Azure
    - [Config] Add hv_network_direct.ko to generic inclusion list
    - SAUCE: RDMA Infiniband for Windows Azure is dependent on amd64...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (26.6 KiB)

This bug was fixed in the package linux - 4.8.0-28.30

---------------
linux (4.8.0-28.30) yakkety; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1641083

  * lxc-attach to malicious container allows access to host (LP: #1639345)
    - Revert "UBUNTU: SAUCE: (noup) ptrace: being capable wrt a process requires
      mapped uids/gids"
    - (upstream) mm: Add a user_ns owner to mm_struct and fix ptrace permission
      checks

  * [Feature] AVX-512 new instruction sets (avx512_4vnniw, avx512_4fmaps)
    (LP: #1637526)
    - x86/cpufeature: Add AVX512_4VNNIW and AVX512_4FMAPS features

  * zfs: importing zpool with vdev on zvol hangs kernel (LP: #1636517)
    - SAUCE: (noup) Update zfs to 0.6.5.8-0ubuntu4.1

  * Move some device drivers build from kernel built-in to modules
    (LP: #1637303)
    - [Config] CONFIG_TIGON3=m for all arches
    - [Config] CONFIG_VIRTIO_BLK=m, CONFIG_VIRTIO_NET=m

  * I2C touchpad does not work on AMD platform (LP: #1612006)
    - pinctrl/amd: Configure GPIO register using BIOS settings

  * guest experiencing Transmit Timeouts on CX4 (LP: #1636330)
    - powerpc/64: Re-fix race condition between going idle and entering guest
    - powerpc/64: Fix race condition in setting lock bit in idle/wakeup code

  * QEMU throws failure msg while booting guest with SRIOV VF (LP: #1630554)
    - KVM: PPC: Always select KVM_VFIO, plus Makefile cleanup

  * [Feature] KBL - New device ID for Kabypoint(KbP) (LP: #1591618)
    - SAUCE: mfd: lpss: Fix Intel Kaby Lake PCH-H properties

  * hio: SSD data corruption under stress test (LP: #1638700)
    - SAUCE: hio: set bi_error field to signal an I/O error on a BIO
    - SAUCE: hio: splitting bio in the entry of .make_request_fn

  * cleanup primary tree for linux-hwe layering issues (LP: #1637473)
    - [Config] switch Vcs-Git: to yakkety repository
    - [Packaging] handle both linux-lts* and linux-hwe* as backports
    - [Config] linux-tools-common and linux-cloud-tools-common are one per series
    - [Config] linux-source-* is in the primary linux namespace
    - [Config] linux-tools -- always suggest the base package

  * SRU: sync zfsutils-linux and spl-linux changes to linux (LP: #1635656)
    - SAUCE: (noup) Update spl to 0.6.5.8-2, zfs to 0.6.5.8-0ubuntu4 (LP:
      #1635656)

  * [Feature] SKX: perf uncore PMU support (LP: #1591810)
    - perf/x86/intel/uncore: Add Skylake server uncore support
    - perf/x86/intel/uncore: Remove hard-coded implementation for Node ID mapping
      location
    - perf/x86/intel/uncore: Handle non-standard counter offset

  * [Feature] Purley: Memory Protection Keys (LP: #1591804)
    - x86/pkeys: Add fault handling for PF_PK page fault bit
    - mm: Implement new pkey_mprotect() system call
    - x86/pkeys: Make mprotect_key() mask off additional vm_flags
    - x86/pkeys: Allocation/free syscalls
    - x86: Wire up protection keys system calls
    - generic syscalls: Wire up memory protection keys syscalls
    - pkeys: Add details of system call use to Documentation/
    - x86/pkeys: Default to a restrictive init PKRU
    - x86/pkeys: Allow configuration of init_pkru
    - x86/pkeys: Add self-tests

  * kernel invalid ...

Changed in linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Robert Hooker (sarvatt) on 2017-02-01
Changed in intel:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers