Minor UI regression in filter editor (r10957)

Bug #932474 reported by su_v on 2012-02-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Veronika Irvine

Bug Description

Regression in the filter editor dialog:

The vertical filter input sources no longer reach to the top of the list of primitives, and the connection of the top-most filter primitive visually no longer connects to an input source (see attached image). The functionality of the dialog is not affected, this is only a visual regression, apparently introduced in r10957:
Lots of gtkmm deprecation fixes
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/10957>

Tested with various GTK+ themes on
- Mac OS X 10.5.8 with GTK+/X11 2.24.4 and GTK+/Quartz 2.24.10, gtkmm 2.24.2
- OS X 10.7.2 with GTK+/X11 2.24.10, gtkmm 2.24.2

su_v (suv-lp) wrote :
jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 11.04, Inkscape trunk revision 10973.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Veronika Irvine (vmi) wrote :

I have attached a patch to filter_effects_dialog.cpp and filter_effects_dialog.h.

The fix entails setting a minimum height for the list of primitives such that the input type labels are always visible. It takes into account the font used in the input type "labels" and the size of the column header.

While looking at the code I also saw that there were some odd sizing issues in the drawing code for the input type labels so I made some minor changes there as well. The main problem in the on_expose_signal() and get_size_vfunc() methods was that the sizing of the width of the input type text "labels" did not take into account the 1 pixel border of the rectangle around the text. As a result, there were some cases where the widths were fudged (*7 instead *6) to provide enough room for the labels.

The patch has been tested on Ubuntu Linux and Windows 7.

This is my first patch to Inkscape so if I have broken any rules or missed any steps I would love to get that feedback.

su_v (suv-lp) wrote :

> This is my first patch to Inkscape so if I have broken any
> rules or missed any steps I would love to get that feedback.

Many thanks for investigating the regression and sharing the fix: no broken rules or missed steps :-)

> The patch has been tested on Ubuntu Linux and Windows 7.

Patch tested ok with Inkscape 0.48+devel r11019 on
- Mac OS X 10.5.8 with GTK+/Quartz 2.24.10, gtkmm 2.24.2
- OS X 10.7.2 with GTK+/X11 2.24.10, gtkmm 2.24.2

(the patch in its original form did not apply for me (failed for src/ui/dialog/filter_effects_dialog.h.) but I haven't figured out why - whether it's a problem with different file encodings, line endings, or white spaces diffs. Attaching the diff against r11019 used instead).

Patch still needs review by one of the devs before getting applied (I don't code C++ myself).

Changed in inkscape:
status: Confirmed → In Progress
Alvin Penner (apenner) wrote :

I had this patch applied and running on an earlier rev, I think it was probably rev 11005. I saw enough to see that it is an excellent fix, congratulations!
    Unfortunately, then I upgraded to rev 11030, and now I get a clean compile with the new patch applied, but an instantaneous crash when I start Inkscape.
    Could someone else check to see if this still runs on a recent rev?

su_v (suv-lp) wrote :

@Alvin - patch works fine for me (no crash, UI of the filter editor is now displaying the input sources correctly) with r11031 on OS X 10.7.2, FSF GCC 4.6.2, GTK+/X11 2.24.10, gtkmm 2.24.2 (see current diff attached).

Alvin Penner (apenner) wrote :

sorry about that, I think I forgot to do a btool clean, works fine now, nice job!

- committed to rev 11034

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Veronika Irvine wrote:
> This is my first patch to Inkscape so if I have broken any
> rules or missed any steps I would love to get that feedback.

Hopefully you are also aware of this one: Inkscape has a two patch rule, once you have a second patch committed, we'll grant you commit access if you're interested. Looking forward to more contributions, and many thanks again for fixing this regression! :-)

Because this regression only occurred in current trunk and never in a released version, I'm changing bug status to 'Fix Released' in accordance to <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status>.

Changed in inkscape:
assignee: nobody → Veronika Irvine (vmi)
status: Fix Committed → Fix Released
Veronika Irvine (vmi) wrote :

Thank you. That was fun and pretty easy. I will try another one.

Pétery Tamás (lazur) wrote :

In 0.92 similar bug is present which is a regression from 0.91.
When working with bit more complicated filters than a simple gaussian blur, once you open up the filter editor the connectors are often rendered all over the place.
Goes away if you resize the filter editor window.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers